PDA

View Full Version : Stock Align 100 Amp ESC


Pages : [1] 2

james1281
04-13-2009, 12:05 PM
I just spooled up for the first time yesterday and it was like the ESC went into a cut-off mode (at only 30%) just after having an irratic throttle and I wasn't moving the stick. My question is - What settings are people using on the stock Align 100 amp ESC? I programmed to default. Here are my components...

- TP Pro Power 30c 6s 5000mAh 22.2v LiPo
- Stock BEC
- Stock Motor
- Stock ESC 100 Amp
- Stock Align BEC Lipo (18c 2s 1900mAh)
- GY 611 + 9256
- BLS 253 Cyclics

I might add, I spooled up just after a bunch of radio and linkage set up so my BEC LiPo was pretty low (only had 2 lights) so I don't know if this was the cause and the low voltage alarm didn't go off in the 611. Any help is appreciated.

Thanks,

James

james1281
04-13-2009, 07:12 PM
Anyone???

Al Miessner
04-13-2009, 08:01 PM
ok was the motor stutering when you were spooling up?
low voltage may make the esc act irratically.
any more info will be useful

highpower
04-13-2009, 08:22 PM
I think once you charge everything to full it will responed normaly...I have have the esp and all settings are on default....I also think the reason your 611 alarm didn't go off is because you still have 7.6v with only 2 lights lit...hope this helps

james1281
04-13-2009, 08:47 PM
ok was the motor stutering when you were spooling up?
low voltage may make the esc act irratically.
any more info will be useful
Hi Tick,
Yes Indeed the motor was stuttering and then it went into cut-off for some reason. The big pack WAS fully charged at the time.

james1281
04-13-2009, 08:50 PM
highpower,

Your reply does help a lot. So now I know I can rule out the settings in the ESC and the low voltage of the BEC pack.

Thanks!!

RKing
04-13-2009, 11:32 PM
Wierd, that is exactly how my Align 100A speed controls act when one of the leads from one of the capacitors at the end broke off. This I experienced after quite a few flights though. I have two that are DOA now.

Heli_freak
04-13-2009, 11:34 PM
The motor stuttering is what people reported right before their Align 100amp esc stopped working. Same thing happened to me.

When you plug in your battery now do you get any peeps? If not, it is toast like so many others here on this forum.

DarkTherapy
04-14-2009, 11:53 AM
Mine did the same, stuttered and a very slow spool up, then no beeps.. flat lined.... Dead.

james1281
04-14-2009, 12:16 PM
The motor stuttering is what people reported right before their Align 100amp esc stopped working. Same thing happened to me.

When you plug in your battery now do you get any peeps? If not, it is toast like so many other here on this forum.
Anything after 25% throttle, the motor starts stuttering after about 5-6 seconds. But, I do get beeps when I plug it in. If something is bad here, that is going to be really frustrating due to the fact that the heli hasn't even left the ground yet and the ESC has only been plugged in twice total (it just came out of the box). :arggg:

SkinWalk3r
04-14-2009, 01:06 PM
james1281 (http://www.helifreak.com/member.php?u=73000) - DUMP THE ESC.....I am not kidding. This appears to be a common symptom before the ESC fails. The symptoms you are describing are exactly what happened to mine. I put it on a bench after that and removed the blades to test it. As soon as I gave some throttle it SMOKED ! I quickly disconnected everything. I was lucky this didnt happen in the air. Save yourself some heartache and dump the ESC and buy a good brand.

louw
04-14-2009, 01:56 PM
I second skinwalk
Mine burst into flames and burned to a powder in middair almost lost the hole heli.
The whole thing was over before the heli hit the ground.
Was quite spectacular to see that ball of flames and smoke fall to the ground.
louw

james1281
04-14-2009, 02:41 PM
Hello All!!

First off - Thanks For all your Support & Quick Replies!!

I have just spoken with my buddy which owns the LHS I go to for all my stuff and told him what I am experiencing. He is not only going to dig for a new Align 100amp ESC (warranty replacement that I am going to throw back in the box for a spare, if I need it) but he also told me has a Castle Creations HV85 & programmer in stock which he is going to sell me for cheap:banana, since I have been having this trouble. I hear CC ESC's are highly recommended. Is this true?

Thanks Again!!:noteworthy:noteworthy

James

DarkTherapy
04-14-2009, 02:58 PM
Yes, i switched to the CC HV-85 and it's awesome! far better than the Align rubbish.

ENDO1
04-14-2009, 02:59 PM
The motor stuttering is what people reported right before their Align 100amp esc stopped working. Same thing happened to me.

When you plug in your battery now do you get any peeps? If not, it is toast like so many other here on this forum.

+1

EXACTLY what mine did

ENDO1
04-14-2009, 03:01 PM
Anything after 25% throttle, the motor starts stuttering after about 5-6 seconds. But, I do get beeps when I plug it in. If something is bad here, that is going to be really frustrating due to the fact that the heli hasn't even left the ground yet and the ESC has only been plugged in twice total (it just came out of the box). :arggg:

Mine was brand new, right out of the box.... put a CC HV85 in it and move on...

CC Setup vids
http://helifreak.com/showthread.php?t=36194

SkinWalk3r
04-14-2009, 04:03 PM
yeppers I got the CC HV 100. Update the software and rock on.

Heli_freak
04-14-2009, 04:29 PM
Yup, I have had two Align 100amp ESC's go bad on me. I now have the CC125. Yes it may be a little over kill, but I know I'm safe. With the 650L easily spiking over a 100amps on a hard clime out, I though the 125 would be super safe.

R0t0R
04-15-2009, 02:43 PM
The Align 100A that came with my ESP kit didn't smoke on me, but after reading all these kind of threads and feeling how hot it came down, didn't want to risk my heli on the Align ESC going up in flames. Like others, I debated on going for the CC110HV ESC thinking that with guys reporting spikes of over 100A, the higher amp ESC was needed. Before ordering, I called Castle Creations and chatted with one of their tech guys for quite a while. What I learned was that the 85HV is more than capable of handling anything you can throw at it with a 650L motor. Because of the way Castle rates their ESCs, the 85HV will handle the spikes unless you are hitting spikes aproaching 200A! The 85HV is much cheaper and lighter, so I went with it over a 110HV and love it.

uniquexme
04-15-2009, 11:54 PM
how much are those CC ESC? i wonder if Align sells the ESP w/o motor and ESC. do u think scorpion ESC is good?

heli-on
04-16-2009, 05:01 AM
CC-HV85 w/usb link is about $200. A lot cheaper than ruining other parts of the heli or possibly even crashing.

Thanks Align:

http://www.helifreak.com/attachment.php?attachmentid=89286&d=1238569117

http://www.helifreak.com/attachment.php?attachmentid=89287&d=1238569117

On a bright note, I did get 40 flights out of it. Again, thank you Align.

uniquexme
04-16-2009, 09:21 AM
heli-on, omg, this is the 1st time i see something so bad. xxxx, did u show this Align? ask for a claim, who knows they might give u free new ESP kit? if they refuse, then post on every forum until they compensate u for that.

u are right, i wouldn't want that to happen to my heli... is your lipo damaged as well? i think HC super simple series are better than Align coz i have been using the 50A in my 450 for about 1yr. damn align.

Chopper Hopper
04-16-2009, 10:43 AM
I have a nip 85hv sitting waiting for a large plane.
Should I yank out the new Align esc and swap it out?
Normally when an esc goes on a plane, you lose everything, (that is why having a seperate rx batt is nice so your control surfaces still work as you're going down). :shock:

I don't wanna risk a $1200 heli set-up because of an Align esc with known problems.
On the flipside, I'd hate to retire a new 100a esc with only 5 good flights on it.

Advice please from both sides of the Align esc fence - Jim

uniquexme
04-16-2009, 10:57 AM
hmm, i m just curious, whats the difference between good ESC and cheap ESC? i.e. we compare CC85A - USD200, with say Hobbycity Super Simple 100A - USD50. Other than using an external BEC for that Super Simple 100A, and that it doesn't have governor mode, what really makes it differ? anyone?

uniquexme
04-16-2009, 11:04 AM
heli-on. forgot to ask u, whats that ESC that BBQ? is that the stock 100A in ESP kit?