PDA

View Full Version : swash help


kaz172
05-03-2009, 09:48 PM
Can anyone explain or help what might be going on when I fly my 250. it is ok with hovering. But when i am in idle up and punch the throttle the heli leans to the left and when i punch full negative collective the heli leans a little to the right and so I put it in thottle hold and just went up and down in idle up and looked at the swash carefully and it just seemed the servos were not matching up all that well but I played with the travel at full up and down and did not fix the problem it is when I punch the controls to full collective from down to up that I notice the left side seemed a to hesatate a little around center stick. Is this a sign of a sloppy swash or do you think my servos are off for some reason I have crashed twice. Thanks any help would be great thanks.

mrivers
05-03-2009, 10:35 PM
Sounds like your collective servo endpoints need to be adjusted (each one individually).

kaz172
05-03-2009, 10:57 PM
I think that is what i have done with the travel adjustments so they are right at top middle and bottom but when i move the collective fast from top to bottom around center stick the swash leans a little, very minute but when doing fast idle up and punching the collective the heli seems to want to take off to the left. Maybe the ds410 are just not all that acurate. they just seem to move alittle at different times during fast stick movements.

kyalamikid
05-04-2009, 12:34 AM
Is it always the same servo that leans? Perhaps you have one faulty. Mine have been great, no leaning at all.

Aussie_phoenix
05-04-2009, 03:41 AM
I had a similar problem. The elevator servo seemed slow to follow the others when going collective up and down. I noticed it when using a swash leveller, soon after my ESC cooked. Sure enough after some fault finding it turned out that the elev servo was overheating the ESC. Changed it out and all is now well.

mrivers
05-04-2009, 02:45 PM
I think that is what i have done with the travel adjustments so they are right at top middle and bottom but when i move the collective fast from top to bottom around center stick the swash leans a little, very minute but when doing fast idle up and punching the collective the heli seems to want to take off to the left. Maybe the ds410 are just not all that acurate. they just seem to move alittle at different times during fast stick movements.

Sounds like you front left servo is a little slow then. Check for binding (ball links, head mechanics, twisted servo case etc) or stripped gears.