PDA

View Full Version : Noob question


ridnick
07-15-2009, 11:41 AM
well i have been flying for about 2 months now. froward flight is manageable for me and landings have gotten better.

I was flying recently and at the end of my 4 min flight time on my t-rex 450 ( a flight consists of a few 4-5 pattern passes and a landing. I just repeat that for practice )
after a landing i took off and i noticed it shake quite violently. tried to land but it wann't pretty.

when i went over to it i noticed a hum coming from the elevator servo . it appeared to be stuck downward. if i un sitck it it will function normaly for a bit and then get stuck..

Is this a bad servo or striped? wondering how i should look into replaceing it ... new gears?

By the way it is the karbonite gears not the metal .hitec 65


thanks for your help

TheBum
07-15-2009, 12:37 PM
Sounds like stripped gears. I'd advise getting metal replacements.

ridnick
07-17-2009, 09:39 AM
Can i just get the metal gear set for the MG or do i have to get a new servo? I was hearing that they were the same but just the karbonite vs metal gears.

TheBum
07-17-2009, 10:16 AM
The only difference between the MG and HB servos is the gear material. So, you'll be just fine putting metal gears in your HB servos.

Bob O
07-17-2009, 10:33 AM
A buddy of mine tried to put a metal gear set in his stripped HB servo.......he had major binding with the metal gears in there and couldn't remedy it. Then I read that the gear sets weren't compatible. After THAT, I read that something special had to be done during swaping of gears to make it work properly.

I didn't bookmark any of those things I read but I'll try to dig something up.

ADDED:

http://www.helifreak.com/showthread.php?t=133070&highlight=65HB+metal+gear+set

shamen222
07-17-2009, 11:04 AM
Nice Post....:thumbup: