PDA

View Full Version : Can't change pitch curve on my DX7


mwillack
06-30-2010, 04:51 PM
I was setting up the new servos on my Trex 500 and was adjusting the arms for center. I ususally go into the pitch curve menu and set the 3 center points for 50%, that way my stick doesn't have to be exactly in the center just close. That's when I noticed I think I have a problem with my radio. No matter how I set the curve I get a totally flat curve from 0% to 100%. When I checked it on my 450 and 250 it did the same thing so it appears to be the radio. I always fly with a flat curve anyway but this should not be happening. Rebinding did nothing to correct the problem. Love to get an answer...

phoenixheli
07-01-2010, 02:28 PM
Thats odd, but unlikely the radio, just the settings. If you set a proper curve there should be no problem, unless for some reason you have your end points set very low, thus the servos wont move anywhere but around center. Recheck your settings because it's possible you changed pit/throt curves for a different idle mode instead of the current idle mode or also have the epa too low.

Norm Curves:
Throt> 0-25-50-75-100
Pitch> 45-48-50-75-100

Idle Curves:
Throt> 100-95-90-95-100
Pitch> 0-25-50-75-100

Ail EPA +100 -100
Ele EPA +100 -100
Pit EPA +100 -100

Hope that helps, but most problems are usually 95% pilot error.

:YeaBaby:

mwillack
07-01-2010, 08:00 PM
Thats odd, but unlikely the radio, just the settings. If you set a proper curve there should be no problem, unless for some reason you have your end points set very low, thus the servos wont move anywhere but around center. Recheck your settings because it's possible you changed pit/throt curves for a different idle mode instead of the current idle mode or also have the epa too low.

Norm Curves:
Throt> 0-25-50-75-100
Pitch> 45-48-50-75-100

Idle Curves:
Throt> 100-95-90-95-100
Pitch> 0-25-50-75-100

Ail EPA +100 -100
Ele EPA +100 -100
Pit EPA +100 -100

Hope that helps, but most problems are usually 95% pilot error.

:YeaBaby:
I'm not doing anything really fancy here...I've done this dozens of times with no problems. But now no matter which of my several models I choose I get a totally flat curve no matter what the settings are. If it set them all at 50% in the radio the servo will reacts as if the curve is totally flat. 0% through 100%. I know there should be no problems but there are. This would not normally bother me as I always use flat curves anyway, it's just that I am getting flat curves no matter what the setting are. This could be a bad accident waiting to happen. I might try to create another model from scratch just to see what happens. The part that has me totally baffeled is the fact that every other model setup that I had prior to creating this new one reacts the same way - flat pitch curves only...I can't wait to see how this turns out...:lol:

75scoutII
07-01-2010, 08:55 PM
I'm not following what you are trying to describe. Post each setting you have in the radio, ie. pos L = 0, etc.

Also check to make sure that you don't have the mid points on inh (inhibit).

mwillack
07-02-2010, 08:55 AM
Thats odd, but unlikely the radio, just the settings. If you set a proper curve there should be no problem, unless for some reason you have your end points set very low, thus the servos wont move anywhere but around center. Recheck your settings because it's possible you changed pit/throt curves for a different idle mode instead of the current idle mode or also have the epa too low.

Norm Curves:
Throt> 0-25-50-75-100
Pitch> 45-48-50-75-100

Idle Curves:
Throt> 100-95-90-95-100
Pitch> 0-25-50-75-100

Ail EPA +100 -100
Ele EPA +100 -100
Pit EPA +100 -100

Hope that helps, but most problems are usually 95% pilot error.

:YeaBaby:
I tried resetting the model and starting from scratch and also created a new model and it is doing the same thing - flat pitch curve no matter what I set it for. I used your example of 40-48-50-75-100...it reacts as 0-25-50-75-100...this is starting to really baffle me...:confused:

I tried to set it at 50% across the board and I still got the flat curve 0-100. I'm afraid to fly with this radio. Is there a master reset on it that will make it like factory new?

What has me very nervous is the fact that all the other settings in my radio that have been there for a long time have the same symptom. The weather this weekend will be awesome so I hate to miss out. I also hate to turn my 500 into a lawn dart...help!

N017RW
07-02-2010, 09:28 AM
What are your swash mix settings?

Could the Pitch be set to zero% some how?

mwillack
07-02-2010, 10:30 AM
What are your swash mix settings?

Could the Pitch be set to zero% some how?
Wrong wording, sorry. I meant zero stick to full stick...50% being 0 pitch.
My totally flat curve is 0-25-50-75-100. I want the 3 center points to be 50, temorarily, so where ever I put my stick in that range I always had zero pitch. It makes centering the servo arms sooo much easier. Think I learned that on this site. :thumbup: BUT when I do that the servo goes smoothly through it's whole range. I am very concerned that I am about to have a major crash if something else is wrong than just this. Does this all make sense? :confused:

N017RW
07-02-2010, 02:05 PM
OK, well many refer to that curve setting as being linear as opposed to flat. Now I understand.

The next question is are you changing the curve that corresponds to the flightmode you have selected?

I did see that phoenixheli mentioned this in a previous post but you did not confirm it.

phoenixheli
07-02-2010, 03:26 PM
Btw, a flat curve would be like 50-50-50-50-50 or 75-75-75-75 or 100-100-100-100, etc. A 0-25-50-75-100 is a linear curve.

Verify that you don't have t. hold on, as this will open up a can of worms and have the heli unplugged at this time.

Flip your flight mode switch to norm, then goto the pitch curve menu, make sure it says norm with 45-48-50-75-100 then goto norm throt curve and check for 0-25-50-75-100. Expo should be INH.

Next, flip to idle1(st-1) and goto the pitch curves for st-1 and make sure it says st-1 with 0-25-50-75-100 then goto st-1 throttle curve and check for 100-95-90-95-100. Expo should be INH.

Now go to idel1(st-2) and goto the pitch curves for st-2 and make sure it says st-2 with 0-25-50-75-100 then goto st-2 throttle curve and check for 100-95-90-95-100. Expo should be INH.

Goto the thold menu and make sure the pitch menu says 0-25-50-75-100 then goto throttle curve for t hold and verify it's 0.

If these are correct then goto the travel adjust menu and make sure you have 100 and 100 for each cyclic servo for each throw direction, ail, ele and pit.

If these are correct, goto the swash mix menu and verify that you have atleast 60 for each axis, ail, ele and pit. You will need to check for binding before flight and tweek the swash mix for max pit and swash angle before flight.

Now, flip back to normal, verify that t hold is still off and test out the heli. If this doesn't work, then I don't know what is causing your problem.

Below is an example of an idle1(st-1) throttle curve(not exactly typical), a swash mix screen and travel adjust(epa) screen.

75scoutII
07-02-2010, 09:18 PM
Ah, the dreaded throttle hold. Bet you money the throttle holds on, and when he's adjusting the points, its not moving, cause he's not in the mode he's adjusting.

Also, if you to are adjusting a postion, and the stick isn't over that position you dont' see any direct movement of the swash/servo while you are adjusting it.

I think those might be some of your caveats.

Also, a flat/linear line isn't a curve at all. :YeaBaby:

Jason.

mwillack
07-03-2010, 05:24 AM
Ah, the dreaded throttle hold. Bet you money the throttle holds on, and when he's adjusting the points, its not moving, cause he's not in the mode he's adjusting.

Also, if you to are adjusting a postion, and the stick isn't over that position you dont' see any direct movement of the swash/servo while you are adjusting it.

I think those might be some of your caveats.

Also, a flat/linear line isn't a curve at all. :YeaBaby:

Jason.
The DREADED Throttle Hold...you guys are sooo right. Here's how this problem originally started. When I was first building my 450 a while ago I set the 3 center points on my pitch "curve" to 50 so any slight movement in the stick would not be translated into servo movement when I was attaching the arms. BUT at that point in the assembly I did NOT have the motor plugged in so it was NOT in Throttle Hold. Both of your comments, and phoenixheli - thanks for the great details, got me to thinking about that. I went into the settings on my radio and set the "curve" for TH to the 0-50-50-50-100 like I was trying to do and presto! Works like a charm. It's hard to believe that this was the problem. When ever I have used these settings in the past it was during the construction phase BEFORE I had the motor connected. I feel like an idiot for not seeing the forest for all the trees. Thanks so much for all the help. Next time I will try to think a little harder and longer before I get on here and start complaining that my radio being messed up. Phoenixheli, you were right...most problems are 95% pilot error! :thumbup: ("Flat Curve"...isn't that like "Semi-Boneless"?)

mwillack
07-03-2010, 05:28 AM
Thanks for all the help! I would be lost without this forum. This link usually expalins all my MY posts...:)

http://www.youtube.com/watch?v=1u-I0D9ReqI

75scoutII
07-03-2010, 07:35 PM
No biggie, I've done the same thing before when I was trying to setup pitch, when I read phoenixheli's post, it hit me.

Glad you got it all sorted out.

Jason.

phoenixheli
07-05-2010, 12:45 AM
No problem. Wow, I was right for once, lol.......

Just smack your head off a brick wall a few times, it will either work or you will start to think the problem out. You should have see the problem I had when I first got a dx7 and couldn't comprehend how to use gyro gain without using the gyro gain menu.....wow I felt very stupid when it all clicked.