PDA

View Full Version : DETRUM GY48V Help.


BIGTRUX
07-05-2010, 05:42 PM
Hey guys here is what is going on I have a T-REX 450 SA that has some parts added to it. full metal head and tail were the first thing and then the plastic belt pulley had to go other than that it is mostly stock it has the following

Align 430L 3550KV motor with RCE-BL35G Speed control. 11T pinion.
HiTec HS-65MG x 3 for cyclic.
Futaba S9650 working the tail.
I have a custom radio tray I made out of lexan holding the AR6000 Right below the tail boom block.
335mm fiber main blades and the stock black tail blades.

Ok so now for the problem.

when I am first spinning up the heli continually rotates till I get it off the ground then it seems to be 95% good. I have to bump the tail about every 3 to 5 seconds to hold it strait. and man forget it if I do any thing with the throttle. I gave it full collective strait up and it spun almost 2 full rotations before I could regain control. also when I flip to stunt mode it does the same it gets about 1/4 to almost 1/2 turn till it stops.

Is this just becuase I have a cheap gyro or is this normal. also I have my gear setting at 85 that is where the tail wag just starts to go away. any how any thoghts on this or do I just need to drop the money on an expensive gyro? Is that lil bump every couple seconds normal and I am asking to much? also I rebinded my radio today and it seemed to help but did not completely lose the constant drift issue?:crash

blazingJ
07-17-2010, 03:38 AM
i have a detrum gy48v with the raiden dma-016 servo and it holds pretty good.sounds like the delay trimmer is not at zero.another thing to think about is your esc gov..i dont have that gov.but if not setup right can cause bad tail kick.:wow2: