PDA

View Full Version : Power problems ?


billiano
08-03-2010, 07:14 PM
Hi to all of you.

My set up is 3 JR DS8917 HV an Align DS610 for throttle and a JR DS8900 for tail.
I also use a FBL gyro from Germany AC-3X a Spectrum 2.4G AR-9000 RX(or advise me to replace with JR 921 9CH 2.4G RX) a Scott Gray Reactor-X regulator and
a Thunder Power 2S2P 5300Mah 7.4V RX battery and finally an Aerospire MultiGov.


My heli is being repaired at this moment but as I was flying at 9ft high I switched to Idle2.
The heli reacted like crazy and screwed into ground as if I had minus pitch.
Just for the story my fail safe preset is the same as Normal in low stick position which means -4 pitch and throttle hold.

What is your opinion....
Is it entered failsafe mode due to vibration or it was a fade out due to power drain?

Finally what do you think of plugging a second battery in the RX just an old 4.8V NiMH battery to be my alternative?

And last but not least is it possible that Reactor-X was reset due to overheat or over-current?

Bill

P.S: I got from Mr Kasama the updated part for Swashplate drive arm :happyd
it's KSM10-H10 (new) and KSM10-90H05(old)


EVERY HELP IS WELCOME....:shock:

chasers
08-03-2010, 10:18 PM
How do you go about getting the updated parts from Kasama? Do we email him or??

Vetequk
08-04-2010, 02:52 AM
Email him with the serial number of you model & he will reply.

billiano
08-04-2010, 02:56 AM
I got the update part by chance .I asked for the swashplate drive arms set like the one on every picture but he sent me the updated one.

Mercuriell
08-04-2010, 04:42 AM
POsts moved out of Technical Tips sticky !

I think your problem is not power supply related - the fact that it happened just when you switched to idle2 suggests that your pitch curve was different at that throttle stich position - maybe a linear curve whereas you have less negative in normal mode - if your heli is still functional try flicking conditions and seeing if pitch changes - otherwise check out you pitch curves

billiano
08-04-2010, 09:00 AM
John how are you?

I believe it has to do with gyro vibration for that reason I will place the updated gyro
plate mount KSM10-F29 .
And may god be with us.because the gyro unit its light.

Or during changing to ID 2 I moved my stick just below middle and the heli crashed but I still cannot believe that.:arggg:,it doesn't seems correct.

Anyway I was thinking of getting also from JR that little machine that shows fade outs & frames lost of signal.

Although its been said a few times John what are your headspeeds?

Thanx Bill

Mercuriell
08-05-2010, 02:54 AM
HI Bill - let us know how you go !!! I run 1950 and 2050 on the Faifa and 1850 and 1950 on the nitro

billiano
08-05-2010, 04:02 AM
During my last flight I had 1750 and 1850.
But now I will try to balance the moving parts one more tie better

billiano
09-08-2010, 06:06 PM
Hi to all of you ...:hug:
Firstly I had increased vibes because of my stupidity and placing the piston mark of my YS-91 SR at 2o'clock while the correct is at 7 o'clock.(Influenced by my OSMAXs):arggg:
After some searching I found the correct way.
I trimmed my new frames in the tank area and finally I had my gears mess very smooth.
And last I got my Kasama Gyro Mount.
Now I have no vibes at all.:banana
I set the heli up without fuel mix and gov RPM.(Multigov)
I did some flights and its quite like a typewriter.:Bang
Temps are correct and now in the next flight I will set also the Gov.

The heli even without the Gov has a lot of power.
I hope that I will love my heli all the way from the beginning.:wow2:

billiano
09-12-2010, 06:03 PM
I did some setting on my MultiGov at 1800 IDL1 and 1900 IDL2.
The heli is awesome.
Now the only thing I have to do it's to improve my moves.