PDA

View Full Version : First impressions with the T-100, not so good


Pages : [1] 2

superjoe83
02-26-2011, 04:31 PM
the mail lady just dropped mine off about 45min ago, overall quality looks good, very good packaging, no damaged parts etc.

after charging the batts i was very excited to do a few flights to see how it performs compared to my mSR

I followed the instructions to bind, then i restarted the tx and heli to make sure it was bound correctly, it was

here comes the bad news.....

First flight was good, no trim needed, very stable like the msr, but it feels like there is about 80% expo on the rudder, you have to move the stick a good 1/4 inch before the tail responds, which im sure i will get used to, but I don't like it, the cyclic controls felt good, piro rate is pretty even either way, so after doing about a minute flight i landed so that im not working the motors to hard in their early life

second flight ended in a crash because of a mechanical issue, i pushed the elevator forward to fly around the house, when i released it the heli kept going in the same direction and acted like i didn't let off the stick, so i ran out of room and it hit a wall, no damage. When i came to it i could hear faint servo buzzing, and the elevator servo would not respond to commands, i couldn't move it manually, it seemed to be jammed up.

so on this 5 minute old heli I get to take the 5in1 board off, pry up a potentiometer to get to a screw to take off the servo cover, i couldn't find any broken teeth and the servo motor spins fine, i put it back together and it spins fine by hand, i guessing a piece of plastic from manufacturing got stuck in one of the servo gears (im hoping anyway) im in the process of putting it back together, i will update this if i have any more issues :arggg:

CCbusa05
02-26-2011, 04:43 PM
THANKS Superjoe, for the update. Please let us know if the servo problem has been rectified. Heres hoping that you're having successful normal flights from here on out! I'll be sure to look mine over very carefully BEFORE putting her in the air!

superjoe83
02-26-2011, 07:55 PM
I hope that there is some aftermarket support for this thing, because as of right now my msr flys 10x better :(

i have the links on the longer swash balls, and the links on the outer servo arm holes and my msr has more control authority. For screwing around in the house its fine, but get outside and it feels heavy and slow compared to the msr, oh well....... and the 1/2 in. of deadband in the rudder stick is not helping any
:bawl:bawl

oh, and the elevator servo seems to be working fine so far, but the aileron servo stuck once also, but i was able to wiggle it and it freed up :mad: i have a feeling that these servos are going to be the biggest issue with these helis, or i just got a lemon :mad:

CCbusa05
02-26-2011, 11:40 PM
I'll let you know how mine compares when I get it. If indeed yours is a lemon, let's hope that the hobby shop you ordered it from will make it right with you!!

rcelik
02-27-2011, 03:52 PM
Im new to helicopters, but I agree that there is alot of play in the controls. The heli feels very sluggish, it does not respond as i expected. I should have listen to the guy at the hobby shop and bought the MSR.

superjoe83
02-27-2011, 04:54 PM
some more bad news, about 10-15 flights so far and the tail motor is taking a crap, works ok for the fist 30 seconds then has little holding power, just hovering holding full right rudder and it still piros to the left :mad: and ive checked the obvious, no hair on tail shaft, tail blade is not bent and tracks perfect :( looks like this might end up being an expensive shelf ornament :(

antmeeks
02-27-2011, 06:13 PM
some more bad news, about 10-15 flights so far and the tail motor is taking a crap, works ok for the fist 30 seconds then has little holding power, just hovering holding full right rudder and it still piros to the left :mad: and ive checked the obvious, no hair on tail shaft, tail blade is not bent and tracks perfect :( looks like this might end up being an expensive shelf ornament :(

Can't say I'm surprised... although it sounds like you may have got a lemon.

But if the T100 has these kinds of QC issues after the length of time Align has been working on it, imagine what kind of problems their new T100 "3G" will have if they're supposedly going from CG mockup to "production" in two months, like some people on this board have asserted.

All of these same people banter back and forth about how Align helis are the best on the market - but yet, I never hear of anyone saying that of a stock Align. All of these Align guys have to trump it up with mods and aftermarket parts before it performs to their liking.

I have a feeling that we may be seeing some chinks in Align's armor.

CCbusa05
02-27-2011, 06:37 PM
Yeah...........I haven't even received mine yet and I'm already experiencing buyer's remorse. I'm more of a scale type flier and can't see me ever wanting to move on to the next level (mCP X, 100SG, etc); but I was hoping the Trex 100 would have at least flown as well as my MSR does. I based my purchase on what I've seen on youtube, you know, just the basic relaxed living room type flying session. But heck, if the controls are as sluggish as you guys are saying, maybe I should have spent my money on another MSR. I usually buy two or three of the same model if I'm pleased with performance, durabilty, etc..
Anyway, gosh, I hope that Align has a warranty policy in place for guys like the OP and the problems he is having!!

asm54
02-28-2011, 06:00 PM
Thanks Joe,

The main reason that I bought/ordered the 100 was because of the servos ( I have 2 MSR's) and I do not know if I am going to gamble and say that your unit was a lemon.
If the servos started giving you trouble in the beginning and the tail motor is crapping out in 15-30 flights and thr MSR handles 10x better what do I need this for.
My question is (and I am assuming that you have contacted Align) I am VERY interested in what they had to say?

Thx
Alan

rcelik
02-28-2011, 06:19 PM
I have the same problem as Joe with the rudder. The Heli piros to the left even with the trim all the way to the right. Do you think we can send the Heli's back to Align for a replacement?

I am extremely disappointed.

urs14
03-01-2011, 01:19 AM
Hello! same mine the tail motor can't stay long. after 10 flights it doesn't hold.

CCbusa05
03-01-2011, 07:39 AM
Not looking so good for the Trex100! I should be getting mine today from Ultimate Hobbies and their return policy is honored only if the package is unopened. I will not open mine and will be returning it. I hope the rest of you can get satisfaction under Align's warrantee policy, if one in fact exists.:mad:

EDIT: I emailed Ultimatehobbies.com to request a RMA # and a request to not have to pay the 20% restocking fee, due to the nature of this new defective product. I told them in so many kind words that I intend to share my "experience" with them with this site as well as RCgroups.com.
I'll keep everyone updated.......

WBFAir
03-01-2011, 07:47 AM
Just a thought as I don't own one or am their to see what is happening but on these tail motors, have you checked to see if the blade is just spinning on the shaft a bit.

If you think it might be, perhaps a try just a tab of contact cement or something like that might be help?

Part of why I think this too is that is almost sounds like once the motor is getting hot, that might be expanding the plastic and letting it come a little looser.

BL1STER
03-01-2011, 08:05 AM
Hello! same mine the tail motor can't stay long. after 10 flights it doesn't hold.
are you running it back to back flying if so the motor is over heating

CCbusa05
03-01-2011, 11:14 AM
One of the guys over on RCgroups has apprx 50 flights on his Trex100 and still going strong. :arggg:

v58fuy
03-01-2011, 03:54 PM
What do you expect from Align, great innovators just forget quality along the way - shame really.

David

antmeeks
03-01-2011, 04:26 PM
What do you expect from Align, great innovators just forget quality along the way - shame really.

David

And by "innovators" you mean "copy cats" right? ;)

mmee1992
03-02-2011, 02:04 AM
Hello all,

I had a problem with the first 100 I bought. When the heli would get about 10-15 feet away from the TX it would lose signal. So I got another from Hobby People and this one is great. Anyways, I will keep you all posted on how it does 10-15 flights in.

Matthew

aeroplay
03-02-2011, 01:32 PM
the mail lady just dropped mine off about 45min ago, overall quality looks good, very good packaging, no damaged parts etc.

after charging the batts i was very excited to do a few flights to see how it performs compared to my mSR

I followed the instructions to bind, then i restarted the tx and heli to make sure it was bound correctly, it was

here comes the bad news.....

First flight was good, no trim needed, very stable like the msr, but it feels like there is about 80% expo on the rudder, you have to move the stick a good 1/4 inch before the tail responds, which im sure i will get used to, but I don't like it, the cyclic controls felt good, piro rate is pretty even either way, so after doing about a minute flight i landed so that im not working the motors to hard in their early life

second flight ended in a crash because of a mechanical issue, i pushed the elevator forward to fly around the house, when i released it the heli kept going in the same direction and acted like i didn't let off the stick, so i ran out of room and it hit a wall, no damage. When i came to it i could hear faint servo buzzing, and the elevator servo would not respond to commands, i couldn't move it manually, it seemed to be jammed up.

so on this 5 minute old heli I get to take the 5in1 board off, pry up a potentiometer to get to a screw to take off the servo cover, i couldn't find any broken teeth and the servo motor spins fine, i put it back together and it spins fine by hand, i guessing a piece of plastic from manufacturing got stuck in one of the servo gears (im hoping anyway) im in the process of putting it back together, i will update this if i have any more issues :arggg:
Just received mine about an hour ago. Damn, it's fun to fly. Hopefully, I don't have problems with it. Batteries charge fast, easy to put together and all I needed was to add a bit of trim. I'll look closely at that to see if it is really necessary. At the expense of reiteration, damn it's fun to fly.

BL1STER
03-02-2011, 04:09 PM
good things come to those who wait and I'm still waiting :(

Brick
03-05-2011, 10:55 PM
just this week.....i have learned "nose in" hovering on my mSR !!!!!

just sayin' ;)

mmee1992
03-06-2011, 01:24 AM
Hey,

Just wanted to give an update. I have probably flown my trex100 going on 30 times and still no problems. It flies very well and I would recommend it to anyone.

Matthew

Ludde
03-06-2011, 04:03 PM
duh.. nm..
btw isnt there a way to delete posts? am I blind?

Vuhuyhoang
03-06-2011, 07:29 PM
should i buy t100 or solo pro ? already have msr

Mojappa
03-07-2011, 10:19 AM
duh.. nm..
btw isnt there a way to delete posts? am I blind?

No, we can only go back and edit it, deleting the original post but the box will still show. Also, after 15 days the post is made "permanent" meaning you can no longer edit it.