PDA

View Full Version : Broken elevator linkage


hotstart
05-09-2011, 06:46 AM
Hey just asking on machines fourth flight Was doing nothing crazy just some rolls forward flips a couple of circuits Then went into a forward tailstand pulled negative for a reverse at the moment at the end of reverse to collective negative push I heard something machine drove itself canopy first into ground ? Looking it over ( which I have to tell u it took hit amazing ) we found the bolt snapped on elevator A arm Now I've had plenty of machines with this setup Inckuding my current velocity 50 and outrage 550 and trust me I've packed them both in once or twice hard I've never seen this Thoughts ?

im4711
05-09-2011, 07:33 AM
Interesting. Could it be an issue with the servo? The elevator arm could have been damaged during impact. Have seen it often and after further investigation sometimes found the issue to be a different one. -> just a thought since those are pretty hard to break.

hotstart
05-09-2011, 08:32 AM
checked servo Fine yes i agree it could have broken on impact Just ive never seen it The plastic link is one thing But it this case bolt was snapped inside A arm

im4711
05-09-2011, 08:38 AM
strange indeed. I hope damage is not too severe. Those crashes can end up in some bigger damage. As bad as it sounds but in such scenario I flip throttle hold almost instantly.

Another option could also be a brownout. -> hard to check that later since when walking to the heli often we do not check the receiver.

hotstart
05-09-2011, 08:47 AM
Did check reciever was ok On a bright note besides the regular stuff blades main shaft boom torgue tube some linkages It took hit like a trooper Much much better than we all expected walking out very tough bird Also all connections where and still r shoo-gooed in place

im4711
05-09-2011, 12:19 PM
Interesting indeed. It worries me when something unexplainabe happens.