PDA

View Full Version : Happy Castle owners post here...


Pages : [1] 2 3 4 5 6

Rick Dizzle
05-10-2011, 12:40 AM
OK, so not 100% sure if I posted this in the right spot...mods if not feel free to move.
So based on ALL these CC120HV failures and 700MX's getting smoked by CC ESC's, I have set up my "engine failure" feature in my Phoenix sim on my 700E. How sad is it that I have such doubt in the equipment running in my $1200 heli that I have to do this in my sim! I gotta say it is kinda fun though, as it is forcing me to auto in all kinds of different scenarios. I emailed Castle twice about the 120HV issues, just to get their thoughts and any precautions before first flight...They have been so nice NOT to return either email in over a week. O' well I guess. I hope to maiden my 700 in about two weeks as my work schedule has been rough and I am waiting on my flybar lock and Trueblood swash level to arrive to finalize set up. Anyways just thought I would share my new adventure via my Phoenix Sim....

Ill get off my soap box now....:soapbox

**Edit**
The title of this thread has been changed as to reflect and continue to gather positive intel on the Castle ESC's....

invertsick
05-10-2011, 01:12 AM
how sad it is that the 95% of castle uesrs who dont have any problems are not posting here how happy they are with their esc.
I am one of them :)
ive been flying my 700E for almost 9 months, first 3 months with castle 160 and then castle 120 with zero issues.
i didnt change to 120 because i had a problem with my 160,
its just that the 160 is too bulky and 120 was not available when i bought the 700.

Rick Dizzle
05-10-2011, 01:24 AM
invertsick,
Man I gotta tell you it is refreshing to hear this! I am really hoping to be one of the 95% with no issue. I will post my results as soon as I get her flying. I hope that I am just freaking myself out over nothing! A couple fellow freaks on here have told me..."Just fly it and don't worry!" So thats the plan! Gonna have my buddy who flys some killer 3D at our field do the maiden and the first couple "hard" flights on the esc, that way if it fails he can EASILY recover. But lets keep fingers crossed I am in the 95% club! :thumbup:

OnTheSnap
05-10-2011, 03:13 AM
120HV works fine for most. Worked fine for me. Just go fly.

Lord.L.B
05-10-2011, 03:56 AM
120HV works fine for most. Worked fine for me. Just go fly.

+1, same here, ICE 120HV working fine.

Sirolf
05-10-2011, 05:24 AM
Again happy customer here.. 120HV works great for me.
Still have to practice auto's on my 700 for real, but not worried especially after my recent
mod: http://www.helifreak.com/showthread.php?t=303726

nocontrol1
05-10-2011, 07:45 AM
Me too! No problems in 3+ months on a CC 120HV.

Rob D.

tekparasite
05-10-2011, 07:51 AM
No problems here either.

f22warzone
05-10-2011, 08:41 AM
........... Gonna have my buddy who flys some killer 3D at our field do the maiden and the first couple "hard" flights on the esc, that way if it fails he can EASILY recover. But lets keep fingers crossed I am in the 95% club! :thumbup:

Best would be 2 packs of hovering first, as if it fails it will fail, but i must also say i have had no problems with my hv 160, and i haven't been very nice to it.

but you still need that motor cut feature, I use it in phoenix...... simulates a gear strip lol, have gotten very pro at landing almost all of them now, and in life it really helps out.

invertsick
05-10-2011, 09:38 AM
There u go :)
Lets see more happy customers lol

LegndarySaiyan
05-10-2011, 11:53 AM
Ice 120 here. Been through 2 crashes, used with three different motors, still working perfectly!

smaze17
05-10-2011, 12:07 PM
Well, not a 120 but love my 80HV :thumbup:

S

TheBigBopper
05-10-2011, 12:15 PM
CC 80 HV here. 700M it worked great but my first crash took out the motor(bent shaft). 470KVMX motor smoked after a few flights. next in line is a scorpion HK III 4035-500. i have my fingers crossed and i've been practicing my auto's. :lol:

FredRX
05-10-2011, 02:27 PM
My HV160 ICE works like a charm :thumbup:

MMM.PWR
05-10-2011, 02:35 PM
Another thumbs up for the 120 :thumbup:

Doug Darby
05-10-2011, 02:38 PM
Both my HV85 and 120 have been fine...

geok
05-10-2011, 04:19 PM
CC HV 120 with 700MX working 100% no problems so far. (same for my buddy also. same setup same success :))

litespeed
05-10-2011, 04:36 PM
I have over 100 flights on my CC Ice 80HV. 50+ on the original 700M and the rest on the 700MX 510. Just stripped a CNC gear on a tic-tock and the 80 still lives.

I have no complaints and like the lower price of the Castle Stuff.

Tom

Shef
05-10-2011, 07:55 PM
About a year with my 160 (Rev 2)...flawless so far.

acalley02
05-10-2011, 09:34 PM
Well good to see there is some happy cc customers, mine smoked in the first 30 seconds, and the motor cooked too. All though guess i can't really say that the motor maybe casued it to go too, to far gone to tell now. Hope my second one works better.

invertsick
05-10-2011, 10:43 PM
I hope this thread makes you guys like the op feel better :)

Yes i love my 120HV
And when i buy another heli it will definately be controled by castle again.

Oh by th way my 2 other birds already have castle in the already.
6S trex 450 pro
And 6S mini protos
Both have ice 50.

s0laris
05-10-2011, 10:45 PM
Ice100 on one outrage 550
Cc120 on another

Zero issues.

crudd-bucket
05-11-2011, 06:20 AM
No problems here - adhere to the setup parameters which are found on the CC website and you can't go wrong.

Chris_M
05-11-2011, 07:19 AM
Just got a new 120HV 3 weeks ago after my HV110 cap exploded (found that one of cap leads came loose) and have over 20 flights on it with no problems. Also emailing Castle is not a good way to get a response as they are VERY slow at returning emails. Give them a call and you will get immediate results.

Cirkus
05-11-2011, 10:59 AM
I think I heard there were over 30,000 120HV's made so far. While there is no denying the fact that more than a handful have gone up in flames, the percentage vs. ones that work perfectly is very very very small.

Count me in for one that is working great so far.