PDA

View Full Version : Castle 120HV FIRE


Pages : [1] 2 3 4

floop
05-21-2011, 04:29 PM
Yet another story. 25 flight. First ESC was DOA. Then this on spool up.

:arggg:http://www.helifreak.com/attachment.php?attachmentid=229049&d=1306013099

nightflyr
05-21-2011, 04:57 PM
OUCH!!!!! hope it mostly soot damage:hug:

Just maiden my 700E using the 80HV...worked with out issue

Cirkus
05-21-2011, 05:00 PM
I went to the San Diego Heli fun fly today. Talked with Castle and Align. Apparently they dont read forums because they both claim that 120HV's and Align 700 tail grip bolts don't have issues.

Hank79
05-21-2011, 05:42 PM
Yet another story. 25 flight. First ESC was DOA. Then this on spool up.

:arggg:http://www.helifreak.com/attachment.php?attachmentid=229049&d=1306013099

What are your settings, PWM, gain, etc. Can you post them

kouasupra
05-21-2011, 06:44 PM
What are your settings, PWM, gain, etc. Can you post them

Go ahead and grab a Jive ESC. :thumbup:

CNCjunkie
05-21-2011, 07:02 PM
And I see that's the new case design. I guess the guts are the same. :flamedevil

Cirkus
05-21-2011, 09:15 PM
Go ahead and grab a Jive ESC. :thumbup:

I'm taking that advice.

Matt Nasca
05-21-2011, 10:08 PM
I'm taking that advice.

You won't be sorry!

helicraze
05-22-2011, 02:19 AM
There is an issue on the 120HV, 3 out of 5 in our club caught on fire, that is not good enough.

jetblue2135
05-22-2011, 05:54 AM
damn 25 flights? Better than I did, mine popped 30 seconds into its first flight! I sent it into castle for repair or replacement, finally received an email back from them on friday saying "we are out of stock of the 120's, please allow 1-2 weeks before we can ship you a new one". It has been 3 weeks that they have had it now. So I guess its 4-5 weeks total to get a new ESC if yours pops? So frustrating.

Jacobs
05-22-2011, 12:17 PM
10 sec into flight,,,,,:thumbdown:

Discman
05-22-2011, 02:53 PM
I posted this on the elec. forum, but will share here as well to maybe help warn others. The same thing happened to my 700E with CC 120 HV. I was only hovering around and caught fire. Bummed.

https://picasaweb.google.com/ryankirk/Trex700EF3C?authkey=Gv1sRgCIe7t__9grGJrAE&feat=directlink

tptompkins
05-22-2011, 03:38 PM
Sorry to hear about your ESC. Be sure to post your details to this poll. Maybe some day we'll see some sort of a correlation.

http://www.helifreak.com/showthread.php?t=297072

Tommy

tptompkins
05-22-2011, 03:49 PM
BTW - for all of you that believe CC that cause of the fires is from the heat sink separating, and that the new case would solve the issue, notice that in this particular case the new screwed on casing didn't help much.

Tommy

vintcs
05-22-2011, 10:10 PM
Did u check the clearance per castle creation advisory? I got one which came without a aluminum spacer and get it changed but I upgraded to 160 hv esc.

jprochnow
05-22-2011, 10:23 PM
I'm awaiting a new 120hv from castle and i'm seriously debating on getting the jive. Only thing it I haven't had the problem with the esc as I haven't even powered up my heli yet.

nobody
05-23-2011, 12:51 AM
I have a 140HV on my 700E and nothing but trouble, put new firmware on esc and heli went down twice power cut out, ESC was on insensitive mode so not to void warranty by disabling. Current limiting feature does not work , CC said to just disable it, BUT MY BIRD WENT DOWN!
Another feature on the ESC that does not work is power initial current feature, stops my heli from spooling up.
My 85 HV on my 600E, when I plugged it in for the first time one of the capacitor literally exploded, CC said it was a defective capacitor, really, IT BLEW UP IN MY FACE!
My Phoenix 45 current limiting feature made my 450pro go down twice on insensitive mode broke almost everything, MY BIRD FELL OUT THE SKY TWICE!.
Damn CC stop taking my money and selling me SH&T!

jetblue2135
05-23-2011, 08:41 AM
Another CC 120 up in flames last night at our field, new esc with the plastic casing, second flight since new. 700 F3C.

Mystic3D
05-23-2011, 09:05 AM
I have a 140HV on my 700E and nothing but trouble, put new firmware on esc and heli went down twice power cut out, ESC was on insensitive mode so not to void warranty by disabling. Current limiting feature does not work , CC said to just disable it, BUT MY BIRD WENT DOWN!
Another feature on the ESC that does not work is power initial current feature, stops my heli from spooling up.
My 85 HV on my 600E, when I plugged it in for the first time one of the capacitor literally exploded, CC said it was a defective capacitor, really, IT BLEW UP IN MY FACE!
My Phoenix 45 current limiting feature made my 450pro go down twice on insensitive mode broke almost everything, MY BIRD FELL OUT THE SKY TWICE!.
Damn CC stop taking my money and selling me SH&T!

Choice is a great thing.

tecman
05-23-2011, 03:57 PM
also my cc120A in my field on fire Sunday after a minute of flight.
This is the second time that happens, the first time with the 80A.
I never buy more castle esc creation, now I want to try scorpion commander hv 130A.

nobody
05-24-2011, 03:07 AM
All CC ESC's should come with mini fire extinguishers :rc

Gin3tto
05-28-2011, 09:55 AM
CC SUX!!!
0 (ZERO) seconds fly.

First time to airfield, i have connected BEC and again before mounting canopy auto-fire CC 120.

:mad::mad::mad::mad::mad:

acalley02
05-28-2011, 12:02 PM
I had one go up in flames too in about 30 sec on spool up. Castle still has mine, they also said out of stock and it would be 3 weeks to get it replaced. I just got my jive 120 and im gonna try it out this afternoon.

floop
05-31-2011, 06:17 PM
What a great message. Read below. Notice the "WERE Sorry about your helicopter burning up!" We will replace the unit ASAP.

Castle Creations has great customer service..

__________________________________________________ ______________________

Thank you for sending in a repair to Castle Creations.

We have received your (ICE 120 HV).

Unfortunately the repair is beyond our repair cost limitations. Therefore we will replace yours with a new or refurbished unit once they are available. Wait time is at least 3 weeks as we are out of stock of this item/s. As soon as this is available we will ship your item/s out immediately.


Please let us know if we can assist further.

stang281472
05-31-2011, 08:49 PM
Mine failed yesterday after about 15 flights on my 700e. Went to spool up and motor stuttered hard and then spooled up to about 10% throttle and wouldnt go higher. Unplugged and when plugged back in ....nothing. No beeps nothing. 2 hours later my friend calls me and tells me his went on fire on first flight of his 700e. Changed out my esc with another cc 120 I had from another heli in mine and its back up and flying but this is crazy. Now we both have to send them in and they dont have any to replace them with for weeks?