PDA

View Full Version : Replacement parts not consistant


audio131
08-05-2011, 07:08 PM
i have ordered 2 separate parts for my 6hv and both time they are different than the original and not even like an upgraded part ,just wrong and different. got a new gyotro.fbl tray. and had to dremel the sides and file it till it fit. and I HAD MY SWASHPLATE FOR NO REASON CRACK IN 2 PARTS . got the new one and it it totally different. the balls are set different so i cant get the right angles on my servo arms. the threaded part of the link ball is different from my old one so i cant use them, so now im swrewed for the week end of flying.... almost make me wanna sell this ship and get the new 600e

ugoferri
08-05-2011, 07:16 PM
Wow... something's wrong there, maybe the model or the packed order. When i started i wanted to buy an extre set of screws for my 450 pro, went to the hs and ask for "trex 450 screw set" and they sold that to me, the thing is that they were for a 450 sport not pro, totally different... Now i ask everything with the part number! Haha... And about not flying this wknd, i've been waitin' 3 weeks for my torque tube front geat set... This is gona be my 4th weekend with no flying at all!

Cullen Colapietro
08-06-2011, 08:55 AM
Can you post pictures of the swash?

Bubba Gump
08-06-2011, 11:16 AM
Yea something is wrong. After been flying compass for like 2 years now. Knight 600e and 6hv never had a wrong part issue. There is a 2.5 swash out but it shouldn't change anything. Who did you get your parts from?

crawl
08-06-2011, 12:24 PM
If you ordered from Amain I'm not surprised. They have, for example, non 6HV parts listed in the 6HV section.

audio131
08-06-2011, 06:04 PM
nankin was nice enough to send out that swash to warrenty the original one that cracked in half so no reason. the part number matches the right one but the swash is different. the balls on it are shorter and do not stand out as far as the stock and they are like 2.5 mm threads so the old ones wont fit.... ALSO any one noticed that the left servo on a fbl set up the link rubs on the tail drive gear?? noticed that the other day ,my link was worn almost thru.. i took the gear off and dremeled the tail guide part about and 1/8 off till the link and ball did not rub.. sorta a shitty design.

Cullen Colapietro
08-06-2011, 06:16 PM
There are swash ball link washers that come with the FBL conversion, maybe they were incuded in your kit? Still have the old swash? Might those little alum washers work with the new swash? Also earlier links were 2mm, new links are 2.5mm if I'm not correct. This was an update possible to deal with complaintsof swash balls backing out in a crash? The servo arm might rub, depending on your pitch values. I used a dremel tool and honed down the belt pulley.

Bubba Gump
08-07-2011, 06:39 AM
nankin was nice enough to send out that swash to warrenty the original one that cracked in half so no reason. the part number matches the right one but the swash is different. the balls on it are shorter and do not stand out as far as the stock and they are like 2.5 mm threads so the old ones wont fit.... ALSO any one noticed that the left servo on a fbl set up the link rubs on the tail drive gear?? noticed that the other day ,my link was worn almost thru.. i took the gear off and dremeled the tail guide part about and 1/8 off till the link and ball did not rub.. sorta a shitty design.

Make sure you have the servo spacers that come with the kit on that one servo they should be black color.

audio131
08-07-2011, 01:45 PM
ahhh. thats why i needed them. u u know i left them out and completely forgot i had them to even think i needed them till you said that.. thanks.

Bubba Gump
08-07-2011, 03:52 PM
No problem man. Yea I forgot when i first built the 6hv over a year ago and found that thats what they were for. If you still have some issue with it hitting the pulley just trim some plastic off the pulley.