PDA

View Full Version : brushless motor issue


freestyledork
08-28-2011, 08:27 PM
the stock motor on the b450 is binding up on me.. it started squeaking on spool up so I turned it off pulled it out of the case. I noticed with out power the motor was hanging up when I tried to spin it with my hand I couldn't tell if it was the gears or not so I pulled it all the way out. Still binding on me so I took it apart and cleaned it very thoroughly. No more binding. I took it back out flew it once and changed packs and same problem. Now it wont spool at all just skips even at full throttle (only tired for a second) So is my motor bad?

FuntanaS
08-28-2011, 08:49 PM
Maybe bad bearings?

freestyledork
08-28-2011, 08:55 PM
yup is there a place to get a replacement?

took it apart again and noticed it was completely bent

FuntanaS
08-28-2011, 08:57 PM
The bearing was bent? Or the shaft?

freestyledork
08-28-2011, 09:13 PM
bearing

FuntanaS
08-28-2011, 09:17 PM
I suppose take the bearings out and measure them. Most bearings are measured in millimeters. They are measured by the outside diameter, inside diameter and the thickness. I know tower hobbies sells bearings. Just find a set of bearings with the same dimensions and you should be alright.

freestyledork
08-28-2011, 09:25 PM
stupid thing broke apart and is in pieces now.. I guess I hit the local hobby store tomorrow

FuntanaS
08-28-2011, 09:31 PM
Any ideas on how it happened?

freestyledork
08-28-2011, 09:45 PM
Nope.... Dirt got in I think. Not to sure