PDA

View Full Version : DS510 Servos Clicking After I changed the gears???


Stevin
08-30-2011, 10:20 AM
After a bad autorotation and a tiny blade knick the servos started clicking. I opened it up and found a stripped gear so I changed the gear and looked over the others, all gears are fine but I am still hearing a click when moving the servo. I ahve since flown so it is flying but I am concerned about the clicking noise. Any ideas?

flerpie
08-30-2011, 11:02 AM
Identify which servo is clicking.
Unplug it from the rx.
Continue....any other servos clicking?

How many servos click? Just 1?
Sometimes a little piece of gear can get stuck in the grease
inside the servo and then work it's way back into the gear train.

I find it pretty hard to find broken gears if I don't use a 10x mag glass
to look them over.

acidla
08-30-2011, 11:48 AM
Stevin,

Loosen a little bit the screws that hold the servo case.
Hope this helps.

Tangolima600
08-30-2011, 04:21 PM
I'm guessing you already thoroughly inspected the rest of the gears because more likely than not there's another chipped gear in there. Like Flerpie said check for any debris in the grease too.

helicopter1
08-30-2011, 04:30 PM
Did you clean the servo well? There might still be teeth from the old gear that stripped.
It is very hard to spot them that is why you have to clean it very good, wipe the old grease and replace all the gears that are broke and install new grease.

christopherkriens
08-31-2011, 02:22 PM
I had this happen last week, replaced the gear that was missing teeth, but the servo still clicked. Replaced all the gears and it stopped- never was able to visually identify the bad gear.

Stevin
08-31-2011, 05:43 PM
I kust picked up a pack of metal gears. Can I use the silicone grease for the gears?