PDA

View Full Version : CX2 Vibration


picasso71
09-02-2011, 02:50 PM
Been flying my cx2 for a month or so now....with my fair share of crashes lol. Anywho, I've basically got er up and running as close to brand new as possible, but can't help but notice a wobble/vibration in the head that reverberates throughout the whole heli. It's not constant, but more of a cyclic wobble that increases or decreases with engine speed. You can only really notice it if you are actually holding the heli down with your hand while it is runnning. It fly's just fine, and doesn't seem to cause any problems. I was just wondering if anyone had any ideas as to what it might be and if there is a fix. I don't think it did it when it was fresh out of the box

Oldladypilot
09-03-2011, 12:32 AM
This could be a number of things but I suspect a very slightly bent shaft. Take your blades off and run it. Do you still have the vibration? See any wobble in the shaft?

If not, check your blade balance and tracking.
If you still have vibration, remove your inner shaft and roll it on a flat surface. If it wobbles at all its bent. You can try to straighten it. If that does not work, replace it. I see you've already upgraded to the Extreme extended shaft....good upgrade.

If your inner shaft is not bent, try your outer shaft. Again, if it is bent you can try to straighten it, or replace it.

I know from experience that even a minor crash can bend a shaft. I've replaced several and have a couple new ones on order right now from boomtown hobbies. Mine runs like a Swiss watch with good shafts/proper blade balance, tracking and the Extreme 180 motors. Good luck!

picasso71
09-03-2011, 12:07 PM
Thanks. I went down to my local RC store and the gentleman there figured it was most likely even weight i the blades. Not sure how to fix that but its still flys really well so I'll probably just let er buck until i break some more blades lol

remoteball1
09-04-2011, 11:28 AM
Been flying my cx2 for a month or so now....with my fair share of crashes lol. Anywho, I've basically got er up and running as close to brand new as possible, but can't help but notice a wobble/vibration in the head that reverberates throughout the whole heli. It's not constant, but more of a cyclic wobble that increases or decreases with engine speed. You can only really notice it if you are actually holding the heli down with your hand while it is runnning. It fly's just fine, and doesn't seem to cause any problems. I was just wondering if anyone had any ideas as to what it might be and if there is a fix. I don't think it did it when it was fresh out of the box
I had the same problem i did multiple steps to eliminate this.

1). Check your blades for cracks, chips, exc. A small off balance can cause wobble
2). Take your blades and fly-bar off then run the helis motors up look for wobble in the upper and lower heads, replace the inner shaft and outer shaft if need be.
3). Check your gears above the battery box, they can be warped, stripped, or broken
4). Check your fly-bar for balance

Just noob advice :peace

Luvmyhelis
09-05-2011, 06:25 PM
I had the same problem i did multiple steps to eliminate this.

1). Check your blades for cracks, chips, exc. A small off balance can cause wobble
2). Take your blades and fly-bar off then run the helis motors up look for wobble in the upper and lower heads, replace the inner shaft and outer shaft if need be.
3). Check your gears above the battery box, they can be warped, stripped, or broken
4). Check your fly-bar for balance

Just noob advice :peace
Your noob advice is spot on! :thumbup: