PDA

View Full Version : Shuttle Plus belt problem


chrisb01
04-10-2004, 06:20 PM
I'm building a Shuttle Plus, I follow the book step by step, but the belt seem too short. I pushed the boom about 4mm more into the frame to be able to put the belt around the pulley, now the boom will not come back out. Has anybody had this problem? How did you solve it? Or can anybody tell me how to fix it? :?:

rob_jones
04-11-2004, 09:20 AM
Loosen the four screws that clamp the boom into the frames. There is a notch in the end of the tail boom that must line up a stud inside the frames.

The only way the boom will get stuck is if the bolts are still tight or you somehow got some locktite on it. But there is enough play that you ought to be able to twist it slightly back and forth and work it out.

chrisb01
04-11-2004, 02:14 PM
The problem is with the belt. The belt seem too short. The only way I can let the boom back out would be to remove the belt from the pulley.

rob_jones
04-11-2004, 08:46 PM
Chris,

Something is not right somewhere. The belt shouldn't be that tight. My first guess would be that it's twisted too much. It should only twist 90 degress. You might have it 270. That would make it too short for sure.

If that's not it, the only other thing it could be is that the tail case is not fully seated on the end of the tail boom. Remove the tail case and be sure it's installed correctly.

The only way I can let the boom back out would be to remove the belt from the pulley.

I'm really not sure what you mean by this. You have to remove the belt from the pulley anyway. That's the only way to get the tail boom off.

fitenfyr
04-11-2004, 09:15 PM
Chris,
Take the boom off and the belt out.
Take the numbers off the belt and E-mail Jeff@modelrec.com
Ask him to verify that the belt is correct. Maybe you got a bad belt for some reason. Stranger things have happened.
While the boom is off measure it to ensure you haven't gotten a Sceadu boom by mistake (you didn't say, but I assumed you are building a kit from NIB).
Now when you put it all back together follow the suggestions here and ensure you are doing everything correctly.
If it doesn't fit then. You have to have a wrong part somewhere.
I remember the Plus belt being tight to go on, but you should have some slack in it to adjust out once it is on.

chrisb01
04-12-2004, 07:45 AM
Thank you guys. I'll remove belt, boom and tail assembly and put it all back together. I know I must be doing something wrong some where. If that does not work, then I'll email Modelrec. I will get back to you guys with the results. Bimmer and Jason I really do appreciate your helping me with this.

chrisb01
04-12-2004, 07:47 AM
Yes I got the kit NIB.

rob_jones
04-12-2004, 09:07 AM
I will get back to you guys with the results.

Cool. Please do. I'm curious to see how it turns out.

Bimmer and Jason I really do appreciate your helping me with this.

:D No problemo. That's what it's all about! :D