PDA

View Full Version : Chicken Dance?


Dont155
02-20-2012, 05:52 PM
Anyone else ever have the X do a little chicken dance on you AFTER throwing TH switch? Mine does it every once in a while even after I throw the throttle hold switch and chop the throttle. Gotta be hard on the main motor and the board... :arggg:

Gryffandor
02-20-2012, 07:38 PM
I have had the same thing happen on more than a few occasions :wow2:

Flatearthman
02-20-2012, 07:55 PM
+3

Liduno
02-20-2012, 07:58 PM
Sounds like the throttle hold isn't working, the board will eventually turn off once it gets enough resistance, like you said that's not good for any thing.

Dont155
02-20-2012, 08:00 PM
Nice to know its not just mine. After the first two times it did that, I went over the TX settings with a fine tooth comb just to make sure I had it set right. Its really annoying to watch it hop around like that when you KNOW you've hit the TH just before crashing.

I've walked up to it and heard the motor still straining, then it cuts off and it starts flashing the LVC indicator at you. Not sure why it doesn't get the cut-off signal from the TX... :mad:

petedee
02-21-2012, 03:55 AM
Nope never had this problem. How about posting video of this.

wulfrun
02-21-2012, 08:07 AM
It's happened to me, once with the mSR X and many times on the mSR. As far as I can tell, it only happens if the blades can't turn freely, i.e. the motor is still under a high load. Half the point of TH is to cut the motor in these exact conditions, so I've always thought it is a design flaw. Hitting the throttle-cut button does not work either under these circumstances either, at least not immediately.

wulfrun
02-21-2012, 08:11 AM
Nope never had this problem. How about posting video of this.
Not an easy thing to do, unless you just happen to catch it doing it while you had the camera rolling anyway.

Flatearthman
02-21-2012, 10:05 AM
i have had it happen trying to land with the blue led blinking with the msr
throttle fully cut bfore landing