PDA

View Full Version : DX6i user needing to re-bind each pack - help?


lucidchaos
02-22-2012, 08:54 PM
I finally got my 450v2 3gx dialed in to the point where I am really enjoying it more and more each flight. I have a couple nagging issues - one being proper tail settings for a robotic tail hold which I am slowly but surely sorting out, and then there's the other one I have NO CLUE about.

My 6ch receiver (OrangeRx 610) must be re-bound each time I plug the battery in! I've tried two of them and had the same result.

Is the receiver thinking the connection cable from the 3GX is a bind plug? Everything else looks and flies fine.

Cheatum
02-22-2012, 09:12 PM
I was having the same problem. I removed the white (signal) wire from the provided power cable that runs from the 3GX to the receiver and that fixed it. This drove me mad for about a week.

lucidchaos
02-22-2012, 09:36 PM
I was thinking that may help... thanks for confirming! I think I'll pick up a short servo extension from the hobby shop and snip the signal wire on that. Will report back with results.

hydro_pyro
02-23-2012, 09:47 AM
... must be re-bound each time I plug the battery in! I've tried two of them and had the same result....

Is the receiver thinking the connection cable from the 3GX is a bind plug?

Your receiver's power connection wire at the 3GX aux connector is plugged in backwards. Yes, it thinks it's a bind plug. Flip it over and you should be fine.

Same thing happened to me on the first try.

lucidchaos
02-25-2012, 04:38 PM
I tried reversing the plug into the 3GX as suggested. This made the heli simply spaz out!!! It started to spool up, all servos jittered ... I do NOT recommend this to anyone reading who has the same issues! Hydro I'm glad it worked for you...

What did fix it is disconnecting the white signal cable between the 3GX and the 6ch receiver. If you take a hobby knife and gently lift the plastic retainer on the female signal plug, the whole connector slips right out! I folded this cable back on itself and shrink-tubed it so if I ever need to salvage the servo extension, it will be a plug-and-play affair.

Thanks again all for your help!!!

flynot2000
02-25-2012, 04:43 PM
My 6ch receiver (OrangeRx 610) must be re-bound each time I plug the battery in! I've tried two of them and had the same result.

Umm, the knockoff orange receiver? There's a reason they are cheap, I would think they got the scrap barrel from the spektrum factory. I have seen some fairly odd behavior from that set, ie having to reset trim on a bird for every flight, to just not working sporadically.

Seriously, I wouldn't trust my expensive 450 to that rx, get a real one....

lucidchaos
02-25-2012, 05:01 PM
If I hadn't already spent $35 more on a satellite receiver, I would. In reading the forums however, very few people have anything bad to say about the orange receiver. Hell, everyone and their brother is pissed about the 3GX issues (Backwards drift, resets in the air, dead cyclic at center, sub-par software interface, ETC.) If the 3GX cost $20, there would be plenty of people saying "Get a real FBL system."

The orange receiver holds a bind fine, I actually got another one when I complained about the binding issues. It did the same thing - I tested it standalone and it worked fine.