PDA

View Full Version : Tail issue might be fixed!


Pages : 1 2 [3]

Rob43
03-12-2012, 08:17 AM
Glad you are happy no Mr.Taco. I finally solved my death wobble during hard cyclic command today !!! Only tried changing about every potential part on the heli...... turned out to be the servos.

Capi - please explain...what was the deal with servos? Some gear slop?

DominicD
03-12-2012, 09:14 AM
Being with Compass I can't really go into details without being called biased, so I'll leave it at I am very happy so far with my new align servos.

Rob43
03-12-2012, 11:52 AM
Oh, okay. I hope your 610's work out well. I thought they flew great on my T-Rex. Had one fail on the Fury 55. Never knew why. It just went full travel one way.

3Dmuse
03-14-2012, 07:34 AM
Mr. Taco,

An imbalanced motor, or bad bearings in the motor, can cause the tail wags that you are experiencing.

Elios000
03-15-2012, 07:14 AM
Taco is that tail grip a drop in or is there a mod needed?

AnTi Taco
03-17-2012, 06:01 PM
Taco is that tail grip a drop in or is there a mod needed?

yup just got mine today fits perfect and looks cool

http://i1177.photobucket.com/albums/x358/tacomancy/IMG_0960.jpg

http://i1177.photobucket.com/albums/x358/tacomancy/IMG_0962.jpg

buzzsaw 46
03-17-2012, 06:06 PM
Does look nice. Looks like even with your short balls it could use a touch of filing on the standoffs.

AnTi Taco
03-17-2012, 07:03 PM
Does look nice. Looks like even with your short balls it could use a touch of filing on the standoffs.

Nah man its pretty perfect fit i just used balls with no standoff....i think i know why u think that cause of how the arm link sits on the servo ball at a angle..if so the stock ones does that same......i could of used the stock balls also but i just used shorter balls to get it more parallel

buzzsaw 46
03-17-2012, 07:07 PM
I know it will work like that, no problem. I'm just a perfectionist on stuff like that.

AnTi Taco
03-17-2012, 07:56 PM
I know it will work like that, no problem. I'm just a perfectionist on stuff like that.

ohh i know the feeling trying to get everything perfect :D i just gave up trying to fix everything on this tail after all the effort i put into trouble shooting and figure at this point if the heli flying fine now im happy enough :bacon

buzzsaw 46
03-17-2012, 07:59 PM
I hear ya man, I hear ya. I checked my tail and my links are at a slight angle, but in the other direction.

AnTi Taco
03-17-2012, 08:20 PM
i think u can buy the quick uk tail thats for the LOGO and its the same as what im using only difference is it comes with two arms that connect to the blade grips and i think someone said u can even unscrew the brass sleeve on the pitch slider and just screw in the quick uk one for a better bit but i didn't bother..im happy enough


this peace here

http://www.readyheli.com/ML6T11-1-Quick-UK-Logo-500600-Tail-Pitch-Slider-Replacement_p_37956.html

buzzsaw 46
03-17-2012, 08:26 PM
I was looking for this one state side.

http://www.quickuk.eu/products/1476/webshop_categories/hirobo_parts/shuttle/shuttle_tail_grip_assembly_st-11.html

Airworks
03-20-2012, 01:16 PM
man , take a red sharpie marker, and color your tail grips , silver now is metallic red! damned magic i tell yeh!

sarpilot
03-20-2012, 01:20 PM
man , take a red sharpie marker, and color your tail grips , silver now is metallic red! damned magic i tell yeh!

Rof

Sent from my DROID3 using Tapatalk