PDA

View Full Version : Align 600 nitro engine starting problem


helinutmja
02-12-2008, 12:57 PM
I am trying to start new engine and it keeps hydro-locking i think. Starter then stalls. can any one help. Only 1/2 tank fuel run so far using Bekra 16 fuel.:arggg:

frogbmth
02-12-2008, 02:06 PM
Shut off the fuel line, open the throttle to full, and clear the hydrolock by removing the glow plug and turning the engine with the starter. Replace the plug and shut the throttle off completely. Make sure the enine will now turn. Then unclip the fuel shutoff and proceed to start as normal.

Andy

BarracudaHockey
02-12-2008, 02:11 PM
Key words "Unclip the fuel shut off"

Keep the fuel line clamped till you're ready to start the engine.

frogbmth
02-12-2008, 02:13 PM
I recently had a real issue with the engine locking and locking - turned out my fuel line clamp was a bit rubbish and wasn't quite shutting off the line completely. :arggg:

helinutmja
02-12-2008, 02:14 PM
I will give it a try tomorrow. Thanks

derelict
02-13-2008, 04:52 AM
also make sure that you open the throttle about 3-4 mm away from the mark on the engine case.... i had the same problem as you do... until someone told me to open the throttle more then "just a little bit" in order to get some air into the engine!

hope it help

greets

marcel

TonyUK
02-13-2008, 02:23 PM
I get this, tilt the heli on its side 45 degrees towards muffler.then keep applying starter, it always works. Saves you taking off canopy and plug everytime.

helinutmja
02-13-2008, 02:31 PM
Thanks for you help. Had more success after a few locking problems mainly due to weak starter and very very rich mixture setting on carb. Eventually ok and managed to hover the new heli for the first time this afternoon. Engine ran well. I will try the 45 degree treatment when it locks again.