Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > E-Sky Helicopters > Belt CP


Belt CP E-Sky Belt CP


Reply
 
Thread Tools Display Modes
Old 01-07-2009, 08:34 AM   #1
GCK
Registered Users
 

Join Date: Mar 2008
Location: Central Wisconsin
Default CX450SE V2 setup?

This probably is not the right forum to post this. But since there is not a Copter X section and Iím sure some of you guys have this helicopter I figured what the heck.

I got a CX450SE V2 for Christmas. So far Iíve equipped it with a 40A Hobby wings ESC, Align 430XL motor with 11 tooth pinion, external 3A switching BEC, SG90ís on the swash, and an AR6200 receiver to go along with my DX6i. I plan on using a GY401 gyro and a decent tail servo but Iíve yet to pick that up.

Iíve mounted the servoís (pain in the butt) and went through the entire head setup based on Finless Bobís videoís (CCPM part 1/CCPM part 2). Everything went well all though Iím sure if I built another one I could do it in half the time. I have the collective pitch set to +/- 10 degrees. I can easily get +/- 12 degrees but I figured 10 is good for now. And Iíve set the cyclic pitch to +/- 7 degrees. I noticed in Bobís video that his swash mixes are around 50 or so for pitch and around 60 or so for aileron and elevator. On my setup Iím at Ė85 on pitch and 95 for aileron and elevator. Is this just the difference of the servoís and my radio? Or did I miss something and need to go back through my setup? Everything seems to be working just fine. Iím just curious as to why my swash mix settings are so much higher then Bobís. And Bob is running +/- 11 degrees collective and +/- 8 degrees cyclic in the setup videos.

Thanks for any input.

Greg
GCK is offline        Reply With Quote
Old 01-07-2009, 08:58 AM   #2
Jonnyheli
Registered Users
 
Posts: 5,403
 

Join Date: Mar 2008
Location: Wales, UK
Default

Your mix percentages are way too high. There is definatly a problem somewhere.

I am not an expert on swash mixes but maybe you swash was too low from the start. Try and lower your pitch % and higher your swash useing the links. Turn them all two turns, then 3 or 4 turns until you get 0 pitch at mid stick with 60% pitch.

If you do that then maybe all your other values will need to come down too. So lower your aile and elev to 60% aswell.

-Jonny
__________________
Spektrum DX7, Align Trex 250se, Align Trex 500cf, Align Trex 600n LE
Jonnyheli is offline        Reply With Quote
Old 01-07-2009, 09:05 AM   #3
GCK
Registered Users
Thread Starter Thread Starter
 

Join Date: Mar 2008
Location: Central Wisconsin
Default

I have zero pitch at mid stick regardless of the swash mix setting for pitch. Only thing changeing the pitch setting does for me is change my pitch range.
GCK is offline        Reply With Quote
Old 01-07-2009, 11:44 AM   #4
psilo
Registered Users
 
Posts: 2,574
 
My HF Map location
Join Date: Jan 2008
Location: Cambridge, UK
Default

Hi Greg,

Good choice of forum as a lot of us have CopterX's or hybrid belt copter x/exi/trex!

I agree with Jonny, your mix settings seem insanely high. I am getting +/-11 on my CopterX V2 with just 60% swash mix and get +/-6 cyclic with 60%. When you say you can easily get +/-12 do you mean by increasing swash mix pitch setting?

I would guess that you need to move the ball out on your servo arm and reduce the swash mix down. Which hole do you have the ball in?
__________________
T-Rex 500 ĶBeast, 450 Pro (soon to be ĶBeast) & a Compass 6HV
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

And a P51D plank......SSssssshhhhhhh!
BMFA & RCHA Member
[B][COLOR="Blue"]
psilo is offline        Reply With Quote
Old 01-07-2009, 11:53 AM   #5
GCK
Registered Users
Thread Starter Thread Starter
 

Join Date: Mar 2008
Location: Central Wisconsin
Default

I'm on the third hole on the SG90 servo arms (about 13mm from center). Arms are centered at zero stick. The links are at 90 degrees with the servo arms at mid stick. The swash plate is 10mm from the bearing block at mid stick. Plenty of room on the swash to move +/-12 degrees collective pitch. I do have the swash mix for pitch set to limit the pitch to +/- 10 degrees though. Everything I can think of in my setup looks right. Its acting like these SG90 servo's just don't move as much with a given swash setting. If I move the ball link further out on the servo arm it won't be 90 degrees anymore. What servo's are you using?
GCK is offline        Reply With Quote
Old 01-07-2009, 11:54 AM   #6
Ber60
Registered Users
 
Posts: 2,202
 
My HF Map location
Join Date: Jan 2008
Location: Belgium
Default

+1 with Psilo
My balls are (and I am sure I am going to regret this) at about 12mm out of the center

Yep too late
__________________
Anything that flies
Ber60 is offline        Reply With Quote
Old 01-07-2009, 11:57 AM   #7
psilo
Registered Users
 
Posts: 2,574
 
My HF Map location
Join Date: Jan 2008
Location: Cambridge, UK
Default

I had a friend with that problem too!

Seriously though, have you got any Dual Rates setup or have you reduced the travel adjust on your servos? Admittedly, I am using HS65MG's on mine so not the same setup but have SG90's on the belt with 60% across all swash. As you say, sounds like your setup is indeed correct, Very strange!

Edit: Perhaps you could increase the ATV's for the servos to get more throw, although I guess not much different to adjusting the mix?!
__________________
T-Rex 500 ĶBeast, 450 Pro (soon to be ĶBeast) & a Compass 6HV
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

And a P51D plank......SSssssshhhhhhh!
BMFA & RCHA Member
[B][COLOR="Blue"]

Last edited by psilo; 01-07-2009 at 11:59 AM.. Reason: Another thought!
psilo is offline        Reply With Quote
Old 01-07-2009, 11:58 AM   #8
Ber60
Registered Users
 
Posts: 2,202
 
My HF Map location
Join Date: Jan 2008
Location: Belgium
Default

maybe a dumb question but is the travel limit ( I have a futaba so I don't know how it is called on the DX6) at 100%

Yep too late again
__________________
Anything that flies
Ber60 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > E-Sky Helicopters > Belt CP


Belt CP E-Sky Belt CP

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com