Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Walkera Helicopters


Walkera Helicopters Walkera Helicopter Support


Reply
 
Thread Tools Display Modes
Old 03-12-2011, 11:44 AM   #1
Jolly Roger
Registered Users
 
Posts: 673
 

Join Date: Mar 2011
Location: Massachusetts USA
Default WK 2603 TX and 4f200 heli problems

I am having problems with the right stick

I am using stick mode 2 (Left hand throttle and rudder, Right hand elevator and aileron)

The Left stick is perfect! Throttle and rudder work exactly as they should Both in normal mode.

The right stick is totally messed up.

I am using training gear and have given enough power to lift the heli skids off the ground with the training gear still on the cement floor.

In normal mode nothing seems right. If I move the stick to the right the hely moves left sideways?
if I move the stick forward the pitch changes and the heli grounds itself?

other stick movements produce whatever but certinally not the commands you want.

I have tried reversing the ailerons sepeterly. Still wrong. Reversed the elevator sepertly not sure what that did but not what I would expect.

I have read and reread the manual (crappy at best).

I am stumped!
Any thoughts?
JR
Jolly Roger is offline        Reply With Quote
Old 03-14-2011, 06:36 AM   #2
Jolly Roger
Registered Users
 
Posts: 673
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Massachusetts USA
Default Bump

I really need some advice on this guys.

I bought this WK2603 TX "slightly used".

The right stick is totally messed up. I can't get it to work correctly no matter what I do!

Left and Right are supposed to controll the Ailerons.

Forward and Back are supposed to control the Elivator.

PLEASE advise.

I think I may have bought a defective TX but I'm not sure>

HELP please?
JR
Jolly Roger is offline        Reply With Quote
Old 03-14-2011, 05:27 PM   #3
60something
Registered Users
 

Join Date: Aug 2010
Location: Canada
Default

Quote:
Originally Posted by Jolly Roger View Post
I really need some advice on this guys.

I bought this WK2603 TX "slightly used".

The right stick is totally messed up. I can't get it to work correctly no matter what I do!

Left and Right are supposed to controll the Ailerons.

Forward and Back are supposed to control the Elivator.

PLEASE advise.

I think I may have bought a defective TX but I'm not sure>

HELP please?
JR
The first place to look is to make sure the right servos are plugged into the right receiver sockets, then make sure the servos move correctly (reverse or normal) for the function, including the PIT setup

The elevator servo is the one at the front - CH 2

The aileron servo is the one on the right behind the mainshaft, when viewed from the back. - CH 4

The pitch servo is the one on the left behind the mainshaft when viewed from the back - CH 5

Rudder is channel 2, throttle is ch 6 (ESC)

On the 2612 rx, ch 1 is not used.

In my 2801, the channels are set up like this (they may not be the same for the 2603):

Elevator REV
Aileron REV
Throttle NOR
Rudder NOR
Pit NOR
__________________
Schluter Champion, Kavan Allouette, TRex550E-FB, HC500SE, CloneT450pro-4bladed, Blade 400, WK 4F200, Xaircraft X650, and a CB180D, usually in a tree.
60something is offline        Reply With Quote
Old 03-15-2011, 12:26 PM   #4
Jolly Roger
Registered Users
 
Posts: 673
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Massachusetts USA
Default Hi Old guy,

Actually I'm only a couple of years behind you.

I printed your post and I will check wiring as soon as I get home.

Brand new 4F200 and "slightly used" 2603 TX.

I think I got a bad TX as none of the adjustments I have made to the TX work at all.

Or am I just stuped and don't know how to check a CP heli?
That might be the case as well But,,,,,
IF you give a right Aileron command should that change the pitch so the heli is actually blowing air UP insted of DOWN?

I can't even get the bird to lift off the ground any more at full throttle.

I think I got a bum radio.

Anyother thoughts would be greatly appreicated.

JR
Jolly Roger is offline        Reply With Quote
Old 03-15-2011, 05:54 PM   #5
Jolly Roger
Registered Users
 
Posts: 673
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Massachusetts USA
Default

60something,

ALL SERVOS are connected exactely as you said..


Guys,

I really need some help configuring this TX!
The seller swares it's in perfict working order(of coarse) and so far is refusing a refund.
I swear it's F**ked up!
The heli won't even leave the ground with a wopping 1 1/4 oz homemade training gear attached, unless I happen to give it some right aileron than it will practely try to invert to the left.

I am getting SO tired of wasting time and brain damage trying to figure this out!

Please I need help.

Welkera.com has been down for days so I can't even solicit help from the manufacture.

Please advise how to set this up or prove that it's defective.

Thank you,
JR
Jolly Roger is offline        Reply With Quote
Old 03-15-2011, 06:58 PM   #6
Blayd
Registered Users
 
My HF Map location
Join Date: Jan 2011
Location: Over The Hills and Far Away
Default

You have 2 dip switches on the Rx I believe, one is for "WK" and "ADJ", the other is pitch "+" and "-". Make sure the pitch switch is towrds the "+". I dont have the 4f200, I have the V400, but in the 2603, the servo settings are...all servos are NORM, and a three servo swash setting. "E" at the top.
__________________
Trex700N2E
Trex500ESPTT(PRO head and Tail )
Trex500ESP (Belted)
HC500SE ....GO TEAM FLYBAR!
Blayd is offline        Reply With Quote
Old 01-16-2012, 10:38 AM   #7
sancakmodel
Registered Users
 

Join Date: Jan 2012
Location: turkey
Default i have a big problem

hi,
i have walkera 4f200 and walkera airwolf200sd3,

and i have a bigproblem for theese helicopter.

i have WK2603 transmitter for 4f200 and i have dEVO8 transmitter for airwolf200sd3.


I'm having the same problem as the two helicopters

Correct operation of the helicopter swashplate s

but when i flying theese helicopter, elleron and elevator command are not correctly.

right stick is wrong commands,

if i goes forward to right stick of transmitter, helicopter goes to right elleron,
if i goes rigt to right stick of transmitter , helicopter goes to forward

so right stick working to cross,

i dont undarstand. why is the doing it.

Do you have a general problem with these models
Do you help with this would be
best regard
thank you
sancakmodel is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Walkera Helicopters


Walkera Helicopters Walkera Helicopter Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com