Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 03-18-2012, 12:11 AM   #1
trex_junkie
Registered Users
 

Join Date: Mar 2012
Location: lima,Oh
Default lost my negative pitch today HELP!!!!

So I was flying my mcpx today learning to hover its a v2 by the way. Well after a couple of crashes i lost my negative pitch when i go inverted it just glides to the bottom and thats it. I checked the main gear its on fine didn't change any settings on the radio. Anyone have this problem?
trex_junkie is offline        Reply With Quote
Old 03-18-2012, 05:54 AM   #2
Talesin
Registered Users
 
Posts: 2,149
 
My HF Map location
Join Date: Jan 2012
Location: Kansas City, MO
Default

Made sure your main motor plug is pushed all the way in? Wires at the motor-side haven't been damaged?

Checked to confirm that the blades are going negative-pitch with TH on?
Have you levelled your swash and set up zero pitch at mid stick (apparently, a number come with far too much positive pitch out of the box, robbing negative throw)?
Have you used your pitch travel adjusts on the TX to get equal pitch at each end of the throttle/pitch throw?
Made sure that your swash hasn't popped apart, and that your main shaft and blades aren't cracked?
How many flights do you have on your current main motor?

If not the main motor connector coming loose a bit, first guess would be a combination of an older motor, battery pack wear and too much positive pitch set as zero. Last would be a (correctable in 15-20 minutes) problem, and the other two are just normal wear for these. Also a few of the crashes might have smacked an older engine around enough to just give up the ghost (which wouldn't show upright if you had too much pos. pitch, and cause a slow glide down as you can't apply as much negative as positive).

I guess the next question is how fast it glides down. A slow drop like the motor is trying but doesn't have enough power to spin the blades fast enough, or dropping like a rock (like if the motor just cuts out).
__________________
Blade: mCX2, mSR, mSRX, Nano-CPX, 2x mCPX (v1), mCPX-BL, 120SR, 450 X
Spektrum DX8, DX6i
Talesin is offline        Reply With Quote
Old 03-18-2012, 11:40 AM   #3
SuperBee364
Registered Users
 
Posts: 1,064
 

Join Date: Jan 2008
Default

Try this:
SuperBee364 is offline        Reply With Quote
Old 03-18-2012, 03:16 PM   #4
trex_junkie
Registered Users
Thread Starter Thread Starter
 

Join Date: Mar 2012
Location: lima,Oh
Default

Well its on my V2 its pretty new just a few flights on it and had a few crashes on attempting inverted flight my swash is fine motor gear is wear its suppose to be just doesn't make sense how i just all of sudden loose negative pitch
trex_junkie is offline        Reply With Quote
Old 03-18-2012, 04:04 PM   #5
SuperBee364
Registered Users
 
Posts: 1,064
 

Join Date: Jan 2008
Default

My stock v2 came from the factory with way too much positive pitch.

Still highly recommend you take the time to go through that video. There's a *very* good chance it'll solve your problem.
SuperBee364 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com