Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-21-2011, 01:58 AM   #11
ChrisH
HF Support
 
Posts: 11,368
Thread Starter Thread Starter
 

Join Date: Aug 2007
Location: CA
Default

Quote:
Originally Posted by isogloss3d View Post
Thanks for the tips Chris. I cleaned all 3 servos and the moderate shakes after 70 flights are now gone. The Aileron contacts were the dirtiest. Now that the major shakes are gone I'm noticing a very slight tail bob towards the last 3rd of my flight. Who knows, it could be something else entirely. Thanks again.

-Iso
E-Flite batteries?

Most likely low headspeed. Same thing happens to larger helis -- low headspeed and stiff dampening (especially on FBL) leads to up-and-down tail bobble. Nothing you can really do if you're running 100% flat ... just lets you know it's almost time to land
ChrisH is offline        Reply With Quote
 




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com