Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCX


mCX Blade (eFlite) Micro CX Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 02-22-2012, 03:58 AM   #1
Gimpdiggity
Registered Users
 
Posts: 126
 

Join Date: Feb 2012
Location: United States
Default mCX Won't Stop Turning Clockwise...

Hi guys. I need some help.

A little background to get to where we're at now. I was trying to get a little more speed out of my mCX, and I tried to adjust the servo linkage. After doing that, I was getting some odd movements with the bird. I was able to trim most of it out, but not all of it, and as I was getting ready to set it down I had a pretty nasty crash. I got it throttled down, however, and didn't do a ton of damage.

Now, I'm embarassed by this...but when I was taking the servo linkage back off to adjust it back to the stock setting, I managed to break the ball off of the swash. So I went and got a new swash from the store, and of course, that one had something wrong with one of the balls on it that connects to the rotor blade. I was able to pry it apart and take the good part of the other broken swash and get that on there, effectively making one okay swash out of two bad ones. Then, of course, in the process of putting it all back together I broke a ball of of one of the lower blades.

So back to the store I went to get the new lower blades.

Got everything mounted back up. Got the servo linkages installed and measured the same length as each other.

Now, when I get the bird up in the air, it's really squirrely. I'm using a DX6i, and the settings on the TX weren't adjusted at all after doing all of this.

I can see the tail noticeably twitching while it's hovering. Speaking of hovering, it has a pretty noticeable clockwise yaw. I can get that trimmed out...but here's the kicker.

When I give it rudder commands to go clockwise, it goes clockwise. When I give it rudder commands to go counter clockwise, it spins counterclockwise VERY slowly for about two revolutions, then just starts turning clockwise again all on it's own. After it does this once, no matter what I do with the rudder control, the bird will only turn clockwise.

I took it all apart again to make sure nothing was binding, and then put it back together. I charged up all of my batteries and tried each one. I rebinded. Nothing I do has done anything at all to make the situation any better.

I've only had this heli about two weeks now. I'm getting ready to just take it back and buy the mCX2.

Any suggestions before I do that would be great.

Thanks.
Jeff


***EDIT***

I just took the entire thing apart. I didn't find any hairs or anything like that binding it up. The lower rotor did seem to spin a bit more freely after I put it back together.

I tried it out again, and it seemed to be working a little bit better, but the counterclockwise pirouette was still MUCH slower than the clockwise one.

After just a couple of minutes, it was back to only wanting to turn clockwise. No trimming would make it stop. I continued to fight it until the heli seemed like it was running out of juice, so I gave up for this evening.

Resting voltage on the LiPo I was using, according to my AC680 charger, was 3.85 volts. I don't think that's anywhere near a dangerously low voltage, so I don't think the batteries are the culprits.

Sorry to ramble on...I'm tired, and frustrated.
__________________
In Life, Try to be the Kind of Person Your Dog Thinks You Are...

Blade: mCX2, mCP X V2, 450 3D
DX6i
Gimpdiggity is offline        Reply With Quote
Old 02-22-2012, 10:53 AM   #2
Mega Stumbler
Registered Users
 
Posts: 509
 
My HF Map location
Join Date: Aug 2011
Location: Kansas
Default

I have seen this twice on a mxc2. Replacing both main motor FETs fixed the problem on both of them. I think one was damaged during a crash. Even though it showed no visible signs of damage I think the power output was reduced.

Sent from my DROIDX using Tapatalk
__________________
Owner/operator of MegasMicros.com - I am on Helifreak as a hobbyist not as a salesman. Please help me respect helifreak and keep all sales talk off forum.

If its a blade and < 450 its in my hangar.
Mega Stumbler is online now        Reply With Quote
Old 02-22-2012, 11:04 AM   #3
burnoutboy
Registered Users
 
Posts: 1,664
 

Join Date: Jan 2012
Location: Baltimore, MD
Default

Is the FET built into the motor itself or the board? I understand the concept of a FET but wasn't aware you could swap just the FET on the mCX2 motors? I was under the impression you had to swap the motor itself out.
__________________
DSMX DX6i, MH mCX2, mSR, BL RKH mSR X, 3 X mCP X v.1 (one stocker, one destined for DBL, one destined for DBL mini130X), Lachmund mQX

PM me for your soldering and mSR X BL build needs.
burnoutboy is offline        Reply With Quote
Old 02-22-2012, 12:03 PM   #4
Mega Stumbler
Registered Users
 
Posts: 509
 
My HF Map location
Join Date: Aug 2011
Location: Kansas
Default

The fet if on the board best to the motor pins. If you have not tried a motor I would do that first.

Sent from my DROIDX using Tapatalk
__________________
Owner/operator of MegasMicros.com - I am on Helifreak as a hobbyist not as a salesman. Please help me respect helifreak and keep all sales talk off forum.

If its a blade and < 450 its in my hangar.
Mega Stumbler is online now        Reply With Quote
Old 02-22-2012, 01:35 PM   #5
Gimpdiggity
Registered Users
 
Posts: 126
Thread Starter Thread Starter
 

Join Date: Feb 2012
Location: United States
Default

Thanks for the help, guys.

I don't really want to spend money on a new motor when the heli is still in it's return window...so...

It's getting sent back today!!

I ordered an mCX2 this morning, though, with overnight shipping...so I should have that up and running tomorrow.

In retrospect, I should have gone with the mCX2 in the first place...I went with the mCX to save myself a few bucks (the RTF package on Amazon was only $79.99 at the time) but I didn't know that it didn't have the same level of performance as the mCX2. I thought the mCX2 just had a different body on it...I didn't know about the different swash settings and the slightly more powerful motors.

Oh well, live and learn...that's what hobbies are all about...breaking stuff and spending money!!!
__________________
In Life, Try to be the Kind of Person Your Dog Thinks You Are...

Blade: mCX2, mCP X V2, 450 3D
DX6i
Gimpdiggity is offline        Reply With Quote
Old 02-22-2012, 04:51 PM   #6
Pfloyd
Registered Users
 
Posts: 6,514
 
My HF Map location
Join Date: Mar 2010
Location: Mascoutah, Il USA
Default

Take both servo rods off. Get a good ruler..the stock factory length is 37mm....you problem sounds like one of the motors is going out....check to make sure the motor pinion gears a meshing properly with the white gears.
Then rebind the heli and see if that works. The servo rod ends only go on the swash balls one way...so all adjustments are made in 1 turn increments..you can see by looking at the servo rod end that one side is smaller than the other...the larger size fits on the swash balls. On the links, there should be a dimple on the long part..it should face outwards. Hope this helps.
__________________
MCX-S300-MCX2-MSR-NQX-180QXHD-CB105-Syma S107-Syma X5C-Syma S109-Syma X1-Syma X3-ProtoX-Hubsan X4-WL Toys v222-WL Toys 252-WL Toys 272-Syma X5c-Cheerson CX-10-Others!-DX6i


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
USAF RETIRED 1968-1988 Vietnam Veteran
Pfloyd is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCX


mCX Blade (eFlite) Micro CX Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com