Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopters > Newbies: Tips and Information


Newbies: Tips and Information Section of HF, specifically for Passing along info to newcomers to the hobby. Setup, tweaking, orientation practice, etc.


Reply
 
Thread Tools Display Modes
Old 03-12-2012, 12:53 AM   #1
eldergrenn
Registered Users
 

Join Date: Mar 2012
Location: Australia
Default Trex 450 Pro

Hello to all

I am new to helicopters and predicably I have made some mistakes that have led me to email the experts.

1/ After a minor take off accident i damaged the gears that drive the rear tail rotor. These parts were easy to get and fit and after a test run the helicopter was ready to go.

2/ I then mistakenly left the helicopter battery connected and proceeded to surf the controller a Radio Link T6EHP-E just to see what features it had. Following the manual I pushed together the data input buttons in to open the menu to view the screens such as REVR, EPA, TRIM and N-TH by pressing the select button. During selection of the features the helicopter powered up itself instantly to 100% which then led to another crash. This time the main drive gear stripped which again was easy to get and fit. Hoping all was ok i installed the battery, turned on the controller but unfortunately I now cannot function the throttle and the throttle hold switch does not work.

3/ I have attempted to follow the setup to ensure all is back to original including the REST data reset function and I did discover that the STICK setting was on mode 1 instead of the standard mode 2, I then put it back into mode 2 but this did not assist.

4/ The helicopter will go through a series of beeps and tunes once powered up and last night just like the original incident the beeps went to constant beep and then powered up to 100%.

I hope you can assist me as I am lost to sort this matter out, i bet it is a simple thing.

Thank you for your assistance on advance

Glenn Elder
eldergrenn is offline        Reply With Quote
Old 03-12-2012, 06:50 AM   #2
avrflr
Registered Users
 

Join Date: Dec 2011
Location: Perth, Australia
Default

It sounds like the ESC is going in to setup mode, which it will do if the throttle is up when you plug in the battery. Try reversing the throttle channel.
avrflr is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopters > Newbies: Tips and Information


Newbies: Tips and Information Section of HF, specifically for Passing along info to newcomers to the hobby. Setup, tweaking, orientation practice, etc.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com