Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 05-07-2012, 08:45 PM   #1
vanillatony
Registered Users
 
Posts: 86
 

Join Date: Oct 2011
Location: Rancho Cucamonga, CA
Default Tail won't hold

Tail won't hold after a light crash. Wants to drift right. Tried a rebind several times. Put on new tail. Everything looks good on it. Cant figure it out, any suggestions?
vanillatony is offline        Reply With Quote
Old 05-08-2012, 09:46 PM   #2
Ampdraw
Registered Users
 

Join Date: Nov 2008
Location: Sydney, Australia. We live inverted.
Default

Quote:
Originally Posted by vanillatony View Post
Tail won't hold after a light crash. Wants to drift right. Tried a rebind several times. Put on new tail. Everything looks good on it. Cant figure it out, any suggestions?
If it's just a slow drift, and you have checked all your flight mode rudder trims I'd say it's vibe related.

V2 board per chance?

Amp
Ampdraw is offline        Reply With Quote
Old 05-08-2012, 09:47 PM   #3
koi-fish
Registered Users
 
Posts: 5,647
 

Join Date: Jan 2012
Location: Houston (League City), TX
Default

Quote:
Originally Posted by vanillatony View Post
Tail won't hold after a light crash. Wants to drift right. Tried a rebind several times. Put on new tail. Everything looks good on it. Cant figure it out, any suggestions?
bent shaft on tail motor maybe? What did you hit when you went down?

had this happen to me before
__________________
/ 130x, 180cfx, 300x, Gaui X2, X3, X4 II, x5, 450x, 550X, DX9, 07 Harley Road King/04 Sportster
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


"It's not getting any smarter out there, you have to come to grips with stupidity and make it work for you" - Frank Zappa
koi-fish is offline        Reply With Quote
Old 05-08-2012, 11:08 PM   #4
motoracer5
Registered Users
 

Join Date: Mar 2012
Location: Nakusp
Default

Chewed up main gear is usually the culprit for me. V1 or V2
motoracer5 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com