Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > SR


SR Blade Helicopters (eFlite) SR


Reply
 
Thread Tools Display Modes
Old 06-17-2012, 05:29 AM   #21
olemil
Registered Users
 
Posts: 1,702
 

Join Date: Jan 2011
Location: Michigan
Default

/\ /\ +1. I didn't even think of stripped servo gears, great idea Danno. My last crash left me two servos with stripped gears and one I didn't even realize until I was re-building. You should be able to tell by moving the servo arms by hand (power off) and if there are any 'free' spots you will need to replace either the gears or complete servo. You should be able to see if your swash plate is separated by watching the two halves while cycling the throttle stick from low to high stick. Any chance you could make a short video of the head and linkage while moving through the entire pitch range, it would be very helpful. Good luck.
__________________
Beam E4-(Scorpion HK-2221-6,11T pinion, Phoenix 60, HS65MG cyclics, GY520),120SR, Trex 250SE (stock) MH bottom plate,GY-520,Futaba R6106, MCPx,DX7se,Futaba 8FG Super, DJI Flamewheel F450 w/Naza/GPS, HPI Vorza on Futaba 4PL.
olemil is offline        Reply With Quote
Old 06-17-2012, 10:19 AM   #22
Orangephoner
Registered Users
Thread Starter Thread Starter
 

Join Date: Jan 2012
Location: Southern utah
Default

So i checked everything this morning. Servo gears have all of there teeth. The swash plate is not separated as i did the glue your swash plate mod a few weeks ago. my phone is being dumb so i cant send any videos.....BUT as i was looking it over this morning running the throttle up and down i noticed two things. so first i noticed that one blade stops changing pitch for the last quarter inch of throttle and the other doesnt. AND all of the sudden the servos started twiching like i would throttle up and they wouldnt move and then all the sudden they would jump up to position. they have never done that before. which would explain the high throttle but no hovering untill it leaps into the air...so now the question is what causes servos to twitch like that???
thank you for all your help BTW. you are really saving me and keeping me sane
Orangephoner is offline        Reply With Quote
Old 06-17-2012, 10:23 AM   #23
dcarboni
Registered Users
 
Posts: 756
 

Join Date: May 2012
Location: usa Indiana Ft wayne
Default

try a rebind and see if that helps. also did you check blades on both sides or same side it does make a difference?

Last edited by dcarboni; 06-17-2012 at 10:27 AM.. Reason: added
dcarboni is offline        Reply With Quote
Old 06-17-2012, 11:07 AM   #24
Orangephoner
Registered Users
Thread Starter Thread Starter
 

Join Date: Jan 2012
Location: Southern utah
Default

wow.....hahahhaahhahhaha the simple things that cause so much stress and anger....i rebound it and changed the batts in my transmitter and she flys like nothing ever happened... thank you all for your help. you really saved me.
Orangephoner is offline        Reply With Quote
Old 06-17-2012, 11:13 AM   #25
dcarboni
Registered Users
 
Posts: 756
 

Join Date: May 2012
Location: usa Indiana Ft wayne
Default

cool, now go flying!!!!
dcarboni is offline        Reply With Quote
Old 06-17-2012, 12:52 PM   #26
olemil
Registered Users
 
Posts: 1,702
 

Join Date: Jan 2011
Location: Michigan
Default

Nice!! Congrats and like said above you can go enjoy some flight time!!!
__________________
Beam E4-(Scorpion HK-2221-6,11T pinion, Phoenix 60, HS65MG cyclics, GY520),120SR, Trex 250SE (stock) MH bottom plate,GY-520,Futaba R6106, MCPx,DX7se,Futaba 8FG Super, DJI Flamewheel F450 w/Naza/GPS, HPI Vorza on Futaba 4PL.
olemil is offline        Reply With Quote
Old 06-17-2012, 01:05 PM   #27
GSPI
Registered Users
 
Posts: 3,286
 

Join Date: May 2012
Location: CLE
Default

Excellent!! Get going and have a great flying day!
__________________
OXY Heli and Lynx Heli Innovations Team Pilot
SilentDRC.net -The Order of Brushless Witnesses

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

GSPI is offline        Reply With Quote
Old 06-17-2012, 10:51 PM   #28
DKS_ONE
Registered Users
 
Posts: 4,032
 
My HF Map location
Join Date: Mar 2010
Location: Edmonton Alberta, Canada
Default

Awesome! Glad it's fixed, hope you pounded out a few packs . Electronics can be stupid, but it's good you have some experience here on your side.
__________________
Danno
Fusion 50, 600 conversion, 600mx motor, CC 80HV ESC with cap pack, Jolly Bee canopy
UMX Carbon Cub SS
DX8
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
DKS_ONE is offline        Reply With Quote
Old 09-11-2013, 09:21 AM   #29
oldbob76
Registered Users
 

Join Date: May 2013
Location: Chandler, AZ
Default maybe motor or esc?

I'm glad that you got that sorted out. I have the same problem and none of these fixes work. Spooling up to get to head speed is OK, but when I go into transitional lift, the first couple of inches are fine, then the heli just shoots up into the air for about 20 feet. Pulling off collective and then throttle hold gets it down, but the next flight is the same. I've played with the pitch curve, but it still does it no matter what the settings are. Any more suggestions?

Last edited by oldbob76; 09-11-2013 at 09:24 AM.. Reason: misspelling
oldbob76 is offline        Reply With Quote
Old 09-11-2013, 10:24 AM   #30
Air Wolf
Registered Users
 
Posts: 246
 

Join Date: Oct 2012
Location: Myrtle Beach, SC
Default

What does your pitch curve look like? It sounds like you might have a big jump for position 0 to position 2 or 3. I set mine to 42-50-65-75-100. I also set my throttle curve a little different then most. I set it 0-95-95-95-100. That way the blade rpm remains fairly constant and altitude is controlled by making small changes it the collective. Most of the fbl fliers use this method and I have had good results with it. My SR would not hover for very long at one altitude, it was constantly going up or down and I was constantly chasing it with the throttle. It is much more stable now and is only limited by the small motor that it came with. One other thought, check your feathering shaft. It could be bent a little and causing a bind that releases and makes the heli jump. I usually find mine bent after any crash.
__________________
HK 450 FBL
Blade SR
HK250GT
Air Wolf is offline        Reply With Quote
Old 09-12-2013, 08:17 AM   #31
jbilliter
Registered Users
 

Join Date: Feb 2012
Location: Columbus, OH
Default

Check that the main shaft has no up-down play. That will make the SR "jump" into the air upon takeoff, because when the shaft is pulled up, it gives an instant increase change in positive pitch
__________________
NCPx+ Mild BL, MCPx, EXI 450pro FBL ZYX-S2, HK250GT DFC ZYX-S2, T-Rex 250 DFC ZYX-S2, MSR, DX6i
jbilliter is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > SR


SR Blade Helicopters (eFlite) SR

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com