Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > MSH Brain FBL Unit


MSH Brain FBL Unit MSH Brain Support Forum


Reply
 
Thread Tools Display Modes
Old 08-26-2012, 10:25 AM   #1
Trex-mad
Registered Users
 

Join Date: Apr 2008
Default MSH brain with align DS650 servo at 333hz

Hi all,

First post on heli freak.

I tried to set up my new msh brain last night in preparation for flying this morning. Everything went great up until I tried to set the frequency of the ds650 tail servo, when I select 333hz the servo fails to operate correctly and only operates on 200hz. This servo should operate at 333hz so I can only assume the brain is outputting the incorrect signal.

Just wondering if anyone else is having a similar problem?

I have had three flights on it today and first impressions are great.

Its fitted to a trex600n by the way.
Trex-mad is offline        Reply With Quote
Old 08-26-2012, 12:09 PM   #2
HighFreq
Registered Users
 

Join Date: May 2004
Location: Italy
Default

Make sure you select 1520/333hz

If the servo fails to operate most probably you set half frame rate 560, not supported by that servo.

In the wizard you have to select the first icon 1520/200 than correct frequency to 333 using the slider.

Corrado
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
HighFreq is offline        Reply With Quote
Old 08-26-2012, 01:35 PM   #3
Trex-mad
Registered Users
Thread Starter Thread Starter
 

Join Date: Apr 2008
Default

Hi and thanks for the quick reply.

I think your right in saying I selected the wrong icon for the tail the first time I set it up as I have now gone back to the software and selected the correct icon.

I have done what you said and i can indeed select the 1520/200hz for the tail and then select the 333hz via the slider. However when I leave the page and return the slider has defaulted back to 200hz. Also if I close the software and reboot the tx and heli and software then it defaults back to the 200hz. Is this normal ? As I would have expected the software to read 333hz when re opening.

Thanks for your help.
Trex-mad is offline        Reply With Quote
Old 08-26-2012, 02:45 PM   #4
Lynx.1677
Registered Users
 
Posts: 924
 
My HF Map location
Join Date: Mar 2009
Location: Camberley, Surrey
Default

I have this issue using the DS520. I set 1520 pulse and 333mhz but when I got back into the Brain software it has changed to 760 pulse 333mhz!
__________________
Trex 500 Pro
MCPx v2
130X
DX7
Lynx.1677 is offline        Reply With Quote
Old 08-26-2012, 04:44 PM   #5
m.rik
Registered Users
 

Join Date: Dec 2005
Location: ITALY
Default

Instead in the Wizard, try to read the value in the Advanced -> Servos -> Refresh Frequencies -> Tail.
In The Wizard, some parameters are only written in the Brain but not read from (This happen only in the Wizard like precompensations status).
m.rik is offline        Reply With Quote
Old 08-28-2012, 03:01 AM   #6
Otatiaro
Registered Users
 
Posts: 755
 
My HF Map location
Join Date: Oct 2007
Location: France
Default

Quote:
Originally Posted by Lynx.1677 View Post
I have this issue using the DS520. I set 1520 pulse and 333mhz but when I got back into the Brain software it has changed to 760 pulse 333mhz!
Hello,

Yes as the neutral and throws can change a lot between servos, the only parameter I can check to find back the preset is the frequency, so the software detected you were using 333Hz servos and showed it to you by selecting the 333Hz which is 760s.

Should probably make a switch at 1000s neutral, will take a look today.

Thomas.
Otatiaro is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > MSH Brain FBL Unit


MSH Brain FBL Unit MSH Brain Support Forum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com