Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization


Reply
 
Thread Tools Display Modes
Old 09-12-2016, 11:18 AM   #1
rmorse99
Registered Users
 

Join Date: May 2016
Location: lutherville md
Default Blade 450/ Flymentor- Servo's won't center

I have the installation complete, servo's going correct direction for Transmitter lever inputs and correct response from Flymentor when tilting the Heli. When attempting to center the servo neutral, there is no response from the servo for positive or negative values, servo lever doesn't move. This happens for Ail, Pitch and Elev. servos. I got out a new servo and installed on bench, again no response when trying to center servo neutral. Any ideas?
rmorse99 is offline        Reply With Quote
Old 12-01-2016, 10:51 PM   #2
pril250
Registered Users
 
Posts: 5,882
 

Join Date: Aug 2008
Location: London, Uk
Default

It is a long time since I messed with FM are you trying to do this whil FM is active, meaning turned on?
__________________
T-Rex600-ICE100,WR10ABEC,Scorp4025-1100+17T,Kasama head,QUK Swash CNC Tail,G-Force blocks,3152,DS760+BLS251,DX7+AR7000,FM.
Blade400
-CC ICE50,Scorp2221-8+12T,Sonix Head&Tail,5A BEC,HS65HB,Quark+3500G,AR7000,Align Carbon blades,TRex500 Skids,Flymentor.
pril250 is online now        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2016 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.