Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > 130X


130X Blade 130X Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 01-28-2013, 03:28 PM   #1
soupy01833
Registered Users
 

Join Date: May 2006
Location: Mass
Default 130x tail wag

So i have had may 130x since it was released. Never really had much issues beyond the gears. Well lately I have a bad tail wag. really fast wag. I tried many things without success. Funny thing is it only occurred outside in the cold. inside it flew great. well today i decided to clean the tail servo and presto the tail is solid again.

so if anyone cannot track down their wag please try cleaning your tail servo.
soupy01833 is offline        Reply With Quote
Old 01-28-2013, 04:37 PM   #2
renefigueroa
Registered Users
 

Join Date: May 2012
Location: North Carolina
Default

Awesome, glad you figured it out this quick. One of mine fought me over a month before it gave it up and flying sweet again.
renefigueroa is offline        Reply With Quote
Old 01-28-2013, 06:20 PM   #3
GLHS592
Registered Users
 
Posts: 423
 

Join Date: Aug 2012
Location: Centerville, TN
Default

Mine is starting to wag some. Maybe it's all the time it has spent in the dirt.
__________________
Kevin I.
Poor abused mCP x
Blade 130x
Dx6i
GLHS592 is offline        Reply With Quote
Old 01-28-2013, 06:59 PM   #4
Beebad
Registered Users
 

Join Date: Nov 2008
Location: Jupiter, Fl.
Default

I'm gonna have to try cleaning the servo! My tail was getting jumpy so I checked out the moving parts and found the stock slider was ready to come apart. I installed a micro heli slider and alot of the wag is gone but not all of it. Next, I'll clean servo, then if that does'nt work I guess I'll try lowering the gain. If that does'nt work I'll step on it!

Just kidding, I'm having a great time with it!
__________________
Alcohol doesn't solve any problems but, neither does milk.
Beebad is offline        Reply With Quote
Old 01-29-2013, 02:30 PM   #5
Chris g.
Registered Users
 
Posts: 857
 

Join Date: May 2012
Location: Texas
Default

What are you using to clean the servos and how? My tail was fine until i put the HPO8 motor in and now i have a tail wag. Its not a fast tail wag it just tends to go side to side. I have tried lowering and upping the gain but it doesn't seem to help it too much. I changed out my tail pitch slider help some but not all. I placed an order for an upgraded pitch slider and HH is sending me a new tail servo free..
Chris g. is offline        Reply With Quote
Old 01-29-2013, 02:39 PM   #6
koi-fish
Registered Users
 
Posts: 5,789
 

Join Date: Jan 2012
Location: Houston (League City), TX
Default

Quote:
Originally Posted by Chris g. View Post
What are you using to clean the servos and how? My tail was fine until i put the HPO8 motor in and now i have a tail wag. Its not a fast tail wag it just tends to go side to side. I have tried lowering and upping the gain but it doesn't seem to help it too much. I changed out my tail pitch slider help some but not all. I placed an order for an upgraded pitch slider and HH is sending me a new tail servo free..
I use DeOxit, unscrew the mechanics, and use a q-tip on the board and brushes. Be sure to only go in the direction of the brushes our you will ruin them!

Some guys just spray DeOxit in the servo without disassembling, but I find this cleans them better.
__________________
/ 130x, 180cfx, 300x, Gaui X2, X3, X4 II, x5, Gob 380 (on order), 450x, 550X, DX9, PL8, 07 Harley Road King/04 Sportster
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


"It's not getting any smarter out there, you have to come to grips with stupidity and make it work for you" - Frank Zappa
koi-fish is online now        Reply With Quote
Old 01-29-2013, 03:05 PM   #7
Chris g.
Registered Users
 
Posts: 857
 

Join Date: May 2012
Location: Texas
Default

Quote:
Originally Posted by koi-fish View Post
I use DeOxit, unscrew the mechanics, and use a q-tip on the board and brushes. Be sure to only go in the direction of the brushes our you will ruin them!

Some guys just spray DeOxit in the servo without disassembling, but I find this cleans them better.
Do they carry DeOxit at radio Shack or Home Depot? I might as well try to clean this one before i put the new one in.
Chris g. is offline        Reply With Quote
Old 01-29-2013, 03:18 PM   #8
Chris g.
Registered Users
 
Posts: 857
 

Join Date: May 2012
Location: Texas
Default

Would rubbing alcohol work as well?
Chris g. is offline        Reply With Quote
Old 01-29-2013, 04:13 PM   #9
ssdaly
Registered Users
 
Posts: 51
 

Join Date: Apr 2012
Location: USA, Massachusetts
Default

I have used Electical contact cleaner with good results. Sears and Radio Shack and HD will have it. No body seems to stock Deoxit around here.
__________________
I spend half My life looking for the other half of My life.
ssdaly is offline        Reply With Quote
Old 01-29-2013, 04:16 PM   #10
jrwalte
Registered Users
 
My HF Map location
Join Date: Dec 2011
Location: Atlanta
Default

Radio Shack does appear to stock Deoxit locally - at least all the stores in my area do.

http://www.radioshack.com/product/in...ductId=2104746
jrwalte is offline        Reply With Quote
Old 01-29-2013, 04:36 PM   #11
Chris g.
Registered Users
 
Posts: 857
 

Join Date: May 2012
Location: Texas
Default

Radio Shack does have it in stock here also. Going to pick some up on my way home and will try it. I'll keep you guys updated on whether it fixed my tail wag or not.
Chris g. is offline        Reply With Quote
Old 01-29-2013, 06:23 PM   #12
soupy01833
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2006
Location: Mass
Default 130x tail wag

The dexoit will last a long time rubbing alcohol does not clean for very long.
soupy01833 is offline        Reply With Quote
Old 01-30-2013, 09:18 PM   #13
Chris g.
Registered Users
 
Posts: 857
 

Join Date: May 2012
Location: Texas
Default

Well cleaning the servo helped the tail wag alot.. Just waiting for the upgraded pitch slider to show up and I'll be good.
Chris g. is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > 130X


130X Blade 130X Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com