Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite)


Blade Helicopters (eFlite) Blade Helicopters (eFlite) CP, CX, mCX CX II, CX III. and others


Reply
 
Thread Tools Display Modes
Old 01-13-2009, 10:36 PM   #1
kelley
Registered Users
 
Posts: 138
 

Join Date: Apr 2008
Location: Arizona
Default CP Pro 2

Any word on a release date on the CP Pro 2?
kelley is offline        Reply With Quote
Old 01-14-2009, 10:56 PM   #2
bus kid
Registered Users
 
Posts: 69
 
My HF Map location
Join Date: Sep 2008
Location: 605 & 91 interchange 90701
Default

http://www.horizonhobby.com/Products...rodID=EFLH1350

"Item coming soon." "Due Early February" Notice they dont say what year.



__________________
Fly it like it's your little brother's

www.TheSamba.com .

bus kid is offline        Reply With Quote
Old 01-15-2009, 12:04 PM   #3
shwillbur7
Registered Users
 

Join Date: Nov 2008
Location: louisisana
Default

http://www.helidirect.com/product_in...oducts_id=7931 this site hade them with a december 25th release date and it seemed like that hade them at one time. now they are "sold out" so i dont know.
shwillbur7 is offline        Reply With Quote
Old 01-18-2009, 01:58 PM   #4
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

yeah, it seems like they keep pushing it back. It was fist posted in june 2008 saying "due early july" I guess this is not a correct statement.
helidude3 is offline        Reply With Quote
Old 01-18-2009, 09:31 PM   #5
CHCHGSR
Registered Users
 
Posts: 202
 

Join Date: Nov 2006
Location: The Garden City, Christchurch, NZ
Default

Me too ... love to know when/if it was getting released... i'll tempt fate by upgrading my CP PRO as did John Adams of Spektrum in RCHeli Mag issue 11 pg 106

He uses
Micro Heli Swash (MHECP012B)
GWS Tail and 3x2 PROP (EDP-50XC, EP1280)
E-Flite 370 Brushless 4100Kv
CC 10
E-flite Gyro
S60 Digital servos
AR6100
Thunder Power 11.1v 730

His DX7 setup's below -

http://www.spektrumrc.com/Articles/A...ArticleID=1688

in gonna give it ago...unless the freaks tell me otherwise
__________________
I Spent all my money on Helis, Booze & Chicks... The rest i wasted.....
Phoenix FP | Trex 450 w Z-Power 3800, 65MG's, GY401 - DS520 | Stock Trex 500 CF, AR6100, AR6200, DX7 : Phoenix Sim
New Zealands Dedicated RCForum : www.rcforums.co.nz
My Youtube http://www.youtube.com/user/CHCHGSR

Last edited by CHCHGSR; 01-19-2009 at 02:27 AM.. Reason: part #'s incorrect
CHCHGSR is offline        Reply With Quote
Old 01-19-2009, 01:01 AM   #6
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

I have that exact setup on my blade cp pro. The only thing I am missing is the TP lipo. I got a 1320 instead of a 730 though. I just ordered it on ebay today. Also I that setup is missing a separate tail esc. I want to get that too. They say it allows the gyro to do its job a lot better. Anyway with that setup my blade cp pro (3) flys great. It seems a lot more stable and powerful compared to the stock setup. I used a castle link to further program my phoenis esc too. If you decide to do the upgrade, I have a website dedicated to it (bladecpupgrades.co.nr) and have wrote about it in detail. (I use the dx6i though.)
helidude3 is offline        Reply With Quote
Old 01-21-2009, 11:31 AM   #7
WickedDragon
Registered Users
 
Posts: 1,034
 
My HF Map location
Join Date: Jul 2007
Location: Pittsburgh
Default

Quote:
Originally Posted by CHCHGSR View Post
Me too ... love to know when/if it was getting released... i'll tempt fate by upgrading my CP PRO as did John Adams of Spektrum in RCHeli Mag issue 11 pg 106

He uses
Micro Heli Swash (MHECP012B)
GWS Tail and 3x2 PROP (EDP-50XC, EP1280)
E-Flite 370 Brushless 4100Kv
CC 10
E-flite Gyro
S60 Digital servos
AR6100
Thunder Power 11.1v 730

His DX7 setup's below -

http://www.spektrumrc.com/Articles/A...ArticleID=1688

in gonna give it ago...unless the freaks tell me otherwise
Should work nicely. I have a somewhat similar setup.

I would instead recommend......
HS-55 servos for cyclic (tough and cheap $14 @ HeliDirect)
E-flite swashplate (have both, like the E-flite)
Medusa or Feigao BL for the tail (don't scrimp here! Check the forums for KV)
Logictech 2100T Gyro (given the price difference)

A head modification or two and you're way beyond a BCPP2!
__________________
Doug Bonham, WickedDragonRC
Gravity isn't just a good idea, it's the LAW!
TRex450SE DFC; TRex450Pro DFC; TRex500 DFC Pro; TRex600N DFC's; CHP-TRex600eDL DFC; Trex700e DFC Pro
WickedDragon is offline        Reply With Quote
Old 01-21-2009, 12:35 PM   #8
harrier808
Registered Users
 
Posts: 146
 

Join Date: Dec 2008
Location: Honolulu, Hawaii
Default

1-21-2009. i emailed Horizon Hobby last night. they now have an ETA of early march for the CP Pro 2.
harrier808 is offline        Reply With Quote
Old 01-21-2009, 06:55 PM   #9
CHCHGSR
Registered Users
 
Posts: 202
 

Join Date: Nov 2006
Location: The Garden City, Christchurch, NZ
Default

Arrrgh, I just cant get rid of the "Sticky Collective" issues - I have purchased 3 different brand of head's now.... any ideas?
__________________
I Spent all my money on Helis, Booze & Chicks... The rest i wasted.....
Phoenix FP | Trex 450 w Z-Power 3800, 65MG's, GY401 - DS520 | Stock Trex 500 CF, AR6100, AR6200, DX7 : Phoenix Sim
New Zealands Dedicated RCForum : www.rcforums.co.nz
My Youtube http://www.youtube.com/user/CHCHGSR
CHCHGSR is offline        Reply With Quote
Old 01-21-2009, 08:25 PM   #10
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

OMG, I have had that exact same issue. The problem is that you ARE following the instructions. There are 2 washers that are close to the blades. You have to arrange them so that the smaller one is closest to the blade and the bigger one is farther away. The one with the shoulder is the big one.
helidude3 is offline        Reply With Quote
Old 01-21-2009, 09:05 PM   #11
CHCHGSR
Registered Users
 
Posts: 202
 

Join Date: Nov 2006
Location: The Garden City, Christchurch, NZ
Default

Mate... I have spent easily 4 to 5 hrs last night alone... take the blades off, take the grips off, swap around the washers... Hmmmmm. i'll try your way and get back to you tomorrow ... watch this space.
if I dont reply I have gone mad and moved in to a nunnery !
__________________
I Spent all my money on Helis, Booze & Chicks... The rest i wasted.....
Phoenix FP | Trex 450 w Z-Power 3800, 65MG's, GY401 - DS520 | Stock Trex 500 CF, AR6100, AR6200, DX7 : Phoenix Sim
New Zealands Dedicated RCForum : www.rcforums.co.nz
My Youtube http://www.youtube.com/user/CHCHGSR
CHCHGSR is offline        Reply With Quote
Old 01-21-2009, 09:08 PM   #12
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

Well it could also be as easy as ungreased bearings or fautly servos. Have you tried unplugging the main motor and then moving the collective up slowly to see if there is any problem w/ the servos or any unusual binding?
helidude3 is offline        Reply With Quote
Old 01-21-2009, 09:14 PM   #13
CHCHGSR
Registered Users
 
Posts: 202
 

Join Date: Nov 2006
Location: The Garden City, Christchurch, NZ
Default

I have, lubed everything - tested all servo's (100% OK) sanded down where the slider goes, squeezed the ball links with pliers to free (It's nearly as free as my 450 now)
i'm nearlly bald from pulling my hair out ( I still have my 450 and 500 tho' to take my frustrations out on)
it's horrible when ya try everything but get now where fast......
__________________
I Spent all my money on Helis, Booze & Chicks... The rest i wasted.....
Phoenix FP | Trex 450 w Z-Power 3800, 65MG's, GY401 - DS520 | Stock Trex 500 CF, AR6100, AR6200, DX7 : Phoenix Sim
New Zealands Dedicated RCForum : www.rcforums.co.nz
My Youtube http://www.youtube.com/user/CHCHGSR
CHCHGSR is offline        Reply With Quote
Old 01-21-2009, 09:22 PM   #14
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

Well, have you tried going to bladecprepair.com? here is the link to your problem: http://bladecprepair.com/cause.php?s...l%20Categories
helidude3 is offline        Reply With Quote
Old 01-21-2009, 09:41 PM   #15
CHCHGSR
Registered Users
 
Posts: 202
 

Join Date: Nov 2006
Location: The Garden City, Christchurch, NZ
Default

Sure have,
I have the exact same setup as below, it must be a bearing locking up.
let me see.
I will conquer this.
Thxs for the help so far
__________________
I Spent all my money on Helis, Booze & Chicks... The rest i wasted.....
Phoenix FP | Trex 450 w Z-Power 3800, 65MG's, GY401 - DS520 | Stock Trex 500 CF, AR6100, AR6200, DX7 : Phoenix Sim
New Zealands Dedicated RCForum : www.rcforums.co.nz
My Youtube http://www.youtube.com/user/CHCHGSR
CHCHGSR is offline        Reply With Quote
Old 01-22-2009, 12:15 PM   #16
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

Have you ever though about bringing it to a hobby shop, they might point out something simple that you may have never though of. Also, have you checked the bearings to make sure that they are not blown out. you can use a pencil and then stick the bearing through the top.
helidude3 is offline        Reply With Quote
Old 01-22-2009, 12:57 PM   #17
CHCHGSR
Registered Users
 
Posts: 202
 

Join Date: Nov 2006
Location: The Garden City, Christchurch, NZ
Default

wel, after all that. - Blades - I cut down a set of 315 Align woodies, setup the tracking, Perfect..... Arrrggghhh
There must have been a flexing blade that was some how during + pitch it was flexing and grabbing, if that makes sense?
Oh well it's going now and no sticky collective !
Thxs for your help
__________________
I Spent all my money on Helis, Booze & Chicks... The rest i wasted.....
Phoenix FP | Trex 450 w Z-Power 3800, 65MG's, GY401 - DS520 | Stock Trex 500 CF, AR6100, AR6200, DX7 : Phoenix Sim
New Zealands Dedicated RCForum : www.rcforums.co.nz
My Youtube http://www.youtube.com/user/CHCHGSR
CHCHGSR is offline        Reply With Quote
Old 01-22-2009, 03:11 PM   #18
helidude3
Registered Users
 
Posts: 904
 
My HF Map location
Join Date: Jan 2009
Location: Tiburon, CA, 94920
Default

wow, well I guess this thread will be helpful to someone who does not have that simple as a problem
helidude3 is offline        Reply With Quote
Old 01-25-2009, 12:58 AM   #19
zen
Registered Users
 
Posts: 1,043
 
My HF Map location
Join Date: Feb 2007
Location: Berkeley, California
Default

+1 Yep, (... didn't read the next page. All the info you need and more....)

Sticky collective can be nasty; fix it quick before it fixes your heli!
__________________
Trex 450 SE V2

T-rex 500 ESP
zen is offline        Reply With Quote
Old 01-25-2009, 04:27 PM   #20
cold duck
Registered Users
 
Posts: 408
 

Join Date: Jul 2008
Location: Northern Cali
Default

Another thing to consider about the sticky collective issue is; make sure you don't over tighten the spindle bolts! I used to really crank mine down and was going crazy trying to solve my sticky collective issue until I read about the over tightening issue in a post some place. I backed off on the torque and my sticky collective issue vanished completely. The same thing applies for the screws on the bell-hiller mixing arms on the BCP Pro. I had those too tight also.
cold duck is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite)


Blade Helicopters (eFlite) Blade Helicopters (eFlite) CP, CX, mCX CX II, CX III. and others

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.