Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
Thread Tools Display Modes
Old 02-09-2009, 10:00 PM   #1
Helihangover
Registered Users
 
Posts: 162
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default Pitch help Please..

Hi all. Finally got a pitch guage today.. Doing some checking and the numbers didn't come out like i thought they should.. Need someones advice on what it should be.
This is with the stock throttle and pitch curves for the dx6i
Normal
Low- 5deg
1/4- 7deg
1/2- 9deg
3/4- 15deg
Full- off the guage.

Stunt
Low- -1
1/4- 5
1/2- 8
3/4- 14
Full- off the guage.

Flybar level with boom. Haven"t never turned any ball links more than 1 turn before. This is how it came from the factory.
It starts to take off around 1/4 stick..Any suggestions or help would be appreciated..
Helihangover is offline        Reply With Quote
Old 02-09-2009, 10:05 PM   #2
sokal
Registered Users
 
Posts: 3,681
 

Join Date: Dec 2007
Location: Gloucester point, VA
Default

Quote:
Originally Posted by Helihangover View Post
Hi all. Finally got a pitch guage today.. Doing some checking and the numbers didn't come out like i thought they should.. Need someones advice on what it should be.
This is with the stock throttle and pitch curves for the dx6i
Normal
Low- 5deg
1/4- 7deg
1/2- 9deg
3/4- 15deg
Full- off the guage.

Stunt
Low- -1
1/4- 5
1/2- 8
3/4- 14
Full- off the guage.

Flybar level with boom. Haven"t never turned any ball links more than 1 turn before. This is how it came from the factory.
It starts to take off around 1/4 stick..Any suggestions or help would be appreciated..
go thu my head vids

seems like your a bit off

will take some swash, washouts, flybarcage, and blades to get it right

also its best to set everything up in full range mode IE idleup/stunt

with a pitch curve of 0-25-50-75-100

i set my hold pitch curve up the same as idle up curve so i dont have to unplug motor
but be extreamly carefull doing so if u acedently turn hold off with throttle stick at mid stick it will start spinng very quickly so for now till you get more acuainted in the hobby unplug motor its the safest way to keep you fingers and other body parts
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
B400 DS285/3400G/401/-8/40Aesc/sonicCNC/CNCframe
TwinRexx: 6xHS-65/2xGY240/jfg500/TH2
CH-47D/UH-1H Crewchief/ Mechanic
sokal is offline        Reply With Quote
Old 02-09-2009, 10:34 PM   #3
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default Pic enclosed

Yeah, I always unplug the motor when I am working on my bird.. This is a pic of the reading at full throttle idle up mode.

I didn't buy the wrong pitch gauge did I?.. It's the only one the LHS had. Am i doing the pitch gauge wrong maybe??
Attached Thumbnails
Click image for larger version

Name:	0209092113.jpg
Views:	141
Size:	98.2 KB
ID:	81362  
Helihangover is offline        Reply With Quote
Old 02-09-2009, 10:36 PM   #4
sokal
Registered Users
 
Posts: 3,681
 

Join Date: Dec 2007
Location: Gloucester point, VA
Default

Quote:
Originally Posted by Helihangover View Post
Yeah, I always unplug the motor when I am working on my bird.. This is a pic of the reading at full throttle idle up mode.

I didn't buy the wrong pitch gauge did I?.. It's the only one the LHS had. Am i doing the pitch gauge wrong maybe??
looks like you need to either lower your swashmix pitc setting as long as full neg is the same

if not then you have some adj to do bro
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
B400 DS285/3400G/401/-8/40Aesc/sonicCNC/CNCframe
TwinRexx: 6xHS-65/2xGY240/jfg500/TH2
CH-47D/UH-1H Crewchief/ Mechanic
sokal is offline        Reply With Quote
Old 02-09-2009, 10:44 PM   #5
Larry227
Registered Users
 
Posts: 13,179
 
My HF Map location
Join Date: Jul 2008
Location: Creston, BC (Canada) Porthill, Idaho (US)
Default

It's also not unusual for them to come right out of the box that far off. I know mine was. I just considered it the first step in getting to know my Blade.
Larry227 is offline        Reply With Quote
Old 02-09-2009, 10:49 PM   #6
Slyster
Registered Users
 
Posts: 39,266
 
My HF Map location
Join Date: May 2008
Location: Maplewood, MN
Default

WOW that's far off. It should be -10/0/+10.. yes view the vids! It's kindof fun setting up the head too
__________________
"It's not just a hobby... it's a lifestyle" - Pete
Goblin 500 + 700 / Blade 130x + MCPX BL / SK540 / Jives / DX8 / Quantum / RJX / 4010Duo
Slyster is offline        Reply With Quote
Old 02-09-2009, 11:01 PM   #7
1BADAIR
Registered Users
 
Posts: 3,561
 
My HF Map location
Join Date: Jun 2008
Location: Oxford, Mi
Default

swash to low maybe???
any pics of the head/swash at mid stick?
__________________
Compass 7HVU HBL980/950 Ar7200bx Edge160-- Compass 6HV, 610/650
TRex 700LE , Beastx 610/650, Warp360 TracX 92A+
1BADAIR is offline        Reply With Quote
Old 02-09-2009, 11:10 PM   #8
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default

I will get some pics of the head tomorrow at midstick.. And try a few things sokal told me to try. i will post my finds tomorrow..
Helihangover is offline        Reply With Quote
Old 02-09-2009, 11:19 PM   #9
1BADAIR
Registered Users
 
Posts: 3,561
 
My HF Map location
Join Date: Jun 2008
Location: Oxford, Mi
Default

I wish the RTF manual was like the PNP manual. Lots of good info in it.
It says the swash should be 16.25mm from the chassis at mid stick
http://www.e-fliterc.com/ProdInfo/Fi...Manual_Web.pdf
__________________
Compass 7HVU HBL980/950 Ar7200bx Edge160-- Compass 6HV, 610/650
TRex 700LE , Beastx 610/650, Warp360 TracX 92A+
1BADAIR is offline        Reply With Quote
Old 02-09-2009, 11:37 PM   #10
mr2mkii
Registered Users
 
Posts: 1,116
 

Join Date: Dec 2008
Location: Shippensburg, PA
Default

Quote:
Originally Posted by 1BADAIR View Post
swash to low maybe???
any pics of the head/swash at mid stick?
I was thinking the same thing. Mine came with the swash a bit too high from the factory, but it was still setup pretty close for 0 pitch and range. Only recently did I lower it back down to were it really should be.
__________________
Blade mCX / mCPx / 130X / B400 HS-65MGs FBL CopterX w/3400g CCBEC 440H
B400 HG-5000 w/5083, CNC Head, HS-65HBs / B400 GY401 w/3400g, JR285s
T-Rex 600E / 600N Pro
mr2mkii is offline        Reply With Quote
Old 02-10-2009, 05:19 PM   #11
Propaganda
Registered Users
 
Posts: 108
 

Join Date: Jan 2009
Location: West Jefferson, NC
Default

When I got my Blade 400 it was off as well. Swashplate was not level either. Watch Sokal's videos (a big thanks to that man!) and set it up properly.
Propaganda is offline        Reply With Quote
Old 02-11-2009, 04:27 PM   #12
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default Making Progress

Well i started from scratch. Set the swash up level with 16.25mm Gap as per the PNP manual showed.(thanks for the link 1badair). Then set up the rest of the way like the book showed.. Problem was Long rods that went to the bell mixer arms. They were over 2mm off from the factory. Adjust them as per manual. Then checked swash and adjusted to fine tune..
New measurements are a lot better.
Normal +11/0/-2
Idle up +11/0/-10
Will this work or do I need to do anything else to fine tune?..Way to windy to test it out today..
Helihangover is offline        Reply With Quote
Old 02-11-2009, 04:36 PM   #13
sokal
Registered Users
 
Posts: 3,681
 

Join Date: Dec 2007
Location: Gloucester point, VA
Default

Quote:
Originally Posted by Helihangover View Post
Well i started from scratch. Set the swash up level with 16.25mm Gap as per the PNP manual showed.(thanks for the link 1badair). Then set up the rest of the way like the book showed.. Problem was Long rods that went to the bell mixer arms. They were over 2mm off from the factory. Adjust them as per manual. Then checked swash and adjusted to fine tune..
New measurements are a lot better.
Normal +11/0/-2
Idle up +11/0/-10
Will this work or do I need to do anything else to fine tune?..Way to windy to test it out today..
raise your swash 1 1/2 turns on all 3 swash to servo links

then recenter washout arms and 0 pitch blades

you may also have to lower your pitch swashmix setting a lil to get +10/-10
if not then raise swash 1 1/2 turn till the range is equal just remember each time you adj swash you have to recenter everything above it to level and 0 pitch at mid stick

the measurements in the pnp manual is ok but its not exact
but will get you in the ball park
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
B400 DS285/3400G/401/-8/40Aesc/sonicCNC/CNCframe
TwinRexx: 6xHS-65/2xGY240/jfg500/TH2
CH-47D/UH-1H Crewchief/ Mechanic
sokal is offline        Reply With Quote
Old 02-12-2009, 04:42 PM   #14
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default What's Wrong Now?

I am puzzled now. Tried my blade out today after getting the head set right. Pitch gauge shows+10/0/-10 in idle up, +10/0/-2 normal mode.. But when i tried to lift off, it wouldn't go up.. At full pos in idleup it would start to get light on her feet but that is all it would do.. Rechecked the pitch, and it had not changed.. But no lift.. I watched the swash plate while trying to lift off, it was going down like it should. The head speed sounds a lot higher now then before.. I am lost ....Any Ideas???
Helihangover is offline        Reply With Quote
Old 02-13-2009, 10:53 PM   #15
sokal
Registered Users
 
Posts: 3,681
 

Join Date: Dec 2007
Location: Gloucester point, VA
Default

Quote:
Originally Posted by Helihangover View Post
I am puzzled now. Tried my blade out today after getting the head set right. Pitch gauge shows+10/0/-10 in idle up, +10/0/-2 normal mode.. But when i tried to lift off, it wouldn't go up.. At full pos in idleup it would start to get light on her feet but that is all it would do.. Rechecked the pitch, and it had not changed.. But no lift.. I watched the swash plate while trying to lift off, it was going down like it should. The head speed sounds a lot higher now then before.. I am lost ....Any Ideas???
any luck?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
B400 DS285/3400G/401/-8/40Aesc/sonicCNC/CNCframe
TwinRexx: 6xHS-65/2xGY240/jfg500/TH2
CH-47D/UH-1H Crewchief/ Mechanic
sokal is offline        Reply With Quote
Old 02-13-2009, 10:55 PM   #16
sokal
Registered Users
 
Posts: 3,681
 

Join Date: Dec 2007
Location: Gloucester point, VA
Default

Quote:
Originally Posted by Helihangover View Post
I am puzzled now. Tried my blade out today after getting the head set right. Pitch gauge shows+10/0/-10 in idle up, +10/0/-2 normal mode.. But when i tried to lift off, it wouldn't go up.. At full pos in idleup it would start to get light on her feet but that is all it would do.. Rechecked the pitch, and it had not changed.. But no lift.. I watched the swash plate while trying to lift off, it was going down like it should. The head speed sounds a lot higher now then before.. I am lost ....Any Ideas???
check your seesaw may be cracked
and once thier force on the blades it flexes
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
B400 DS285/3400G/401/-8/40Aesc/sonicCNC/CNCframe
TwinRexx: 6xHS-65/2xGY240/jfg500/TH2
CH-47D/UH-1H Crewchief/ Mechanic
sokal is offline        Reply With Quote
Old 02-13-2009, 11:53 PM   #17
1BADAIR
Registered Users
 
Posts: 3,561
 
My HF Map location
Join Date: Jun 2008
Location: Oxford, Mi
Default

what are your pitch and throttle curves?
__________________
Compass 7HVU HBL980/950 Ar7200bx Edge160-- Compass 6HV, 610/650
TRex 700LE , Beastx 610/650, Warp360 TracX 92A+
1BADAIR is offline        Reply With Quote
Old 02-14-2009, 06:45 AM   #18
leeok75
Registered Users
 
My HF Map location
Join Date: Dec 2008
Location: NTH QLD,AUS
Default

Quote:
Originally Posted by Helihangover View Post
I am puzzled now. Tried my blade out today after getting the head set right. Pitch gauge shows+10/0/-10 in idle up, +10/0/-2 normal mode.. But when i tried to lift off, it wouldn't go up.. At full pos in idleup it would start to get light on her feet but that is all it would do.. Rechecked the pitch, and it had not changed.. But no lift.. I watched the swash plate while trying to lift off, it was going down like it should. The head speed sounds a lot higher now then before.. I am lost ....Any Ideas???
Im only a newb but should'nt the swash be going up when adding throttle?
leeok75 is offline        Reply With Quote
Old 02-14-2009, 08:52 AM   #19
sokal
Registered Users
 
Posts: 3,681
 

Join Date: Dec 2007
Location: Gloucester point, VA
Default

Quote:
Originally Posted by leeok75 View Post
Im only a newb but should'nt the swash be going up when adding throttle?
if your grips are fliped yes
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
B400 DS285/3400G/401/-8/40Aesc/sonicCNC/CNCframe
TwinRexx: 6xHS-65/2xGY240/jfg500/TH2
CH-47D/UH-1H Crewchief/ Mechanic
sokal is offline        Reply With Quote
Old 02-14-2009, 09:51 AM   #20
d3x0r
Registered Users
 
Posts: 606
 

Join Date: Jan 2009
Location: Ireland
Default

I think it was similar settings on my blade out of the box aswell, i have changed servos and zero pitch point with all 65s at 90 degrees was +5 or even +6, it probably was same with old servos because i have mounted ballinks in almost same place on servo horns. but now it seems to be ok
__________________
| TZ V2 Frenzy | GY401/9254 | TT RedLine 53H/TT HiFlow Muffler | REVMAX | 20% Bekra |
| B400 | HS65's | GY401/9257 | CCBec | Turnigy 2836/40A esc | Sonix Head/Alu Frame |
| HK250 | Blade mCX |
Parts shopping, repairs, swash leveling, punctuated by brief periods of flight...
d3x0r is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com