Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
Thread Tools Display Modes
Old 03-22-2009, 08:43 PM   #1
Helihangover
Registered Users
 
Posts: 162
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Question Motor cut out in flight

Well I had both batts charged and the camera girl was ready early this afternoon. Got in the air for about a minute and a half.. I went to do a flip and when I got inverted it was like the power cut off. Finished the flip and was in the process of trying my first Auto and, the bird powered back up. Just not in time to save it...Anyways as soon as I picked it up I felt the ESC it was pretty hot to touch..Battery was still 3/4 charged..
Brought it home and repaired it. Went to fly the other pack right before dark. It made it 3 1/2 minutes and in the middle of another flip it powered down again. Right when it was inverted..Same as earlier..It did 4 or 5 flips the second time before it pooped out. And it picked back up right before it hit the ground..Saved it this time..
I am figuring it might be the Esc after installing the 401 and 290 tail combo this weekend.. Thats the only thing i have changed..Or maybe the battery connector?

Any input would be appreciated..Hovered 2 packs through it today with no problems..
I also just started flying in Idle up mode this weekend..
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Crash Test Dummy
Helihangover is offline        Reply With Quote
Old 03-22-2009, 08:52 PM   #2
1BADAIR
Registered Users
 
Posts: 3,561
 
My HF Map location
Join Date: Jun 2008
Location: Oxford, Mi
Default

sounds like you need a BEC.
the 401 takes more power to run
__________________
Compass 7HVU HBL980/950 Ar7200bx Edge160-- Compass 6HV, 610/650
TRex 700LE , Beastx 610/650, Warp360 TracX 92A+
1BADAIR is offline        Reply With Quote
Old 03-22-2009, 09:02 PM   #3
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default

If i get the align 35g will i still need the seperate bec?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Crash Test Dummy
Helihangover is offline        Reply With Quote
Old 03-22-2009, 09:22 PM   #4
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default

Just checked the battery it is 3.8 3.8 3.81.. It flew for 3min and 23sec in idle up..Before it cut out. Never timed it good before.. Is that about normal? Using 1800 mah eflites..
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Crash Test Dummy
Helihangover is offline        Reply With Quote
Old 03-22-2009, 09:39 PM   #5
Wolfpackin
HF Support
 
Posts: 11,313
 
My HF Map location
Join Date: Nov 2007
Location: Eagle, CO
Default

You can tell if your ESC is shutting down/browning out by the rx light.
If it was flashing before you powered down the heli then you had a momentary shut down.

If your ESC was too hot to touch then it's probably a thermal shut down caused by overload or binding, maybe a tight belt.

Quote:
If i get the align 35g will i still need the seperate bec?
Depends on what's causing your problem. If it's simply that you have upgraded electronics and the stock internal BEC can't handle the load when pushed hard then the Align ESC will probably be OK by itself. If you have binding somewhere the 35G might also need help.

FWIW, I'm running the B400 with stock motor/ESC, HS65HB x 3, G401B/DS290G and no external BEC with no problems and ESC temps around 100F. I also fly a CopterX V2 with Align 430XL/35X ESC, HS65HB x 3, LTG2100T/DS290G and no external BEC with no problems.

I keep my belt loose and size any tight ball links, so very little binding/friction. I don't push this equipment very hard, though. Just some quick sport flying and just added some backflips. My temps stay cool right now, between 85-105F, but my ambient temps are still around 60F.
__________________
Jonathan Livingston Helicopter
Blade 400: E-flite 420H/35X ESC, AR6100e, HS65HB x 3, G401B/DS290G. (Ret.)
CopterX 450AE V2: 430XL/35X ESC, AR6100, HS65HB x 3, LTG2100T/HSG-5084MG.
T-Rex 550E V1 Classic Flybar: 600MX/BL70G, AR6200, DS610 x 3, Quark/DS650, 16t/520mm blades.
Wolfpackin is offline        Reply With Quote
Old 03-22-2009, 09:55 PM   #6
Slyster
Registered Users
 
Posts: 38,875
 
My HF Map location
Join Date: May 2008
Location: Maplewood, MN
Default

spin by hand.. should spin at LEAST 4 times. + bec a good idea.
__________________
"It's not just a hobby... it's a lifestyle" - Pete Team Outrage.
Goblin 500 + 700 / O550 / Blade 130x + MCPX BL / SK540 / Jive / DX8 / Quantum / RJX / 4010Duo
Slyster is offline        Reply With Quote
Old 03-22-2009, 10:08 PM   #7
Helihangover
Registered Users
 
Posts: 162
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2009
Location: Moundville, AL
Default

I didn't check the light on the rx.. The head spins really freely.. The belt was pretty loose yesterday and i was getting drift on the 401 so i tightened it up a little more and did some other things and the drift went away.. But i can just about touch the other side of belt if i push with just finger strength..Gonna try to get a bec tomorrow if i can.. Funds is low still. The esc was to hot to keep my hand on both times..
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Crash Test Dummy
Helihangover is offline        Reply With Quote
Old 03-23-2009, 01:44 PM   #8
mstan8648@yahoo.com
Registered Users
 
Posts: 61
 

Join Date: Mar 2008
Location: Mobile Alabama
Default

Helihangover,
I am having simular problems, heres my setup

hs65 on cyclic
401b
jr digital on tail
castle creations bec
stock esc and every thing else

After installing the 401b and tail servo I could only get about 3 min out of a 2200ma pack. So I installed the cc bec and now I am up to 5 or 6 min. Still seems to low of time to me when only ff and hovering. Mine still seems to be doing the thermal cutoff thing when I fly with the canopy on. Either way my esc is to hot to touch after a pack. I would sure wish someone would lead us in the correct direction here. I hate to see u get the bec when it might still act up. Our setups seem to be near the same. Might want to save the money on the bec and get a good esc. Anyone have any answers?

What is a good cheap esc?

Flys wonderful with the 401 and digital servo but I am getting kinda broke getting 2 or more upgrades abter doing one upgrade!!!
mstan8648@yahoo.com is offline        Reply With Quote
Old 03-26-2009, 09:24 PM   #9
1BADAIR
Registered Users
 
Posts: 3,561
 
My HF Map location
Join Date: Jun 2008
Location: Oxford, Mi
Default

mstan864 what are your throttle curves?
__________________
Compass 7HVU HBL980/950 Ar7200bx Edge160-- Compass 6HV, 610/650
TRex 700LE , Beastx 610/650, Warp360 TracX 92A+
1BADAIR is offline        Reply With Quote
Old 03-26-2009, 09:32 PM   #10
BladeMadMan
Registered Users
 
My HF Map location
Join Date: Oct 2008
Location: West Palm Beach, FL
Default

Couple things to recheck{Again}. Gear mesh and belt tension.From what I have read those could be the only two things causing such short flight times and overheating.
BladeMadMan is offline        Reply With Quote
Old 03-26-2009, 09:39 PM   #11
KOBIJUST
Registered Users
 
Posts: 505
 

Join Date: Dec 2008
Location: Pritchardville SC
Default

Also depends on what battery you are using. Stock battery sounds about right for your times. Im getting 8 min on my 2200 zippy with the airwolf fuse which is down from 10-11 min
KOBIJUST is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com