Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mSR


mSR Blade (eFlite) Micro SR Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 10-01-2011, 11:52 AM   #181
Daryoon
 

Join Date: Jul 2011
Location: San Diego, CA
Default

That's a great first post. Welcome and it should help other mSR newbie become more proficient in flying their heli.
Daryoon is offline        Reply With Quote
Old 10-10-2011, 10:58 AM   #182
oldhelichuck
Registered Users
 

Join Date: Oct 2011
Location: Moundsville,WV
Default MSR Help

Hi, I sold my MSR to a friend and it was flying great when he got it, but now after a crash, I can't get it to fly right at all.
As soon as it reaches enough speed to lift off, it just rolls over to the left.

I have done all the normal stuff, main gear, swashplate adjust etc.. it looks like it should fly OK but it will not.
Anyway , any help is appreciated.
Thanks,
Chuck
oldhelichuck is offline        Reply With Quote
Old 10-10-2011, 03:06 PM   #183
Pfloyd
Registered Users
 
Posts: 6,573
 

Join Date: Mar 2010
Location: Mascoutah, Il USA
Default

How did you adjust the swash, with the red tool? That's a good start. Check to see if the swash guide pin has come out of the goal posts.
__________________
MCX-S300-MCX2-MSR-Pico QX-NQX-MQX-180QXHD-CB105-Syma S107-Syma X5C-Syma S109-Syma X1-Syma X3-ProtoX-Hubsan X4-WL Toys v222-WL Toys 252-WL Toys 272-Syma X5c-Orange T-Six


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
USAF RETIRED 1968-1988 Vietnam Veteran
Pfloyd is online now        Reply With Quote
Old 10-10-2011, 03:29 PM   #184
oldhelichuck
Registered Users
 

Join Date: Oct 2011
Location: Moundsville,WV
Default Help

Yes, I did all that, as I said I can't find anything wrong.
It just wants to go to the left all the time, I mean hard to the left.

Chuck
oldhelichuck is offline        Reply With Quote
Old 10-10-2011, 11:56 PM   #185
Pfloyd
Registered Users
 
Posts: 6,573
 

Join Date: Mar 2010
Location: Mascoutah, Il USA
Default

Check the blade grips.
__________________
MCX-S300-MCX2-MSR-Pico QX-NQX-MQX-180QXHD-CB105-Syma S107-Syma X5C-Syma S109-Syma X1-Syma X3-ProtoX-Hubsan X4-WL Toys v222-WL Toys 252-WL Toys 272-Syma X5c-Orange T-Six


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
USAF RETIRED 1968-1988 Vietnam Veteran
Pfloyd is online now        Reply With Quote
Old 10-11-2011, 12:54 PM   #186
oldhelichuck
Registered Users
 

Join Date: Oct 2011
Location: Moundsville,WV
Default

New head, new grips, new flybar,

Check them for what ???
oldhelichuck is offline        Reply With Quote
Old 11-01-2011, 01:46 PM   #187
hobbes
Registered Users
 

Join Date: Nov 2011
Location: AsiaPac
Default

Hi guys, got my msr for about 3 weeks now. Had a couple of hard crashes but it still flies ok... mostly.

Thing is, when i am doing a right banking turn at relatively high speeds (I am still learning this), and i need to rotate left to compensate when it goes out of control, it doesn't respond (it does not rotate). Could it be a busted tail motor?

I can rotate it with no problems when in a hover or at low foward/backward speeds. This problem only presents itself at higher speeds.... Any ideas would be appreciated!
hobbes is offline        Reply With Quote
Old 12-18-2011, 07:31 PM   #188
litehawkdown
Registered Users
 
Posts: 3,403
 

Join Date: May 2011
Location: Canada
Default

Well had my MSR for a long time. Fixed it many of times. I was having the drop outta the sky problem so I replaced the main motor. All was well again. But 50 or less flights in and it is back at it. Thinking it may be the tail motor this time. Both my MCP X and MSR have new mains that I replaced recently. But both are running the original tails. And both are acting up Think I will pick up a new tail motor and give it a try. Thing is the tail holds and runs well on both heli's............ So does the main.... and the batteries are strong as can be. Tried rebinding too. One other note when the LVC turns on after 30sec of flight +/- I can not cut the throttle. The heli just like to do the fish outta water flop.

Any other way to check a bad motor besides unplugging and running independently?
litehawkdown is offline        Reply With Quote
Old 12-18-2011, 07:47 PM   #189
litehawkdown
Registered Users
 
Posts: 3,403
 

Join Date: May 2011
Location: Canada
Default

How do I delete a post? LOL I forgot to quote the guy I was replying to.
litehawkdown is offline        Reply With Quote
Old 12-18-2011, 07:49 PM   #190
litehawkdown
Registered Users
 
Posts: 3,403
 

Join Date: May 2011
Location: Canada
Default

Quote:
Originally Posted by hobbes View Post
Hi guys, got my msr for about 3 weeks now. Had a couple of hard crashes but it still flies ok... mostly.

Thing is, when i am doing a right banking turn at relatively high speeds (I am still learning this), and i need to rotate left to compensate when it goes out of control, it doesn't respond (it does not rotate). Could it be a busted tail motor?

I can rotate it with no problems when in a hover or at low foward/backward speeds. This problem only presents itself at higher speeds.... Any ideas would be appreciated!
Sounds like what mine would do right before the main motor gave up the ghost. If it is the main you should also see a loss of flight time and dropping from the air as it progresses.

What was causing the look of a tail blow out was the main stopping for a second. I also would lose a bit of altitude as well. I have never had a bad tail motor as of yet (6months in). Just posted about a problem that might be tho LOL.
litehawkdown is offline        Reply With Quote
Old 12-19-2011, 03:22 AM   #191
litehawkdown
Registered Users
 
Posts: 3,403
 

Join Date: May 2011
Location: Canada
Default

Turns out I got a bad main motor. Tore the whole heli down. Looks like my new one was a Lemon. lasted for only 30-50 flights. This motor had a black plug instead of white. Think I will try to stay away from those ones if I can. Thank god it was only 10 bucks.
litehawkdown is offline        Reply With Quote
Old 12-21-2011, 05:38 AM   #192
AugerIn
Registered Users
 

Join Date: Dec 2011
Location: Victoria, Australia
Default

Been having a lot of fun with the mSR. Only now, when in a constant hover, the throttle fluctuates wildly. (Like I'm increasing and decreasing throttle)
I don't have a constant head speed. Is this the main motor or the 5 in 1 ?
AugerIn is offline        Reply With Quote
Old 12-21-2011, 02:04 PM   #193
litehawkdown
Registered Users
 
Posts: 3,403
 

Join Date: May 2011
Location: Canada
Default

That sounds like what happened when the main went on my MCP X. When a main goes on my MSR it just goes to LVC real quickly.
litehawkdown is offline        Reply With Quote
Old 12-23-2011, 03:18 AM   #194
litehawkdown
Registered Users
 
Posts: 3,403
 

Join Date: May 2011
Location: Canada
Default

Looks like I was wrong. Not the main motor after all. Got to be the batteries...........

But the problem only happens when the main motor is under load.

main shaft is straight.....

oiled..........

not the main..........

not the tail........

batteries hold up and test out on the meter fine................................

Thinking I might have a bad battery connection! Might try to replace my lead and connector. Bad news is somebody bought the last one at the LHS today LOL!
litehawkdown is offline        Reply With Quote
Old 03-02-2012, 10:36 AM   #195
lanny haff
Registered Users
 

Join Date: Sep 2011
Location: usa fl greenacres
Default

I was having a problem where the heli didn't want to go forward or back.I watched the elev. servo + it didn't move all the time. I blew it out with acan of the stuff you use to clean computers. A cloud of dust came out, The servo seems to be working fine. I have afew 2nd hand helis I 'm gonna do the same way Who knew! Lanny
__________________
2 Blade 120SRs 2 Syma s107s 1 Blade Scout 1 Madhawk 300 1 Blade MSR 1 Blade MSRX 1 EXI 450 many planes + boats
lanny haff is offline        Reply With Quote
Old 10-18-2012, 01:49 PM   #196
Noch
Registered Users
 

Join Date: Sep 2012
Location: IL
Default Strange

My MSR is acting fairly strange. When in mid flight it,the sound of the motor would change (pitch / tone)and shortly after it would screech and just fall from the sky! ... Then be normal again for awhile. Thought it was the tail motor dying. I've come to be familiar with this sound so last night as I noticed the sound I caught the bird and held it for a bit. Sure enough, it happened again in my hand. Only this time I noticed it wasn't the tail motor, it appears to be the main motor. It screeches quite loudly and almost stalls, losing power / RPM (is best I can describe it). The issue is bad enough that it twistes the main gear out of placement and I'd have to re-adjust/align it with the shaft. It happens pretty randomly but usually when I go over half throttle. Also, It's bound to a dx6i.

My question is, IS this indeed the main motor or the 5 in 1 going bad?

***i can try to include a video if it'll help but it's pretty random

I'll also note, I do notice a TBE but sometimes it isn't there and sometimes it's insane TBE... I don't even know if it would be consider TBE, cause the whole heli would go immediately into a big CCW circle with the heli slowly rotating...even if I MAX out the trim on the TX it isn't nearly enough. I'm not sure if this is related or not but please point me in the right direction. Thanks.


I've done some searches and cannot really find anyone having this issue (the main motor issue, I'm not too worried about the TBE now) I'm having. If you guys know, please point me in the right direction.
Noch is offline        Reply With Quote
Old 12-11-2012, 01:40 PM   #197
Sidewinder66
Registered Users
 
Posts: 126
 

Join Date: Nov 2011
Location: Roswell,NM.
Default

Mine has a sound that sounds like the motor is going up and down in speed but so far no problems. My only problem is that when I do have a crash sometimes it wont stop running right away. Doesnt do it everytime just when it crashes sometimes. Any thoughts?
Sidewinder66 is offline        Reply With Quote
Old 12-27-2012, 03:25 PM   #198
Delfin
Registered Users
 
Posts: 207
 

Join Date: Dec 2012
Location: Puerto Rico
Default

After a crash my mSR just spins non Stop to the left I used all the trim to the right and still keeps spinning? Any adea what it can be?



Sent from my iPad using Tapatalk HD
__________________
Missing being single. Guys that have no luck with women have no idea how lucky they are
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Mcx2, mSR nCPX mCPX stock an mCPX with FAI Fuselage DX8
Delfin is offline        Reply With Quote
Old 12-28-2012, 09:17 AM   #199
RichKnapp
Registered Users
 
Posts: 4,301
 
My HF Map location
Join Date: Dec 2012
Location: Appleton,WI
Default

Quote:
Originally Posted by Sidewinder66 View Post
Mine has a sound that sounds like the motor is going up and down in speed but so far no problems. My only problem is that when I do have a crash sometimes it wont stop running right away. Doesnt do it everytime just when it crashes sometimes. Any thoughts?
Mine has been doing that on and off. Chop the throttle and it looks like a flopping fish on the ground. Turn the tx off and it keeps going for a sec or 2.

Not sure whats going on either. I set my throttle trim all the way down and it still did it. I didn't know if it wa

NOTE: This posted as I was wrighting and I can't find how to deleate it just edit the text. Moderator please deleit this one.
RichKnapp is offline        Reply With Quote
Old 12-28-2012, 09:18 AM   #200
RichKnapp
Registered Users
 
Posts: 4,301
 
My HF Map location
Join Date: Dec 2012
Location: Appleton,WI
Default

Quote:
Originally Posted by Sidewinder66 View Post
Mine has a sound that sounds like the motor is going up and down in speed but so far no problems. My only problem is that when I do have a crash sometimes it wont stop running right away. Doesnt do it everytime just when it crashes sometimes. Any thoughts?
Mine has been doing that on and off. Chop the throttle and it looks like a flopping fish on the ground. Turn the tx off and it keeps going for a sec or 2.

Not sure whats going on either. I set my throttle trim all the way down and it still did it. I didn't know if it was my stock tx ( the trim buttons don't always register) or the bird.
RichKnapp is offline        Reply With Quote
Reply

Tags
blade msr broke help




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mSR


mSR Blade (eFlite) Micro SR Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com