Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 500 Class Electric Helicopters


500 Class Electric Helicopters 500 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 01-16-2010, 09:45 PM   #1
Liposition
Registered Users
 
Posts: 169
 

Join Date: Sep 2009
Location: North Carolina
Default Tracking issue with Pro 3D blades

Has anyone else had any problems getting a pr of the Pro 3D blades to track correctly. I have had 2 sets now that will not track. I know it is the blades because I can replace them with my RTs and they track perfectly. I do realize the RTs cost triple.
Liposition is offline        Reply With Quote
Old 01-16-2010, 09:56 PM   #2
Bayward
Registered Users
 

Join Date: Dec 2007
Location: Pasco County, Florida
Default

I have them for three helis. A Trex 500, Trex 600 and Thunder Tiger E325. Not one tracking problem. However, I did have to use about a shopping cart full of tape to balance one pair. Okay, maybe not a cart full, but a lot anyway.

Bob
Bayward is offline        Reply With Quote
Old 01-17-2010, 01:03 AM   #3
Slyster
Registered Users
 
Posts: 40,225
 
My HF Map location
Join Date: May 2008
Location: Maplewood, MN
Default

Never a tracking issue for me! It must be your feathering shaft is slightly bent or some other mechanical reason. And from my experience.. (I have used around 10 sets of various lengths)... I have never used more than 2" of black electrical tape to balance.. usually less than inch.
__________________
"It's not just a hobby... it's a lifestyle" - Pete
Goblin 500 + 700 / SK540 / Jives / DX8 / Quantum / RJX servos / 4010Duo / Deep cycles
Slyster is offline        Reply With Quote
Old 01-17-2010, 10:49 AM   #4
Liposition
Registered Users
 
Posts: 169
Thread Starter Thread Starter
 

Join Date: Sep 2009
Location: North Carolina
Default

I thought the featheringing shaft might be bent also so I replaced it with a new one. Tracking is still off. That is when I put the Rotortechs on and they tracked perfectly.
Liposition is offline        Reply With Quote
Old 01-17-2010, 10:51 AM   #5
Liposition
Registered Users
 
Posts: 169
Thread Starter Thread Starter
 

Join Date: Sep 2009
Location: North Carolina
Default

BTW Slyster, I have enjoyed your bibles.
Liposition is offline        Reply With Quote
Old 01-17-2010, 11:34 AM   #6
DarkHeli
Registered Users
 
Posts: 1,200
 

Join Date: Oct 2007
Location: nYc
Default

Balance them. My 3D's have a nice roll of tape on one end...it works perfect and tracks 100%, only it looks like a piece of tip got ripped off and I used tape to glue it back on...
__________________
Trex450v2/cxhead,cc35,65MG,9650/401,2221-8/13T
Trex500ESP-8cell beast ICE100,Scorp 1210kv,510's,spartan/MKS8910
Trex600NSP--Hyper50,Align gov,Align pipe,7703D+8900,Hitec 5965's,s3003 for throttle
7c 2.4
DarkHeli is offline        Reply With Quote
Old 01-18-2010, 08:40 AM   #7
JeandrePrinsloo
Registered Users
 

Join Date: May 2009
Location: Centurion, South Africa
Default

I had the same problem until I balanced mine.... Also used about a meter of tape though, but perfect now.
JeandrePrinsloo is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 500 Class Electric Helicopters


500 Class Electric Helicopters 500 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.