Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > E-Sky Helicopters > King II/III/IV and CP 2/3


King II/III/IV and CP 2/3 E-Sky King 2, 3, 4 plus CP 2 & 3


Reply
 
Thread Tools Display Modes
Old 03-15-2010, 10:27 AM   #1
idealhobbies
Registered Users
 

Join Date: Aug 2008
Location: Milford, Delaware
Default I'm about to give up on this

King II...

I can not work out the toilet bowling that it's doing. It's spinning counter clockwise at a very high rate. If I give full left rudder, I can make it stop. I have no idea what I am doing wrong (or what I'm doing for that matter).

On the tail, I have an Xmhobbies G401B gyro and the stock digital servo.

The heli was given to me because my buddy gave up on it. I have stripped it down and started completely over trying to get this thing to fly right. I have totally rebuilt the head and slowly and very carefully leveled it with a leveling tool. I just can not get the tail to act right.

The book, (written in very fine Chinglish) says that the gap in the tail should be 1/3 of the distance of the shaft (if this makes sense to you). If someone could measure theirs, this may help me.

I'm about to go back to a CX2. It was at least fun and not so darn frustrating.
idealhobbies is offline        Reply With Quote
Old 03-15-2010, 10:45 AM   #2
KeithT
Registered Users
 
Posts: 1,323
 

Join Date: Nov 2008
Location: Over here in Blighty
Default

Don't give up Idealhobbies - it can be sorted for sure
I'm no expert by a mile, but suffered the same problem as you with a brand new King3 which spun like a top.
If it is rotating CCW, that is because the tail has no authority against the torque of the main rotor. This can be for a number of reasons.
1) tail rotor spinning the wrong way & with this in mind, I think there is a thread somewhere on here that mentions the instruction manual tells you to do it wrong way round. It depends on which way you fit the tail and then twist to set the belt right. On the K3, the tail spins CCW when you look head-on at the blades from the right side of the heli.
2) blades incorrectly fitted
3) belt slipping
4) incorrectly set up with the tail servo.
5) gyro set in 'reverse'

Are you using a stock Tx? Also, have you set up in rate mode or HH?
Is your pushrod in line with the boom and not fouling etc.

There are ways to adjust the position of the tail servo in rate mode to stop it wanting to turn either way just at lift off, which then makes HH work like a dream. Basically, you move the servo mounts towards the frame or the tail to adjust the angle of attack of the tail blades. The horn on the servo needs to be as vertical (90deg) to the boom as possibe in rate mode with the sticks in neutral.
Have you checked any of the Finless Bob videos on the 450 forum. They explain the whole set up for a ccpm much better than I can.

Sorry if this is all old hat - someone who really knows should be along in a minute, but this is a sort of emergency resue attempt.

Let us know the answers to some of these q's and it will help to nail the problem

I repeat - don't quit, the eventual rewards are worth it
Cheers, Keith
__________________
Raptor 50 TitanSE - AR7200BX + RJX head
Raptor 550E with a flybar!!
Align 500 pro with Speed fuselage
mCPX V2

Last edited by KeithT; 03-15-2010 at 10:49 AM.. Reason: More info
KeithT is offline        Reply With Quote
Old 03-15-2010, 04:45 PM   #3
Bugster
Registered Users
 
Posts: 3,379
 
My HF Map location
Join Date: Nov 2008
Location: Warwickshire UK
Default

Reckon you covered everything very well there KT - let's hope idealhobbies finds a fix
__________________
Cheers, Bugster

Bugster is offline        Reply With Quote
Old 03-17-2010, 08:10 PM   #4
idealhobbies
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2008
Location: Milford, Delaware
Default

Quote:
Originally Posted by KeithT View Post
1) tail rotor spinning the wrong way & with this in mind, I think there is a thread somewhere on here that mentions the instruction manual tells you to do it wrong way round. It depends on which way you fit the tail and then twist to set the belt right. On the K3, the tail spins CCW when you look head-on at the blades from the right side of the heli. The tail is rotating counter clockwise as it should be.
2) blades incorrectly fitted
They're correct.
3) belt slipping
Maybe. No idea how to check this other than tearing it down and replacing the belt.
4) incorrectly set up with the tail servo.
It's correct as far as I can tell
5) gyro set in 'reverse'
Gyro is in "norm"

Are you using a stock Tx? I'm using a JR7202 Also, have you set up in rate mode or HH? I have NO IDEA how to do this. Could not begin to tell you.
Is your pushrod in line with the boom and not fouling etc. Push rod is not bound up

There are ways to adjust the position of the tail servo in rate mode to stop it wanting to turn either way just at lift off, which then makes HH work like a dream. Basically, you move the servo mounts towards the frame or the tail to adjust the angle of attack of the tail blades. Tried that today. Still spinning. The horn on the servo needs to be as vertical (90deg) to the boom as possibe in rate mode with the sticks in neutral. It's as close as I can physically see. I set the horn manually, then used a little sub trim on the radio to bring it the rest of the way.
Have you checked any of the Finless Bob videos on the 450 forum. They explain the whole set up for a ccpm much better than I can. I watched his video on setting up a Gyro today. Still spinning at a high rate. I changed Gyros and it's still doing it. I am assuming that because of a different Gryo doing the same thing, that it's a mechanical issue...I just can not figure out what it is.
Cheers, Keith
I'm about ready to box it up and sell everything or stomp the snot out of it. I may just have to stick to airplanes.
idealhobbies is offline        Reply With Quote
Old 03-18-2010, 09:58 AM   #5
KeithT
Registered Users
 
Posts: 1,323
 

Join Date: Nov 2008
Location: Over here in Blighty
Default

If you have no idea how to set up the gyro, then this points to it being a big part of your problem. An incorrectly set-up, malfunctioning or busted gyro will not hold the tail.
Lets take things step by step though.
The way to test for belt slip is to hold the tail rotor firm and rotate the mains in normal (CW) direction. If the belt jumps the tail drive, it's too loose. If it is, loosen the mount where the boom joins and pull the boom away from the frame until the belt is tight.
I'm afraid I'm not familiar with your TX, but here are some pointers.
HH & Rate mode refers to the amount of gyro gain you uhave dialled in to your gyrosens settings. For rate it needs to be sub 50% and for HH it needs to be generally above 50%. With mine it's good to go at 70%. If you find the setting and identify the switch, you can set it how you want.
You should set the heli up in rate (ie about 40 or 45%). With the horn vertical, adjust the position of the server forwards and backwards until the heli doesn't just spin. You should be able to tell just before it lifts off. If you can get it like that, flip the switch to HH mode (assuming you are familiar with which one it is - again on mine it's Aux2). You should not use any sub trim or trim when setting up. The gyro sees this as constant input and reacts to counter it.
If the tail still doesn't hold, it's possible your gyro is screwed.

To test this, power up in HH mode (you should do that routinely after setting imo) and watch the tail servo horn. In HH mode it should creep forwards towards the frame. If you switch to Rate mode, it should snap back to vertical.
Another test is - disconnect the motor for safety, power up in HH and pick the heli up. If you move it rapidly acw the tail servo horn should move towards the frameset and stay there. If you rotate cw - it should head towards the tail. The tail blade pitch should adjust + to - as a result. If it doesn't do this, it's possible that you gyro NEEDS to be reversed not normal. Just one last thought, with my K3 and a telebee gyro, I have to power up and wait for the Tx to bind, then unplu the power and re-connect to get the gyro to initialise. Don't know with your gyro, but might be worth a try.

If it's a gyro screw up or servo malfunction, then it's up to you whether you stamp on it or sell it. We can try to help, but that's all. Some pictures might assist us, if you want to try.
Cheers
Keith
__________________
Raptor 50 TitanSE - AR7200BX + RJX head
Raptor 550E with a flybar!!
Align 500 pro with Speed fuselage
mCPX V2

Last edited by KeithT; 03-18-2010 at 12:38 PM..
KeithT is offline        Reply With Quote
Old 03-19-2010, 07:04 AM   #6
idealhobbies
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2008
Location: Milford, Delaware
Default

Thanks Keith. My rates are screwed up in the radio. What you said just clicked. Hopefully that will do it.
idealhobbies is offline        Reply With Quote
Old 03-19-2010, 07:49 AM   #7
KeithT
Registered Users
 
Posts: 1,323
 

Join Date: Nov 2008
Location: Over here in Blighty
Default

let us know how it goes.
__________________
Raptor 50 TitanSE - AR7200BX + RJX head
Raptor 550E with a flybar!!
Align 500 pro with Speed fuselage
mCPX V2
KeithT is offline        Reply With Quote
Old 03-19-2010, 09:04 AM   #8
Wrench 54
Registered Users
 

Join Date: May 2009
Location: Jax. Fl.
Default

Hi Idealhobbies, A programable radio is the best thing you can do for a K2 but also till you get to understand it and all the settings can drive you to bang your head on something-- I even had to go to the LHS where I got mine and ask for help with it and now 10 mounths later am still learning all the trick things it will do, most manuals for them lack good info and just tell you how to set the diff things, might need if you can to get some hands on help, it's hard for us to see or know just how yours is set up, all the help info that has been given is A+ so don't cry uncle just yet, sometimes it just takes time and playing with it and lots of PATIENCE!!!!!-----Wrench
Wrench 54 is offline        Reply With Quote
Old 03-19-2010, 10:31 AM   #9
idealhobbies
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2008
Location: Milford, Delaware
Default

Patience....I'm trying. I've had future dreams of a 500, but I figured before I sunk a whole lot of $$$ I'd try the cheap route first to see if it was my cup of tea. Not looking good so far. I'm giving her an honest attempt.
idealhobbies is offline        Reply With Quote
Old 03-19-2010, 11:04 AM   #10
KeithT
Registered Users
 
Posts: 1,323
 

Join Date: Nov 2008
Location: Over here in Blighty
Default

What was that T-shirt someone mentioned.......
"Planks - for people who can't fly helis"


i'm saying nothing
__________________
Raptor 50 TitanSE - AR7200BX + RJX head
Raptor 550E with a flybar!!
Align 500 pro with Speed fuselage
mCPX V2
KeithT is offline        Reply With Quote
Old 03-19-2010, 11:54 AM   #11
chrismechanic
Registered Users
 
Posts: 2,560
 
My HF Map location
Join Date: Feb 2010
Location: Margate, England
Default

yer nice one keith . i like that t shirt.
ideal hobbies, all i can say is i have been into helis for 3 months now and been hovering for 2 months, i can now hover reasonably well in no wind and can set up my heli ok.
this heli hobby is frustrating at first, but it just gets better the more you learn.
if your heli dont work properly dont try to fly it, you will crash, well you will crash anyway sooner or later, its all a steep learning curve.
set up yourheli in rate mode so you have as little wander of the tail as possible by sliding the tail servo up/down the tail boom till its at the best you can get with no trim.
then in hh mode it should hold the heli well, if not the gyro is probably cheap/busted.
take it slow and learn/read as much as you can about gyro and heli setup and all will click into place...good luck m8.
chris
__________________
warp 360-ds92-ds525m-polaris bec-beastx-edge 50 lite-yummy
Synergy E5-castle 100 ice-bec pro-beastx.
futaba T8FG--R606FS/R617FS
chrismechanic is offline        Reply With Quote
Old 03-19-2010, 02:25 PM   #12
dayshaddow
Registered Users
 
Posts: 2,438
 
My HF Map location
Join Date: Aug 2009
Location: kent
Default

hang in there mate it will all click in to place.i built my first cp over xmas and it didnt start flying nice for two months.just focus on one thing at a time till you compleatly understand its purpose then move on to the next

i gave the dam heli a few weeks break when i got annoyed with it,then came back played for and hour left it a few days..then i woke up one and everything made sence and then it just flew like it should..been 3 months now and still lerning with every flight-crash-dumb monent

antony
__________________
msr msrx tr250 hk450
2 planks
wat for foamy and eflite beast
1/8th Brushless LiPo Powered monster Truck and a maverick strada evo xt
dayshaddow is offline        Reply With Quote
Old 03-19-2010, 02:27 PM   #13
dayshaddow
Registered Users
 
Posts: 2,438
 
My HF Map location
Join Date: Aug 2009
Location: kent
Default

hay chrismechanic just saw your in margate...kool beans im in folkestone yay small world
__________________
msr msrx tr250 hk450
2 planks
wat for foamy and eflite beast
1/8th Brushless LiPo Powered monster Truck and a maverick strada evo xt
dayshaddow is offline        Reply With Quote
Old 03-20-2010, 06:19 AM   #14
chrismechanic
Registered Users
 
Posts: 2,560
 
My HF Map location
Join Date: Feb 2010
Location: Margate, England
Default

hey antony...ye very small world, ill have a pint of that too .
planet thanet
__________________
warp 360-ds92-ds525m-polaris bec-beastx-edge 50 lite-yummy
Synergy E5-castle 100 ice-bec pro-beastx.
futaba T8FG--R606FS/R617FS
chrismechanic is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > E-Sky Helicopters > King II/III/IV and CP 2/3


King II/III/IV and CP 2/3 E-Sky King 2, 3, 4 plus CP 2 & 3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.