Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Outrage Velocity 50 Nitro


Outrage Velocity 50 Nitro Outrage Velocity 50 Nitro Helicopter Factory Support Forum


Reply
 
Thread Tools Display Modes
Old 05-14-2010, 07:22 AM   #1
visionplay
Registered Users
 
Posts: 118
 

Join Date: Sep 2007
Location: Melbourne, Australia
Default Sab 620 Red Devils wont fold back

I just put on the new 620mm Sab red devils on the V50 and they wont fold back into the blade holder

They only turn about 30 degrees and then hit the spindle bolt and wont go any further.

Anyone else tried these? Is it safe to dremmel the Carbon on the edges to give it clearance so they can turn in the grips? (i would not think so)
__________________
John
Logo 600, Vbar, Jive 80HV, Pyro 700, BLS.
Synergy N5, OS55, Vbar
Mini Protos FBL, Vbar, YGE, 3S TP 65c's.
visionplay is offline        Reply With Quote
Old 05-14-2010, 11:39 AM   #2
Eric Brandenburg
Registered Users
 
Posts: 888
 

Join Date: Sep 2005
Location: usa
Default

Yes, you can dremel or file down the corners of the roots on these blades to get them to fold. Just be careful to only take off what is needed, if you go too far there is a possibility of weakening the blades.
__________________
Give me a lever long enough and I'll move the world...

):> Team Helifreak!
Eric Brandenburg is offline        Reply With Quote
Old 05-14-2010, 02:44 PM   #3
acri84
Registered Users
 
Posts: 58
 

Join Date: May 2006
Location: Covington, GA
Default

I had the same problem . U can take your spindle bolts off and replace washers with MisAlign spindle washers. Problem solved.
__________________
Mike
acri84 is offline        Reply With Quote
Old 05-14-2010, 04:28 PM   #4
highland flyer
Registered Users
 

Join Date: Jun 2006
Location: Inverness
Default

The UK SAB importer gave the OK to remove enough to get the blades to fold as the roots are solid.
highland flyer is offline        Reply With Quote
Old 05-15-2010, 01:40 AM   #5
visionplay
Registered Users
 
Posts: 118
Thread Starter Thread Starter
 

Join Date: Sep 2007
Location: Melbourne, Australia
Default

Sweet, Thanks for all the replies!
__________________
John
Logo 600, Vbar, Jive 80HV, Pyro 700, BLS.
Synergy N5, OS55, Vbar
Mini Protos FBL, Vbar, YGE, 3S TP 65c's.
visionplay is offline        Reply With Quote
Old 11-23-2010, 10:38 PM   #6
reaziel
Registered Users
 
Posts: 19
 

Join Date: Nov 2010
Location: canton ohio
Default

Quote:
Originally Posted by acri84 View Post
I had the same problem . U can take your spindle bolts off and replace washers with MisAlign spindle washers. Problem solved.
i have the 600mm same problem i seen this and it worked
thanks for the tip
reaziel is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Outrage Velocity 50 Nitro


Outrage Velocity 50 Nitro Outrage Velocity 50 Nitro Helicopter Factory Support Forum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.