Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
Thread Tools Display Modes
Old 06-14-2010, 11:48 AM   #1
TwinTurbo95
Registered Users
 
Posts: 1,027
 
My HF Map location
Join Date: Mar 2010
Location: Augusta, Ga
Default Not getting power to motor, ESC or Motor?

Ok guys, I'm getting power to the servos, but I'm not getting the beep that signifies the motor is ready. The gyro light does come on, but no beep. I do get some movement out of the motor, but only slightly.

Didn't have any problems Saturday. Glad I wasn't in the air when this happened.

What you guys think it is?
__________________
Compass 7HV: BeastX - MKS HV
Gaui X4 V2: BeastX - Scorpion
Blade 300X: Hyperion - Hitec - JR
TwinTurbo95 is offline        Reply With Quote
Old 06-14-2010, 12:16 PM   #2
whoanelly
Registered Users
 
Posts: 5,418
 

Join Date: Apr 2008
Location: Central Ca
Default

Well this is a tuffy,,if you didnt get your final beep to initialize i wouldnt think the motor would turn at all,,u say it does turn a little? if it doesnt engage motor would be dead still. are you using the stock ESC ? if so maybe time to dump it.
__________________
700LE : 105HZR AR7200BX JR8917 Multi gov , JR9503
600ESP : 100AMP Castle. Scorpion Motor . AMA #962896
400 Blade : Scorpion 2221-6 ,Castle ICE 50 Sonix Head and t
Align 450 pro V2 3G MKS DS95 MSR , 2 x MCPX (brushless C05 & HP05), Blade 130X.
whoanelly is offline        Reply With Quote
Old 06-14-2010, 12:35 PM   #3
TwinTurbo95
Registered Users
 
Posts: 1,027
Thread Starter Thread Starter
 
My HF Map location
Join Date: Mar 2010
Location: Augusta, Ga
Default

It was the ESC. I had a stock spare one laying around. I figured it was (had just a little corrosion on some of the soldier).

Funny thing it gave no warning. I haven't had any thermal shutdowns or anything. When I first put the Blade together months ago (got it used and slightly broken on eBay, hella deal) it gave me a few shutdowns cause the belt was too tight. But it's been good since then. Oh well, stock stuff what should I expect right?
__________________
Compass 7HV: BeastX - MKS HV
Gaui X4 V2: BeastX - Scorpion
Blade 300X: Hyperion - Hitec - JR
TwinTurbo95 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com