Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Spartan RC


Spartan RC Spartan RC - Quark, DS760 Gyros and other Spartan RC Electronics Factory Support


Reply
 
Thread Tools Display Modes
Old 01-23-2011, 11:53 AM   #1
lennyk
Registered Users
 

Join Date: Apr 2009
Location: POS
Default 760 problems

Hi Guys,

I have 2 760's which I have been using a while in 500's.

One day at the end of a flight one of the 760's starting drifting fast to the right in HH mode
Now it no longer holds in HH mode, I can adjust/trim it manually to fly in rate mode but even if it is trimmed for rate mode when I switch to HH it drifts badly.

Any suggestions ?
lennyk is offline        Reply With Quote
Old 01-23-2011, 04:45 PM   #2
pril250
Registered Users
 
Posts: 5,796
 

Join Date: Aug 2008
Location: London, Uk
Default

Your advantage is having two of them. You are able to interchange to determine and verify whether it is the gyro, servo or heli (vibrations) causing your problem.
__________________
T-Rex600-ICE100,WR10ABEC,Scorp4025-1100+17T,Kasama head,QUK Swash CNC Tail,G-Force blocks,3152,DS760+BLS251,DX7+AR7000,FM.
Blade400
-CC ICE50,Scorp2221-8+12T,Sonix Head&Tail,5A BEC,HS65HB,Quark+3500G,AR7000,Align Carbon blades,TRex500 Skids,Flymentor.
pril250 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Spartan RC


Spartan RC Spartan RC - Quark, DS760 Gyros and other Spartan RC Electronics Factory Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.