Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > BeastX FBL System


BeastX FBL System BeastX FBL Flybarless System Software and Hardware Support


Reply
 
Thread Tools Display Modes
Old 04-26-2011, 06:35 PM   #1
zaboaa
Registered Users
 
Posts: 389
 
My HF Map location
Join Date: Nov 2007
Location: Rockwall, Texas
Default BeastX first fligth rport & ?'s

Posted this in the 700E forum also. But thought some of you all my not see it.

The wind finally got below 15 Knots today so I decided to maiden my 700E. My notes:


Set-up Beastx and ESC::

-Pots are all centered/factory setting.
- Set to pro, and tail gain set to 75% in radio (JR 11X).

- ESC/misc info: Running Gov CC120 Set-up as per CC FAQ. Using 2X 4500MAH Nano Tech's 25-50C. Separate 2s lipo with a reg for the Beast X. Run the align slant gear. and KDE tail with Edge tail blades.

ESC Gov Gain 12
PWm 8Khz
Norm: 1852
Idle 1 (70% flat curve): 1954
Idle 2 (100%): 2025

- Was worried about the lift off from previous posters, non factor felt normal as compared to my old Fly bar'd TREX 500. Hover was stable and nice.

- Tail had nice crisp rate and stopping was perfect.

- Cyclic was a lot touchier then I am used to. Felt like very little Expo using the Pro setting. Very controllable but I did notice it. This is my first FBL, so that might be why. I see transmitter mode in my future.

- Non Beastx info: Motor and ESC came down on the warm side. Could hold my finger on the motor but barley. Very mild flying so a little concerned about when I start to crank it a little.

Issues and questions:

- Tail was overall solid, but I did get a little wag after a fast cyclic change. Especially if I pumped it. Want to solve this before my next flight. Any suggestions?

- Anyway to calm the cyclic down in the preset modes (I know this isn't the first time this has been asked)?

- Non Beastx ? Worried about the heat on the ESC and motor . Any ideas?

On a side note: I also converted my 500 to Beastx and maiden it today also. Everything was perfect with it (cyclic felt a little better on it for some reason).

Thanks
Mark
zaboaa is offline        Reply With Quote
Old 04-26-2011, 08:16 PM   #2
gregg25
Registered Users
 
Posts: 614
 

Join Date: Nov 2008
Location: covington, la
Default

what motor ya using ? what were the temps?
gregg25 is offline        Reply With Quote
Old 04-26-2011, 08:59 PM   #3
zaboaa
Registered Users
 
Posts: 389
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2007
Location: Rockwall, Texas
Default

500MX. Didn't have temp reader.
zaboaa is offline        Reply With Quote
Old 04-26-2011, 09:20 PM   #4
Zaaaguy72
Registered Users
 
Posts: 780
 

Join Date: Nov 2007
Location: Grand Rapids, MN
Default

Lower the tail gain a couple clicks. What letter are you on for tail gain, should be around G to start with I think.
__________________
Team HeliProz
Zaaaguy72 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > BeastX FBL System


BeastX FBL System BeastX FBL Flybarless System Software and Hardware Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com