Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Castle Creations ESC and Software


Castle Creations ESC and Software Castle Creations ESC Software and Hardware Support


Reply
 
Thread Tools Display Modes
Old 05-09-2011, 11:40 PM   #1
Rick Dizzle
Registered Users
 
Posts: 746
 

Join Date: Jun 2010
Location: Sierra Vista, AZ, USA
Default Happy Castle owners post here...

OK, so not 100% sure if I posted this in the right spot...mods if not feel free to move.
So based on ALL these CC120HV failures and 700MX's getting smoked by CC ESC's, I have set up my "engine failure" feature in my Phoenix sim on my 700E. How sad is it that I have such doubt in the equipment running in my $1200 heli that I have to do this in my sim! I gotta say it is kinda fun though, as it is forcing me to auto in all kinds of different scenarios. I emailed Castle twice about the 120HV issues, just to get their thoughts and any precautions before first flight...They have been so nice NOT to return either email in over a week. O' well I guess. I hope to maiden my 700 in about two weeks as my work schedule has been rough and I am waiting on my flybar lock and Trueblood swash level to arrive to finalize set up. Anyways just thought I would share my new adventure via my Phoenix Sim....

Ill get off my soap box now....

**Edit**
The title of this thread has been changed as to reflect and continue to gather positive intel on the Castle ESC's....
__________________
Trex 500 ESP w/ KBDD Tail blades and paddles
Trex 600 Nitro DFC/ OS 55HZ limited edition
Phoenix 5.0 Sim, DX9

Last edited by Rick Dizzle; 05-11-2011 at 05:57 PM..
Rick Dizzle is offline        Reply With Quote
Old 05-10-2011, 12:12 AM   #2
invertsick
Registered Users
 
Posts: 2,045
 

Join Date: Nov 2007
Location: Glendale CA.
Default

how sad it is that the 95% of castle uesrs who dont have any problems are not posting here how happy they are with their esc.
I am one of them
ive been flying my 700E for almost 9 months, first 3 months with castle 160 and then castle 120 with zero issues.
i didnt change to 120 because i had a problem with my 160,
its just that the 160 is too bulky and 120 was not available when i bought the 700.
invertsick is offline        Reply With Quote
Old 05-10-2011, 12:24 AM   #3
Rick Dizzle
Registered Users
 
Posts: 746
Thread Starter Thread Starter
 

Join Date: Jun 2010
Location: Sierra Vista, AZ, USA
Default

invertsick,
Man I gotta tell you it is refreshing to hear this! I am really hoping to be one of the 95% with no issue. I will post my results as soon as I get her flying. I hope that I am just freaking myself out over nothing! A couple fellow freaks on here have told me..."Just fly it and don't worry!" So thats the plan! Gonna have my buddy who flys some killer 3D at our field do the maiden and the first couple "hard" flights on the esc, that way if it fails he can EASILY recover. But lets keep fingers crossed I am in the 95% club!
__________________
Trex 500 ESP w/ KBDD Tail blades and paddles
Trex 600 Nitro DFC/ OS 55HZ limited edition
Phoenix 5.0 Sim, DX9
Rick Dizzle is offline        Reply With Quote
Old 05-10-2011, 02:13 AM   #4
OnTheSnap
Registered Users
 
Posts: 11,109
 

Join Date: Jan 2009
Location: Santa Clara, Ca
Default

120HV works fine for most. Worked fine for me. Just go fly.
__________________
HeliDirect
Zeal Blades
MSH Brain Flybarless Systems
OnTheSnap is online now        Reply With Quote
Old 05-10-2011, 02:56 AM   #5
Lord.L.B
Registered Users
 
Posts: 199
 
My HF Map location
Join Date: Jan 2009
Location: Aberdeen UK
Default

Quote:
Originally Posted by OnTheSnap View Post
120HV works fine for most. Worked fine for me. Just go fly.
+1, same here, ICE 120HV working fine.
__________________
TREX - 700E - 500ESP - 450PRO - 250V1

Lord.L.B is offline        Reply With Quote
Old 05-10-2011, 04:24 AM   #6
Sirolf
Registered Users
 
Posts: 1,285
 

Join Date: May 2009
Location: Netherlands
Default

Again happy customer here.. 120HV works great for me.
Still have to practice auto's on my 700 for real, but not worried especially after my recent
mod: http://www.helifreak.com/showthread.php?t=303726
Sirolf is online now        Reply With Quote
Old 05-10-2011, 06:45 AM   #7
nocontrol1
Registered Users
 

Join Date: Jan 2007
Location: Melbourne, FL
Default

Me too! No problems in 3+ months on a CC 120HV.

Rob D.
__________________
---------
nocontrol1 is offline        Reply With Quote
Old 05-10-2011, 06:51 AM   #8
tekparasite
Registered Users
 
Posts: 939
 
My HF Map location
Join Date: Apr 2009
Location: Houston
Default

No problems here either.
tekparasite is online now        Reply With Quote
Old 05-10-2011, 07:41 AM   #9
f22warzone
Registered Users
 
Posts: 2,751
 
My HF Map location
Join Date: Apr 2010
Location: Arlington tx
Default

Quote:
Originally Posted by Rick Dizzle View Post
........... Gonna have my buddy who flys some killer 3D at our field do the maiden and the first couple "hard" flights on the esc, that way if it fails he can EASILY recover. But lets keep fingers crossed I am in the 95% club!
Best would be 2 packs of hovering first, as if it fails it will fail, but i must also say i have had no problems with my hv 160, and i haven't been very nice to it.

but you still need that motor cut feature, I use it in phoenix...... simulates a gear strip lol, have gotten very pro at landing almost all of them now, and in life it really helps out.
__________________
TRex-800E /Scorp 5035-478 5+5YY 1.8mm/VBar Blue Full 5.2Pro /CC Hv160/WR-Herc Super BEC/RJX 810mm 3D /RotoTech 115 + QuickUk Tail/ Hitec 7940th HV/TP 5000 65c
f22warzone is offline        Reply With Quote
Old 05-10-2011, 08:38 AM   #10
invertsick
Registered Users
 
Posts: 2,045
 

Join Date: Nov 2007
Location: Glendale CA.
Default

There u go
Lets see more happy customers lol
invertsick is offline        Reply With Quote
Old 05-10-2011, 10:53 AM   #11
LegndarySaiyan
Registered Users
 
Posts: 1,493
 

Join Date: Jan 2010
Location: Buffalo, NY
Default

Ice 120 here. Been through 2 crashes, used with three different motors, still working perfectly!
__________________
-Phillip Johnson, AMA #954735
LegndarySaiyan is online now        Reply With Quote
Old 05-10-2011, 11:07 AM   #12
smaze17
Registered Users
 
Posts: 2,257
 
My HF Map location
Join Date: Feb 2011
Location: Calabasas, CA
Default

Well, not a 120 but love my 80HV

S
__________________
Trex 700e DFC / iKON / CC ICE2 120HV / Align 700MX
Trex 450L Dominator / iKON / RCE-BL45X / 460MX
smaze17 is offline        Reply With Quote
Old 05-10-2011, 11:15 AM   #13
TheBigBopper
Registered Users
 
Posts: 251
 

Join Date: May 2009
Location: Pennsyltucky
Default

CC 80 HV here. 700M it worked great but my first crash took out the motor(bent shaft). 470KVMX motor smoked after a few flights. next in line is a scorpion HK III 4035-500. i have my fingers crossed and i've been practicing my auto's.
__________________
oooo baby that's a what i liiiike!
TheBigBopper is offline        Reply With Quote
Old 05-10-2011, 01:27 PM   #14
FredRX
Registered Users
 

Join Date: Aug 2009
Location: France
Default

My HV160 ICE works like a charm
FredRX is offline        Reply With Quote
Old 05-10-2011, 01:35 PM   #15
MMM.PWR
Registered Users
 
Posts: 450
 
My HF Map location
Join Date: Sep 2010
Location: Miami, FL
Default

Another thumbs up for the 120
__________________
Futaba 8FG AMA # 961861
Tyrannosaurus': 450 Sport : 500 ESP : 700E
MMM.PWR is offline        Reply With Quote
Old 05-10-2011, 01:38 PM   #16
Doug Darby
Registered Users
 
My HF Map location
Join Date: Jan 2007
Location: Dallas Texas
Default

Both my HV85 and 120 have been fine...
__________________
doug

TRM Power - RC Racing Engines - - VP Racing / Powermaster Fuels
Aero Hobbies - Lewisville, TX (972) 420-1414
Doug Darby is offline        Reply With Quote
Old 05-10-2011, 03:19 PM   #17
geok
Registered Users
 

Join Date: Jul 2010
Location: Greece
Default

CC HV 120 with 700MX working 100% no problems so far. (same for my buddy also. same setup same success )
geok is offline        Reply With Quote
Old 05-10-2011, 03:36 PM   #18
litespeed
Registered Users
 

Join Date: Jun 2006
Location: Missouri
Default

I have over 100 flights on my CC Ice 80HV. 50+ on the original 700M and the rest on the 700MX 510. Just stripped a CNC gear on a tic-tock and the 80 still lives.

I have no complaints and like the lower price of the Castle Stuff.

Tom
litespeed is offline        Reply With Quote
Old 05-10-2011, 06:55 PM   #19
Shef
Registered Users
 
Posts: 3,679
 
My HF Map location
Join Date: Jul 2008
Location: Manhattan (NYC)
Default

About a year with my 160 (Rev 2)...flawless so far.
__________________
Former owner of T-Rex: 250, 450 V2, 500ESP V-Bar, 550 DFC 3GX, 600ESP V-Bar, 700E 3G
Shef is offline        Reply With Quote
Old 05-10-2011, 08:34 PM   #20
acalley02
Registered Users
 

Join Date: Apr 2011
Location: Lexington, NC
Default

Well good to see there is some happy cc customers, mine smoked in the first 30 seconds, and the motor cooked too. All though guess i can't really say that the motor maybe casued it to go too, to far gone to tell now. Hope my second one works better.
acalley02 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Castle Creations ESC and Software


Castle Creations ESC and Software Castle Creations ESC Software and Hardware Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.