Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Hitec Radios > Hitec Gyro/Servos


Hitec Gyro/Servos Hitec Gyro and Servo Support


Reply
 
Thread Tools Display Modes
Old 07-29-2011, 11:06 PM   #1
jdqsGua
Registered Users
 

Join Date: Jul 2010
Location: Guatemala
Default HSG-5084 servo question

can someone tell me the type of this servo? I think it is 1520us/333hz, but can someone confirm it please...
jdqsGua is offline        Reply With Quote
Old 07-31-2011, 02:42 PM   #2
vertualex
Registered Users
 

Join Date: May 2009
Location: Farmington, CT
Default

Confirm
vertualex is online now        Reply With Quote
Old 05-07-2012, 08:27 AM   #3
Timtreo
Registered Users
 
Posts: 598
 

Join Date: Dec 2011
Location: Pennsylvania Warminster
Default

I was told by Hitec the 5084 must be run less than 333hz after 2 of mine burned out (even though the Sparten Quark manual states 1520us/333hz for the 5084). They also said they must be run in anolog mode on the GY401.
Just noticed the date of this thread but I'll post this anyway, might help someone else... BTW they both burned out again after Hitec fixed them. I used thier recommended settings, and no vibes or binding on helis. POSs, my cheap EXI digitals I'm using now give me no problems.
__________________
Check out my Night Blades Blog here on HF
Timtreo is offline        Reply With Quote
Old 07-08-2012, 10:37 PM   #4
minititinflyer
Registered Users
 
Posts: 1,621
 

Join Date: Dec 2007
Location: hollywood fl
Default

Quote:
Originally Posted by Timtreo View Post
I was told by Hitec the 5084 must be run less than 333hz after 2 of mine burned out (even though the Sparten Quark manual states 1520us/333hz for the 5084). They also said they must be run in anolog mode on the GY401.
Just noticed the date of this thread but I'll post this anyway, might help someone else... BTW they both burned out again after Hitec fixed them. I used thier recommended settings, and no vibes or binding on helis. POSs, my cheap EXI digitals I'm using now give me no problems.
my servos get warm too and im useing a align gp750 and i do got the same servo on a qaurk running the 1250us/333hz and have no porblems with same servo i have two of them servos the one the align is geting warm fast real warm som going ot try the anolog thing
__________________
blade msr!, blade mcpx! ,blade 130x!, trex 250!, ,mini titan e325 v2! ,gaui hurricane 425e! ,trex 600 esp!, trex 700e! ,Hitec Aurora 9!, spektrum dx6i!
ikon! quark! !AMA# 1021263!
minititinflyer is offline        Reply With Quote
Old 12-04-2012, 08:49 PM   #5
minititinflyer
Registered Users
 
Posts: 1,621
 

Join Date: Dec 2007
Location: hollywood fl
Default

well i got my quark gyro set up it on the 1520qu 250hz it works dosent het hot stays locked it dont run it on 333hz it wasnt made for that
__________________
blade msr!, blade mcpx! ,blade 130x!, trex 250!, ,mini titan e325 v2! ,gaui hurricane 425e! ,trex 600 esp!, trex 700e! ,Hitec Aurora 9!, spektrum dx6i!
ikon! quark! !AMA# 1021263!
minititinflyer is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Hitec Radios > Hitec Gyro/Servos


Hitec Gyro/Servos Hitec Gyro and Servo Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com