Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Outrage RC


Outrage RC Outrage RC - and XP Li-Po Factory Support Forum


Reply
 
Thread Tools Display Modes
Old 01-11-2012, 01:53 PM   #1
skunkworx
Registered Users
 
Posts: 9,657
 
My HF Map location
Join Date: Jan 2007
Location: Woodbridge, VA, USA
Default Torq servos on 9V?

I have some Torq servos which are rated at 7.4V but can be run at 8.4V. I was wondering if it would be overdoing it at 9.0V since my regulator will go up that high. I've never seen the topic brought up and was curious if it'd ever been tried before.
__________________
Tim - Atom 500, 6HV, 3D+, eAurora
KBDD TEAM PILOT
Compass support/ProStarHobby.com
--Si vis pacem, para bellum--
skunkworx is offline        Reply With Quote
Old 01-11-2012, 08:11 PM   #2
im4711
Registered Users
 
Posts: 4,878
 
My HF Map location
Join Date: Oct 2008
Location: Cape Coral, FL, USA
Default

interesting -> specs say they are rated 8.4V. And that what I run them. I cannot answer the 9V part since this would be higher than specs.
im4711 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Outrage RC


Outrage RC Outrage RC - and XP Li-Po Factory Support Forum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com