Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 02-05-2012, 04:43 PM   #1
weidmark
Registered Users
 

Join Date: Mar 2011
Location: Toronto, ON
Default random 90 degree turns

Hi,

I have an mcpx and dx7s. i have the settings imported from the blade website.\

I have started flying in stunt mode and have notice I get random yaw turns to the right of 90 degrees. I have not noticed this at all in normal mode.

This issue just caused me to have a pretty hard crash. I have ordered the parts that broke but would like to get this resolved before i take it back in the air.

Thanks
weidmark is offline        Reply With Quote
Old 02-05-2012, 05:03 PM   #2
caseyjholmes
Registered Users
 
Posts: 1,642
 

Join Date: Aug 2005
Location: Vancouver, Wa
Default

I don't know what's going on, but order you some cheap safety glasses and a padded glove.
That way you can spool it up in your hands and watch what's going on safely to see if you notice anything wrong.

If it's not your programming, I'd start with a tail motor and then look to the FET transistor..
sounds like the program is off.
caseyjholmes is offline        Reply With Quote
Old 02-05-2012, 05:26 PM   #3
weidmark
Registered Users
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Toronto, ON
Default

Quote:
Originally Posted by caseyjholmes View Post
I don't know what's going on, but order you some cheap safety glasses and a padded glove.
That way you can spool it up in your hands and watch what's going on safely to see if you notice anything wrong.

If it's not your programming, I'd start with a tail motor and then look to the FET transistor..
sounds like the program is off.
So it is an issue with the board? I only have about 15-20 flights on this heli in normal mode. This was my first major crash. Is this a common occurrence with the 3 in 1s?
weidmark is offline        Reply With Quote
Old 02-05-2012, 07:25 PM   #4
caseyjholmes
Registered Users
 
Posts: 1,642
 

Join Date: Aug 2005
Location: Vancouver, Wa
Default

I seem to have gotten away with about 40 crashes or so on mine before I had to order some FET's just now.

I haven't crashed my second 3-in-1 all that much yet. So not sure.
caseyjholmes is offline        Reply With Quote
Old 02-06-2012, 04:47 AM   #5
magpie1832
Registered Users
 

Join Date: Jul 2008
Location: Stockport , UK
Default

Hi, mate

I have the same problem.. In forward flight random 90 clockwise turns. Also If I hover and piro one full turn I get it carrying on another 90degrees. Also light on skids on floor give it quick jabs left and right then the tail gives in to a 90 degrees clockwise turn..

Would love to know the problem too.

Chris..
magpie1832 is offline        Reply With Quote
Old 02-06-2012, 05:02 AM   #6
Goatkeeper
Registered Users
 
Posts: 1,536
 

Join Date: Feb 2011
Location: North Carolina
Default

This same issue pops up about once a month. The normal solutions have been to check the mainshaft for splits, the feathering shaft the main gear. It's normally a vibration issue screwing with the gyro. And the tail motor wire plugs. I've had the same issue with each cause. Normaly it's the main shaft for me. The first time it was the plug on the tail motor wire. It wasn't making a good contact. I direct soldered both ends and I have never had the issue again.
Goatkeeper is offline        Reply With Quote
Old 02-06-2012, 11:21 AM   #7
AlphaKilo
Registered Users
 

Join Date: Jan 2012
Location: NorCal
Default

Hey, there is a "1/4 turn" thread here in this sub-forum. We've discovered many,many reasons for this. But, almost always it's physical.
-split tail boom and/or rotor mast seems to be the primary cause. Check it out.
-full power mode shows it first

http://www.helifreak.com/showthread....38#post3626238
AlphaKilo is offline        Reply With Quote
Old 02-06-2012, 12:25 PM   #8
GB ian
Registered Users
 
Posts: 797
 

Join Date: Apr 2008
Location: Geyserville, CA
Default

I had the same issue just yesterday..weak connection in the tail wiring. Mine is not stock and one of solder joints had started to fail. It might be mechanical as well. But weak tail connections are also common as the plug is not a great fit.
GB ian is offline        Reply With Quote
Old 02-06-2012, 12:26 PM   #9
Liduno
Registered Users
 

Join Date: Jan 2012
Location: West Palm Beach Florida
Default

Like mentioned above there could be many causes

Cracked blade
Cracked main shaft
Main gear rotated on shaft[there are flat spots on the gear and shaft that need to be aligned]
Slipping main gear from a cracked gear
Missing teeth on main gear
Tail rotor pushed on too far
Long hair wrapped around tail motor shaft[Ask me how I know this one..lol]
Loose tail motor plug
Bad 3-1 board
Liduno is offline        Reply With Quote
Old 02-06-2012, 12:30 PM   #10
My98stang46
Registered Users
 
Posts: 639
 

Join Date: Dec 2011
Location: Mobile, AL
Default

I've got one eflite battery that does this like that a religious requirement. Pop one of my other batteries in and it flys like a champ. I've also had the trailing edges on my blades cracked a little and new blade fixed it as well as a main shaft split that was also the cause of the problem. Basically just check over the heli for things that aren't the way they should be
__________________
2003 SVT Cobra 538RWHP
2010 Corvette ZR1 all stock
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Blade 450FBL, PRTOS 500CF FBL
My98stang46 is offline        Reply With Quote
Old 02-06-2012, 12:32 PM   #11
weidmark
Registered Users
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Toronto, ON
Default

Quote:
Originally Posted by Liduno View Post
Like mentioned above there could be many causes

Cracked blade
Cracked main shaft
Main gear rotated on shaft[there are flat spots on the gear and shaft that need to be aligned]
Slipping main gear from a cracked gear
Missing teeth on main gear
Tail rotor pushed on too far
Long hair wrapped around tail motor shaft[Ask me how I know this one..lol]
Loose tail motor plug
Bad 3-1 board
I am replacing my gear, main shaft and blades. I didn't want to fork over another $15 for a tail boom as I dont think the tail motor is bad. (only 20 or so flights)
weidmark is offline        Reply With Quote
Old 02-06-2012, 12:38 PM   #12
Liduno
Registered Users
 

Join Date: Jan 2012
Location: West Palm Beach Florida
Default

Quote:
Originally Posted by weidmark View Post
I am replacing my gear, main shaft and blades. I didn't want to fork over another $15 for a tail boom as I dont think the tail motor is bad. (only 20 or so flights)
Easy way to tell if the gear or the main shaft are cracked is to simply hold the gear from rotating and twist the head to see if the shaft flexes or the gear slips easy, also make sure the screw holding the head to the shaft is tight, some times the hole for the screw gets hogged out and oblonged from crashes.

Oblonged? Is that a real word? lol
Liduno is offline        Reply With Quote
Old 02-06-2012, 01:05 PM   #13
My98stang46
Registered Users
 
Posts: 639
 

Join Date: Dec 2011
Location: Mobile, AL
Default

No you can't make it past tense. You would just say they hole can be oblong from crashes lol
__________________
2003 SVT Cobra 538RWHP
2010 Corvette ZR1 all stock
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Blade 450FBL, PRTOS 500CF FBL
My98stang46 is offline        Reply With Quote
Old 02-06-2012, 01:12 PM   #14
Liduno
Registered Users
 

Join Date: Jan 2012
Location: West Palm Beach Florida
Default

Quote:
Originally Posted by My98stang46 View Post
No you can't make it past tense. You would just say they hole can be oblong from crashes lol
Thank you..lol
Liduno is offline        Reply With Quote
Old 02-06-2012, 06:45 PM   #15
Ampdraw
Registered Users
 

Join Date: Nov 2008
Location: Sydney, Australia. We live inverted.
Default

Quote:
Originally Posted by Liduno View Post
Like mentioned above there could be many causes

Cracked blade
Cracked main shaft
Main gear rotated on shaft[there are flat spots on the gear and shaft that need to be aligned]
Slipping main gear from a cracked gear
Missing teeth on main gear
Tail rotor pushed on too far
Long hair wrapped around tail motor shaft[Ask me how I know this one..lol]
Loose tail motor plug
Bad 3-1 board
Pretty good list.

Firstly, the 3in1 is pretty much the least likely. Power wires being pulled on too hard and burnt Fet's are pretty much their only failures. Occasional bind loss but rare.

So...other things to check
elongated jesus screw hole
cracked or misbalanced blades
bent spindle
poor connection in tail at 3in1, or at the tail.
Non smooth swash bearing

Amp
Ampdraw is offline        Reply With Quote
Old 02-06-2012, 06:48 PM   #16
Liduno
Registered Users
 

Join Date: Jan 2012
Location: West Palm Beach Florida
Default

Elongated !! That's the word I was looking for And I forgot to mention the feathering shaft, I assume that's what you meant by spindle.
Liduno is offline        Reply With Quote
Old 02-07-2012, 09:17 AM   #17
-=RAGE=-
Registered Users
 
Posts: 248
 

Join Date: Mar 2009
Location: Germany
Default

Im sitting here with my new mCP X 2 and have the same problem. I dont think that the heli did this turns from the beginning. A crash may have been the cause. But I replaced all broken parts with new ones.

Today, I bought a new motor and an new tail. The last thing I could exchange, is the 3in1 unit.

Yesterday, I checked the main shaft. It is in a very good condition. No splitting.
__________________
T-Rex 700 Pro DFC BeastX | Spektrum DX9
Blade
130X
-=RAGE=- is offline        Reply With Quote
Old 02-07-2012, 10:24 AM   #18
magpie1832
Registered Users
 

Join Date: Jul 2008
Location: Stockport , UK
Default

I have the same problem.... I have replaced the main with a solid carbon shaft, replaced the main gear with AEO black main gear new blade aswell.. It has extended boom because of crash which is when it started....

Mine also has very bad blowout.. I give it full thottle stick and the torque it taking the nose left until I stop climbing.. If I go straight it kicks nose randomly right 90 degrees.

ALSO..Just noticed the rear motor gets hot to the touch after a couple of minutes...

How much bent does the feathering shaft have to be... I cant tell if it is..

Chris..
magpie1832 is offline        Reply With Quote
Old 02-07-2012, 11:32 AM   #19
Goatkeeper
Registered Users
 
Posts: 1,536
 

Join Date: Feb 2011
Location: North Carolina
Default

Quote:
Originally Posted by magpie1832 View Post
I have the same problem.... I have replaced the main with a solid carbon shaft, replaced the main gear with AEO black main gear new blade aswell.. It has extended boom because of crash which is when it started....

Mine also has very bad blowout.. I give it full thottle stick and the torque it taking the nose left until I stop climbing.. If I go straight it kicks nose randomly right 90 degrees.

ALSO..Just noticed the rear motor gets hot to the touch after a couple of minutes...

How much bent does the feathering shaft have to be... I cant tell if it is..

Chris..
It sounds like you may have some poor conducting brushes in the tail motor. That would be a reason why it's creating extra heat and poor power.
The best way to check the feathering shaft is to remove the blades and spin the shaft inside the grips and hub still attached with a screw driver. If the grip move around the shaft is bent.
Goatkeeper is offline        Reply With Quote
Old 02-07-2012, 12:14 PM   #20
dannylightning
Registered Users
 
Posts: 14,251
 
My HF Map location
Join Date: Jun 2010
Location: Akron, Ohio
Default

i just took mine out to fly and it did the same thing.. tried to flip inverted twice and the tail kicked out like that and i had to correct to keep it from crashing.

i am done with this thing. always something going on with it.i think i might put it up for sale for parts since its a bit beat up and not flying well. got lots of spares but honestly i don't like it enough to keep spending time on the thing... it needs a new frame and landing skids, got the skids rigged up and the frame is mising some canopy mounts. i dont have those spare parts for it and i don't intend to by them or waist my time putting the new frame on.. but what can you do i guess, i hate blade products...

so its either going to set on the shelf and look pretty or dump it off .... i am sick of this thing...

maybe ill get a video of the mcpx being smashed with a hammer..
__________________
7hv, torq, yge, xera, beast x.
gaui x5,torq, yge, hyperion, v bar,
warp360
mks, yge, scorpion, beast x.
dannylightning is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com