Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Futaba Radios and Electronics


Futaba Radios and Electronics Futaba Radios, Gyros, Servos, Etc.


Reply
 
Thread Tools Display Modes
Old 02-29-2012, 04:02 PM   #1
KSTT325
Registered Users
 

Join Date: Aug 2007
Location: Salt Lake City
Default Help, with futaba ciu-2

Please, I need help downloading the drivers for the ciu-2. I am running windows 7/ 64 OS.
I have tried just about everything I know. Called futaba 3x, they were useless. If anyone
out there knows the steps to install the drivers. I would very grateful.:arggg
KSTT325 is offline        Reply With Quote
Old 02-29-2012, 06:53 PM   #2
Al Miessner
Registered Users
 
Posts: 3,035
 
My HF Map location
Join Date: Oct 2007
Location: Virginia Beach, Virginia
Default

Quote:
Originally Posted by KSTT325 View Post
Please, I need help downloading the drivers for the ciu-2. I am running windows 7/ 64 OS.
I have tried just about everything I know. Called futaba 3x, they were useless. If anyone
out there knows the steps to install the drivers. I would very grateful.:arggg
I totally agree with you. I have identical OS running on an ASUS. Same issue, nother buddy has OS 7 but 32 bit and it works fine.
__________________
Flying Hard makes it fun (AnimAL)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
GrandRC Team Pilot
Al Miessner is offline        Reply With Quote
Old 02-29-2012, 08:21 PM   #3
kcordell
Registered Users
 

Join Date: Aug 2006
Location: St. Louis, Missouri
Default

With Windows 7 it can be a bit finicky.
Keep trying, only use 1 USB port, don't switch around thinking that's the cause until after it loads properly.
Took me 3-4 times to get it to work on Windows 7.
__________________
Team Futaba, Team Miniature Aircraft, Team Flightpower, Radix Blades, VelTye, YS Engines
kcordell is offline        Reply With Quote
Old 03-01-2012, 05:15 PM   #4
scotty82
Registered Users
 
Posts: 98
 

Join Date: Dec 2010
Location: Australia, NSW, Sydney
Default

Hi,

I had this problem when I first got my CIU-2. I am running Win 7 64 bit on my laptop. I downloaded all the drivers and software for the CIU-2. I opened up the software and plugged it in and the LED wouldn't go Red or Green.

I tried plugging in to different USB ports and it still didn't work. I deleted everything and removed the drivers. I re-downloaded and installed everything again.

I plugged in the USB and Windows downloaded the drivers for it to run the device. I then opened up the GY Link and Update software and the LED went from Red to Green and it worked.

I can plug in to different USB ports now and it works no problems.

I don't know what it was becuase I did everything the same on the second attempt.

Cheers
Scott
scotty82 is offline        Reply With Quote
Old 03-02-2012, 07:46 AM   #5
kcordell
Registered Users
 

Join Date: Aug 2006
Location: St. Louis, Missouri
Default

The software is just finicky with W7. Futaba Japan knows of this issue.
__________________
Team Futaba, Team Miniature Aircraft, Team Flightpower, Radix Blades, VelTye, YS Engines
kcordell is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Futaba Radios and Electronics


Futaba Radios and Electronics Futaba Radios, Gyros, Servos, Etc.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com