Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > YGE


YGE YGE ESC Support and Discussion


Reply
 
Thread Tools Display Modes
Old 04-24-2012, 08:37 PM   #1
Danny_Swe
Registered Users
 
Posts: 1,326
 
My HF Map location
Join Date: Oct 2010
Location: Sweden
Exclamation YGE clone - HeliDrive warning!!!

Today my mate had problem with this YGE-clone from HobbyKing. I bought a YGE 120HV, he bought a HeliDrive 120HV.

So...

1) first the motor failed to start on default settings. We tried to go from auto, to 2%, to 4%, and then it worked at 4%. Have heard issues that some people have never got it to work. Only stands and stutters all over and burn.

2) it lost some settings two times. After we had tried this and that with motor start settings and so on it just suddenly started to stutter again and we checked. It had lost some settings! Strange!

3) so this is the worst thing about it. When we finally got it to work, he hovered a few seconds, made some pitch pumps and then the motor just died!!! From like 4 m up, so he auto'd down and like 20 cm from the ground the motor went on again!!! Scary like hell. I thought he did something but he didn't do anything. It just cut! And no beeps after.

So... I just wanted to put out a warning on this one. It doesn't feel really safe. It's up to you but I think it's worth the money to get the real one.

(I hope I didn't posted bad now, no strange advertising of some products, I'm not affiliated in some way with no brand.)
__________________
550E, X3 | BeastX, YGE, DX8 | Olympus OM-D
http://dannesholk.se/rc.shtml
Danny_Swe is online now        Reply With Quote
Old 04-24-2012, 10:44 PM   #2
Stolla
Registered Users
 

Join Date: Jul 2009
Location: Port Elizabeth South Africa
Default

Quote:
Originally Posted by Danny_Swe View Post
Today my mate had problem with this YGE-clone from HobbyKing. I bought a YGE 120HV, he bought a HeliDrive 120HV.

So...

1) first the motor failed to start on default settings. We tried to go from auto, to 2%, to 4%, and then it worked at 4%. Have heard issues that some people have never got it to work. Only stands and stutters all over and burn.

2) it lost some settings two times. After we had tried this and that with motor start settings and so on it just suddenly started to stutter again and we checked. It had lost some settings! Strange!
Mi
3) so this is the worst thing about it. When we finally got it to work, he hovered a few seconds, made some pitch pumps and then the motor just died!!! From like 4 m up, so he auto'd down and like 20 cm from the ground the motor went on again!!! Scary like hell. I thought he did something but he didn't do anything. It just cut! And no beeps after.

So... I just wanted to put out a warning on this one. It doesn't feel really safe. It's up to you but I think it's worth the money to get the real one.

(I hope I didn't posted bad now, no strange advertising of some products, I'm not affiliated in some way with no brand.)
Just curious, what motor? And does the motor work on other esc? Have seen similar things with 330 Kv scorpion on jive. Some of my mates got some of these as well will be interesting.... I'll just hang onto my jive's
Stolla is offline        Reply With Quote
Old 04-25-2012, 04:26 AM   #3
Danny_Swe
Registered Users
 
Posts: 1,326
Thread Starter Thread Starter
 
My HF Map location
Join Date: Oct 2010
Location: Sweden
Default

Scorpion HKIII-4035-5xx something, on a T700. It worked great on the ICE160HV.
__________________
550E, X3 | BeastX, YGE, DX8 | Olympus OM-D
http://dannesholk.se/rc.shtml
Danny_Swe is online now        Reply With Quote
Old 04-25-2012, 08:58 AM   #4
aviatorflyer
Registered Users
 

Join Date: Sep 2010
Location: midwest
Default

Why didn't he just buy a YGE 120. I just purchased one & set it up with a VBar gov with no issues with the help of this forum & videos.
aviatorflyer is offline        Reply With Quote
Old 04-25-2012, 10:04 AM   #5
Danny_Swe
Registered Users
 
Posts: 1,326
Thread Starter Thread Starter
 
My HF Map location
Join Date: Oct 2010
Location: Sweden
Default

I'm really satisfied with my YGE as well (my two YGE). Well, it was "just" an Align heli so he thought he could buy a cheap setup. Here the talk goes and says these ESC should be good, so he didn't knew better and wanted to try it. Well. Now he knows difficult this. I read in another forum where MrMel said that from 90% of the guys he heard tried this ESC, they experience similar problems, and something more also, the motor could reverse in flight! Hmm... guess HK needs to do something about this! (I like them otherwise, have their LiPo's and PSU's)
__________________
550E, X3 | BeastX, YGE, DX8 | Olympus OM-D
http://dannesholk.se/rc.shtml
Danny_Swe is online now        Reply With Quote
Old 04-25-2012, 07:38 PM   #6
Mystic3D
Registered Users
 
Posts: 4,460
 
My HF Map location
Join Date: Feb 2008
Location: Texas
Default

and why is this in the YGE Forum?
__________________
"If you think you can or you can not you are right"
Goblin Xera 4530, YGE 160,VBar
Trex 700E, YGE 120HV,, Xera 4035/,8917/ VBar
Diablo, HJive, 4525 Ultimate,VBar
Mystic3D is offline        Reply With Quote
Old 04-25-2012, 08:13 PM   #7
aviatorflyer
Registered Users
 

Join Date: Sep 2010
Location: midwest
Default

Amen on this in the YGE forum.
aviatorflyer is offline        Reply With Quote
Old 04-26-2012, 05:22 AM   #8
Danny_Swe
Registered Users
 
Posts: 1,326
Thread Starter Thread Starter
 
My HF Map location
Join Date: Oct 2010
Location: Sweden
Default

I couldn't find a fitting forum. And besides I know some that are interested in the Helidrive check out this YGE-forum for a grasp on how it works, with prog card and so on.

But I apologize if it was wrong forum and please move the thread in that case.
__________________
550E, X3 | BeastX, YGE, DX8 | Olympus OM-D
http://dannesholk.se/rc.shtml
Danny_Swe is online now        Reply With Quote
Old 04-27-2012, 07:45 AM   #9
scottyay
Registered Users
 
Posts: 1,009
 
My HF Map location
Join Date: Jul 2010
Location: NT, Australia
Default

Why wouldn't YGE want people posting in their forum about how much these clones suck. Cause thats pretty much all anyone seems to think of them.
scottyay is offline        Reply With Quote
Old 04-28-2012, 07:19 AM   #10
raptor50luvver
Registered Users
 
Posts: 534
 

Join Date: Mar 2008
Location: UK
Default

My Helidrive 120 works fine in my 700e,stock motor in fact I have five Kontronic Jives rev 9 and I would go as far as to say the Helidrive gov is better,I removed a Jive from the 700e and fitted the Helidrive as a replacement.

As above,was looking in this forum for prog card setup hints as in effect it's the same ESC.

Last edited by raptor50luvver; 04-28-2012 at 08:24 AM..
raptor50luvver is offline        Reply With Quote
Old 04-28-2012, 09:47 AM   #11
Danny_Swe
Registered Users
 
Posts: 1,326
Thread Starter Thread Starter
 
My HF Map location
Join Date: Oct 2010
Location: Sweden
Default

good to hear luvver, seems it depends much on the motor also
__________________
550E, X3 | BeastX, YGE, DX8 | Olympus OM-D
http://dannesholk.se/rc.shtml
Danny_Swe is online now        Reply With Quote
Old 04-28-2012, 11:42 PM   #12
fusionsx00
Registered Users
 

Join Date: Sep 2010
Location: usa
Default

Funny some of those symptoms sound like my first one,

I'm starting to think the only way to get a good working esc is to buy a tried and tested used one off someone you trust. I'm chalking it up to having extremely bad luck.
fusionsx00 is offline        Reply With Quote
Old 05-12-2012, 12:47 PM   #13
prototype3a
Registered Users
 
Posts: 3,335
 
My HF Map location
Join Date: Jun 2006
Location: Christiansburg, VA, USA
Default

My buddy got one of the clones and it seems to be working fine so far. He has one of the 100A LV models. We haven't set up gov store yet. We're just using the basic gov.
__________________
Jeti DS14us -- TT e700 [needs more tail authority] -- Logo600 UL -- Logo500 UL -- MA Furion 450 custom FBL
prototype3a is online now        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > YGE


YGE YGE ESC Support and Discussion

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.