Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
Thread Tools Display Modes
Old 05-07-2012, 11:35 AM   #1
GermanDude
Registered Users
 

Join Date: Oct 2011
Location: Tuscaloosa
Default GY401 Servo Problem

Hey guys,

I have used the B400 Bible to set up my GY401 and Futuba S9257. It is definitely set up correctly.
I just have 2 simple quick questions because I couldn't find any answers when searching for them.

1. When in HH and my helicopter is standing still on my desk, my tail servo (S9257) will move really slow until it hits the limit, now this happens when the helicopter is not moving at all. Is it supposed to do that?

2. in order for my helicopter to be stable my gain is set to about 85. That's a tad high. I believe I had to set it on 85 because of some vibration. Is it correct that with less vibration I can lower my gain?

Edit: I guess it would be helpful for you to know what I'm trying to do: When I first setup my GY401 S9254 it was perfect, no drift and it was holding great. 2 months later and I can't set my gain lower than 80 and it drifts to the left. I read all the threads about drifts, so I will try to add a second layer of tape for the GY401. This is how I understand it: I have bad vibrations that I can't see which causes me to increase the gain to 85. Once I eliminate all vibrations it will be perfect again.

All that doesn't explain why the servo moves when standing still.
GermanDude is offline        Reply With Quote
Old 05-07-2012, 11:58 PM   #2
Luvmyhelis
Registered Users
 
Posts: 9,653
 

Join Date: Jul 2010
Location: spokane,washington
Default

All heading hold gyros will cause the servos to drift when setting still. This comes from the nature of an HH gyro that is trying to predict drift and compensate by giving the servo directions. When it doesn't "sense" any corrections, it keeps giving the servo commands util it "feels" the correction. When setting still, it wont see any tail corrections so it will continue giving the servo commands until it is at full travel.

Vibrations, on a heli that is vibe free you can usually run a tad more tail gain as there are fewer vibes to mess with the gyro. But tail gain is not simple to predict. Lots of times it has more to do with the interplay between the gyro and servo (such as how fast the servo responds) The better the servo the more gain you can run. Also mass has an effect. The heavier the tail/or heli, the more gain you can effectively run. I have a current Gy401 running at almost 88 gain and still feel there is room for slighty more.
So, don't go so much by the numbers. But by what works on your heli.
__________________
Jeti, 800Triabolo, SHS Gob800 & 700, Trex600,Chase Sk720B/540/360 YGE/YEP/MKS/Outrage/Turnigy RcTek Boca Herc/Gryphon/ScottGray Scorp/KDE/Kontronik Tenax Lynx
Luvmyhelis is offline        Reply With Quote
Old 05-08-2012, 08:55 AM   #3
GermanDude
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2011
Location: Tuscaloosa
Default

Great explanation, thank you.

just making sure I understood. when I have bad vibes I raise my gain?

Reason I'm asking: I had bad tail vibes when I originally installed the 401, set gain to 65 and it flew great. 2 months later I changed out the bearings to get rid of the vibes and now I can't set it lower than 85 and it slightly drifts. It seems as if the 401 performed better with vibes.

Sent from my SGH-I777 using Tapatalk 2
GermanDude is offline        Reply With Quote
Old 05-08-2012, 09:56 AM   #4
Luvmyhelis
Registered Users
 
Posts: 9,653
 

Join Date: Jul 2010
Location: spokane,washington
Default

No, it is the opposite. Bad vibes will mess with the gyro so you have to either clean up the vibes or reduce gain/sensitivity. Sounds to me like you now have a lazy tail response, this is mechanical or servo related.
__________________
Jeti, 800Triabolo, SHS Gob800 & 700, Trex600,Chase Sk720B/540/360 YGE/YEP/MKS/Outrage/Turnigy RcTek Boca Herc/Gryphon/ScottGray Scorp/KDE/Kontronik Tenax Lynx
Luvmyhelis is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com