Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 100 Class Electric Helicopters


100 Class Electric Helicopters 100 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 06-20-2012, 11:21 PM   #1
kramerr
Registered Users
 
Posts: 156
 

Join Date: Feb 2009
Location: Calgary, Alberta (Canada)
Default T-Rex 100 Swashplate Issue

I recently bought a T-Rex 100X. In attempting to fly this heli, I noticed that when I move the cyclic stick forward, the swashplate does not drop forward like on my T-Rex 250. It drops at an angle instead. It appears that the sticks don't move up/down/left/right like a normal transmitter (and same with the iPad/iPod A5 transmitter). Rather, they are set to move diagonally. I am wondering if this is normal or if I have a faulty controller board.......

__________________
T-Rex 700E / T-Rex 600N / T-Rex 600ESP / T-Rex 550E
T-Rex 500ESP / T-Rex 500 DFC / T-Rex 450 Pro / T-Rex 450SA
T-Rex 250 / T-Rex 100 / Blade mCPx / Blade mCX
MAAC: 80309
kramerr is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 100 Class Electric Helicopters


100 Class Electric Helicopters 100 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.