Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > 130X


130X Blade 130X Helicopters Information and Help


Reply
 
Thread Tools Display Modes
Old 08-18-2012, 04:40 PM   #1
adelmasw
Registered Users
 
Posts: 568
 
My HF Map location
Join Date: Dec 2006
Location: Ohio
Default How to change the Elev. Cyclic Servo?

My elevator cyclic servo quit and HH is sending me a new one. So do you have to take the frames apart to get this in? What is the best way to replace it? Or is it just going to be a big PITA to do it?
__________________
~ S Adelman
adelmasw is offline        Reply With Quote
Old 08-18-2012, 04:43 PM   #2
lovespicyfood
Registered Users
 

Join Date: Dec 2006
Location: Westlake Village, CA
Default

I've heard you have to split the frame
lovespicyfood is offline        Reply With Quote
Old 08-18-2012, 05:02 PM   #3
merch@nt
Registered Users
 
Posts: 239
 

Join Date: Oct 2011
Location: Scotland
Default

Yup you have to split the frame.
merch@nt is offline        Reply With Quote
Old 08-18-2012, 05:22 PM   #4
adelmasw
Registered Users
 
Posts: 568
Thread Starter Thread Starter
 
My HF Map location
Join Date: Dec 2006
Location: Ohio
Default

Thanks for the info. I was afraid of that....

Sent from my DROID RAZR using Tapatalk 2
__________________
~ S Adelman
adelmasw is offline        Reply With Quote
Old 08-18-2012, 11:35 PM   #5
chuck-o
Registered Users
 

Join Date: Feb 2012
Location: Fitchburg Ma.
Default

And don't forget to put the pushrod back on the servo before you screw the frame back together.
chuck-o is offline        Reply With Quote
Old 08-19-2012, 07:28 AM   #6
Mentalic
Registered Users
 
Posts: 1,769
 
My HF Map location
Join Date: Apr 2008
Location: Louisiana
Default

Quote:
Originally Posted by lovespicyfood View Post
I've heard you have to split the frame
+1

Just cleaned all my servos feedback pots last night and yes its a pita!
Remove the gear, pull off the canopy mount on the screw side of the frames, remove the frame screws. It can be done without unplugging all the servos if your carefull.
__________________
Wayne Armstrong

Team Mikado USA
Logo 480 / Logo 600sx / Logo Uvular / Logo 700 / Vbar Control
Mentalic is offline        Reply With Quote
Old 08-19-2012, 07:31 AM   #7
NCcraig
Registered Users
 
Posts: 9,260
 

Join Date: Mar 2011
Location: North Carolina
Default

Quote:
Originally Posted by adelmasw View Post
Thanks for the info. I was afraid of that....

Sent from my DROID RAZR using Tapatalk 2
What are you afraid of?
__________________
Team Newb pilot
Trex 450 Pro V2 (KDE450XF motor,iKON),Trex 500 ESP (KDE500XF motor, iKON), Witespy HT450, NQX, DX9, AMA# 966513.
NCcraig is offline        Reply With Quote
Old 08-19-2012, 07:47 AM   #8
Chris Gardill
Registered Users
 
Posts: 573
 

Join Date: Feb 2012
Location: Wheeling, WV USA
Default

Quote:
Originally Posted by chuck-o View Post
And don't forget to put the pushrod back on the servo before you screw the frame back together.
This is timeless advice.


Sent from my iPad using Tapatalk HD
__________________
Synergy E5 (6S, Scorpion 4025-1100, Ikon, Futaba BLS451/452); Gaui X3 (6S, KDE 450XF-1750, iKon); 450X; Blade 350QX; TRex 250 Pro DFC.
Chris Gardill is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > 130X


130X Blade 130X Helicopters Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com