Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Align 3G FBL System > Align 3GX FBL System


Align 3GX FBL System Align 3GX FBL Flybarless System Software and Hardware Support


Reply
 
Thread Tools Display Modes
Old 10-11-2013, 12:26 AM   #1
HighVoltage450
Clone of dwdw910
 

Join Date: Oct 2013
Location: United States
Default 4.0 Fix For Tail Problems

A few people here have mentioned this- I made this thread to spread the word.

If your tail will not lock, wanders or wags- here is the fix. 4.0 is great so it's worth the effort. I received this advice directly from a representative at Align and it solved all my tail problems.

1. Flash to 4.0

2. Use the software while connected to USB to visually watch the Rudder Delay Slider
- Hold set button on 3GX for two seconds
- Toggle through to get to Rudder Delay
- Set red or green to your size bird ( I use the red for my 450)
- Use the rudder stick to get the Rudder Delay Value to 0. Its kind of tricky- you just barely tap it
- LET THE UNIT TIME OUT

3. You should now see the Rudder Delay Value read 0 in the software

4. You may now need to adjust the Rudder Lock Gain down as far as 30... this will vary

5. Go through setup again with the blades at 0 pitch and main shaft square to planet earth

6. Make sure you leave DIR mode with the helicopter level and the blades at 0 pitch!

5. Enjoy 4.0 Its definitely the best yet... Pitch pumps are more stable among other improvements.

Last edited by HighVoltage450; 10-11-2013 at 04:59 PM..
HighVoltage450 is offline        Reply With Quote
Old 10-11-2013, 12:46 PM   #2
HighVoltage450
Clone of dwdw910
Thread Starter Thread Starter
 

Join Date: Oct 2013
Location: United States
Default

I flew around on 4.0 with some more tuning and noted a few more things.

I have the DFC Pro 450 by the way.

-My Rudder Delay is 0
-My Rudder Lock Gain Value is 65
-My Gyro TX is at 50% Futaba 6J

Anyway, 4.0 is butter smooth and more organic. It definitely flies more stable and everything just feels smoother.

The only thing you may not like or have to get used to- is that the rudder has a more rubber feel to it. On 3.1 it would lock and snap like a robot... Like the terminator.

On 4.0, the tail will hold and lock... its just smoother. At first I really didn't like the feel of it. It feels so different than 3.1 when you just hover around. Once you get in the air and start whipping around- you'll see why its better.

Overall, its definitely an improvement. Great update.

Last edited by HighVoltage450; 10-11-2013 at 06:29 PM..
HighVoltage450 is offline        Reply With Quote
Old 10-19-2013, 11:03 AM   #3
CrashNburn420
Registered Users
 
Posts: 3,301
 

Join Date: May 2012
Location: USA
Default

Are you changing the rudder lock in the software, on the 3gx or with the radio? I set mine up like you said here and it flew really well this morning. It may be that it just flies a little different than 3.1?

edit: I flew 6 more batteries through it this afternoon, only thing off that I noticed was with right rudder input it still bounces back slightly. Left rudder is locked in.

Last edited by CrashNburn420; 10-19-2013 at 02:15 PM..
CrashNburn420 is offline        Reply With Quote
Old 10-19-2013, 03:40 PM   #4
HighVoltage450
Clone of dwdw910
Thread Starter Thread Starter
 

Join Date: Oct 2013
Location: United States
Default

You adjust the rudder delay value with the set button WHILE you are plugged into the software.

This way allows you to actually get the rudder delay to zero instead of guessing and checking while programming with the set button and TX.

If you have a bounce still.... Try turning your rudder locking gain value down ONE click at a time.

It is very sensitive and one click in the software can solve the bounce while still keeping the tail locked in heading.

The rudder on 4.0 is far different than 3.1

Its way better in actual flight but it isn't perfect in hover.

Perhaps in the next update, Align can find the best attributes of 3.1 and 4.0 rudder performance.

As a whole though, 4.0 is ridiculously good. The 3GX is as good or better than any gyro out there.
HighVoltage450 is offline        Reply With Quote
Old 10-20-2013, 02:10 AM   #5
billryalls
Registered Users
 

Join Date: Mar 2012
Location: washington state
Default

your not saying you have to flash to 4.0 to be able to set rudder delay to 0, right, as I JUST did that on my trex450 3gx with 3,1 Im now searching forums (why i found this thread) looking for answers as to why my heli at about 40% throttle acts like I just hit HARD RIGHT on my stick and then any correction sends it HARD the other way, Ive been though all the videos, set the delay, yadda yadda yadda and still wants to spin before lift argh
billryalls is offline        Reply With Quote
Old 10-20-2013, 11:44 AM   #6
HighVoltage450
Clone of dwdw910
Thread Starter Thread Starter
 

Join Date: Oct 2013
Location: United States
Default

No, flashing to 4.0.... I just meant that you do the update.


Edit...


You are saying that the helicopter spins around upon lift off? on the Rudder/Yaw axis?

In that case, your gyro is just programmed backwards. Read about gyro reversal setting in the manual.
HighVoltage450 is offline        Reply With Quote
Old 10-27-2013, 11:33 PM   #7
TOD022
Registered Users
 

Join Date: Sep 2012
Location: New york
Default 4.0 rudder issues

1. Flash to 4.0

2. Use the software while connected to USB to visually watch the Rudder Delay Slider- Hold set button on 3GX for two seconds- Toggle through to get to Rudder Delay- Set red or green to your size bird ( I use the red for my 450)- Use the rudder stick to get the Rudder Delay Value to 0. Its kind of tricky- you just barely tap it- LET THE UNIT TIME OUT

3. You should now see the Rudder Delay Value read 0 in the software

4. You may now need to adjust the Rudder Lock Gain down as far as 30... this will vary

5. Go through setup again with the blades at 0 pitch and main shaft square to planet earth6. Make sure you leave DIR mode with the helicopter level and the blades at 0 pitch!5. Enjoy 4.0 Its definitely the best yet... Pitch pumps are more stable among other improvements.






I have an align 550e and have recently updated my 3GX to version 4.0. The problem that I am experiencing is that my rudder keeps bouncing back after running through the setup procedure. When I give it right or left rudder it bounces back to the center as if the heading hold is turned off. I have followed the above instructions posted by user name HighVoltage450. I was able to set my rudder delay value to 0. I just haven't figured out how to adjust my rudder lock gain. The rudder lock gain is currently set to 70.

Can someone point me in the right direction? I would really appreciate it.
TOD022 is offline        Reply With Quote
Old 10-28-2013, 02:32 PM   #8
CrashNburn420
Registered Users
 
Posts: 3,301
 

Join Date: May 2012
Location: USA
Default Re: 4.0 Fix For Tail Problems

Mine is also doing the bounce back still but only with right rudder input. My fix is to dump 4.0 and go back to 3
CrashNburn420 is offline        Reply With Quote
Old 10-28-2013, 03:09 PM   #9
nameci
Registered Users
 

Join Date: Nov 2011
Location: Lake Zurich, IL
Default

Tail bounce is when you test this on the bench, correct? (like that of rate mode setting we are familiar with)

I have not seen any negative issue in the air. I'm wondering if Align added this functionality for reducing issues during take off.

Quote:
Originally Posted by TOD022 View Post
1. Flash to 4.0

2. Use the software while connected to USB to visually watch the Rudder Delay Slider- Hold set button on 3GX for two seconds- Toggle through to get to Rudder Delay- Set red or green to your size bird ( I use the red for my 450)- Use the rudder stick to get the Rudder Delay Value to 0. Its kind of tricky- you just barely tap it- LET THE UNIT TIME OUT

3. You should now see the Rudder Delay Value read 0 in the software

4. You may now need to adjust the Rudder Lock Gain down as far as 30... this will vary

5. Go through setup again with the blades at 0 pitch and main shaft square to planet earth6. Make sure you leave DIR mode with the helicopter level and the blades at 0 pitch!5. Enjoy 4.0 Its definitely the best yet... Pitch pumps are more stable among other improvements.






I have an align 550e and have recently updated my 3GX to version 4.0. The problem that I am experiencing is that my rudder keeps bouncing back after running through the setup procedure. When I give it right or left rudder it bounces back to the center as if the heading hold is turned off. I have followed the above instructions posted by user name HighVoltage450. I was able to set my rudder delay value to 0. I just haven't figured out how to adjust my rudder lock gain. The rudder lock gain is currently set to 70.

Can someone point me in the right direction? I would really appreciate it.
nameci is online now        Reply With Quote
Old 10-28-2013, 06:17 PM   #10
TOD022
Registered Users
 

Join Date: Sep 2012
Location: New york
Default 4.0 rudder issues

@ Crashnburn420, I reverted back to version 2.1 that I've been using for the past year. I haven't had any issues with this version. Is there anyone who has successfully upgraded to 4.0? If you have, does the rudder bounce back to the center after giving it left/right rudder? If so, have you been able to successfully achieve hover without the heli wanting to spin out before take off? Have you flown successfully?

As Nameci mention, did align add this feature for reducing issues? Or does the software work for some and not for others?

TOD022 is offline        Reply With Quote
Old 10-28-2013, 06:43 PM   #11
TOD022
Registered Users
 

Join Date: Sep 2012
Location: New york
Default 4.0 rudder issues

@ Highvoltage450, How do you access the rudder locking gain? I connected the 3GX to the computer via the usb cable. I am able to view rudder parameters. My rudder locking gain is at the default 70. I am not sure how to adjust it.
TOD022 is offline        Reply With Quote
Old 10-28-2013, 09:03 PM   #12
HighVoltage450
Clone of dwdw910
Thread Starter Thread Starter
 

Join Date: Oct 2013
Location: United States
Default

Just take your mouse and click/hold the slider icon and adjust parameter. Or use the the plus minus buttons.

If you hold the mouse pointer over the slider bar- an icon will appear a few seconds later and describe how the parameter is adjusted correctly.

I think you said you have a 550 class helicopter? Im not sure your rudder delay should be 0 with helicopter that size. I would check with others in that forum class.
HighVoltage450 is offline        Reply With Quote
Old 10-29-2013, 12:27 AM   #13
jimmanyk
Registered Users
 

Join Date: Mar 2008
Location: England
Default

Quote:
Originally Posted by TOD022 View Post
1. Flash to 4.0

2. Use the software while connected to USB to visually watch the Rudder Delay Slider- Hold set button on 3GX for two seconds- Toggle through to get to Rudder Delay- Set red or green to your size bird ( I use the red for my 450)- Use the rudder stick to get the Rudder Delay Value to 0. Its kind of tricky- you just barely tap it- LET THE UNIT TIME OUT

3. You should now see the Rudder Delay Value read 0 in the software

4. You may now need to adjust the Rudder Lock Gain down as far as 30... this will vary

5. Go through setup again with the blades at 0 pitch and main shaft square to planet earth6. Make sure you leave DIR mode with the helicopter level and the blades at 0 pitch!5. Enjoy 4.0 Its definitely the best yet... Pitch pumps are more stable among other improvements.






I have an align 550e and have recently updated my 3GX to version 4.0. The problem that I am experiencing is that my rudder keeps bouncing back after running through the setup procedure. When I give it right or left rudder it bounces back to the center as if the heading hold is turned off. I have followed the above instructions posted by user name HighVoltage450. I was able to set my rudder delay value to 0. I just haven't figured out how to adjust my rudder lock gain. The rudder lock gain is currently set to 70.

Can someone point me in the right direction? I would really appreciate it.
Check tail rod length - rate mode, move in a hole on the servo horn, Rudder Locking Gain 40, delay to 0, increased the gyro gain - still there but much better on my 500.
__________________
Trex :- 450SE V2 retired, 250SC retired, 450 PRO fbled Airwolfed, 500 ESP fbled Airwolfed, 250DFC, 450DFC, 500DFC, 800DFC - Futaba/Align. Blade :- 4003D retired,CX2, MQX - spektrum. 4503D, 450X - spektrum/Savox.
jimmanyk is offline        Reply With Quote
Old 10-29-2013, 09:58 AM   #14
TOD022
Registered Users
 

Join Date: Sep 2012
Location: New york
Default 4.0 rudder issues

Highvoltage450, thank you. I'll check the forum to see if anyone with the 550 class helicopter is experiencing similar issues.

TOD022 is offline        Reply With Quote
Old 11-05-2013, 10:26 AM   #15
Randmental
Registered Users
 

Join Date: Oct 2012
Location: Pretoria, South Africa
Default

I have upgraded both my 250 DFC and 600EFL to version 4.0 and re-done the setups.
I have really no issues on either - tails are rock solid even with a 10m pitch pump and pirouettes.

I have the delay on the ail gyro 0 and the locking gain at the default 70 for both.

Pots are set to show the same value on the software, 90 for the 250 and 110 for the 600e; the rest are all default (except of the small/large heli setting and the torque comp. on the 250 that it is mounted upside down.
Randmental is offline        Reply With Quote
Old 11-15-2013, 02:11 PM   #16
Grumpy_Old_Man
Registered Users
 

Join Date: Nov 2013
Location: Aberdeen, UK
Default

Quote:
Originally Posted by HighVoltage450 View Post
2. Use the software while connected to USB to visually watch the Rudder Delay Slider
- Hold set button on 3GX for two seconds
- Toggle through to get to Rudder Delay
- Set red or green to your size bird ( I use the red for my 450)
- Use the rudder stick to get the Rudder Delay Value to 0. Its kind of tricky- you just barely tap it
- LET THE UNIT TIME OUT
Thanks for the tip. the 'LET THE UNIT TIME OUT' is the key. If you press the button again like it says to do in the instructions then it defaults back to some positive value and you can never get it to zero.
Grumpy_Old_Man is offline        Reply With Quote
Old 12-09-2013, 03:01 PM   #17
The Mechanic
Registered Users
 
Posts: 185
 

Join Date: Nov 2012
Location: Carol Stream, Illinois, USA
Default Awesome fix

HighVoltage 450 youíre my hero! In my humble opinion this thread should be a sticky with a big red flashing light!

Iíve been chasing a tail wag problem since I built the 450 pro and started flying it in April or May. Iím using the stock 3GX gyro with v3.1 firmware. I kept v3.1 and set the Rudder Lock Gain to 50 from 70. Set the Rudder Delay to zero and Bobís you uncle!!!

Went out yesterday and no wag at all even during high speed passes and pitch pumps. Like I said Iíve been working on this problem for months and was this close to buying a Mini V-Bar and a new tail gyro. You saved me $300. Thanks!
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
The Mechanic is offline        Reply With Quote
Old 12-09-2013, 03:32 PM   #18
nameci
Registered Users
 

Join Date: Nov 2011
Location: Lake Zurich, IL
Default

Quote:
Originally Posted by The Mechanic View Post
HighVoltage 450 you’re my hero! In my humble opinion this thread should be a sticky with a big red flashing light!

I’ve been chasing a tail wag problem since I built the 450 pro and started flying it in April or May. I’m using the stock 3GX gyro with v3.1 firmware. I kept v3.1 and set the Rudder Lock Gain to 50 from 70. Set the Rudder Delay to zero and Bob’s you uncle!!!

Went out yesterday and no wag at all even during high speed passes and pitch pumps. Like I said I’ve been working on this problem for months and was this close to buying a Mini V-Bar and a new tail gyro. You saved me $300. Thanks!
Sounds like your issue is due to too high of tail gyro gain on the transmitter programmed, not the same issue that OP's suggestion for V4.0 related tail issue.

I'm not sure what transmitter you are using but if your transmitter HH is 0-100 and you were using 70, it was way too high. People who are referring to 70-75% tail gyro gain for initial set up is referring to the setting for transmitter that uses 50% to 100% for HH(i.e. DX7, DX6i, X9303/9503)
nameci is online now        Reply With Quote
Old 12-09-2013, 04:52 PM   #19
The Mechanic
Registered Users
 
Posts: 185
 

Join Date: Nov 2012
Location: Carol Stream, Illinois, USA
Default

namci,
The gain setting the OP is referring to is set in the software on the computer connected to the 3GX. Itís on the ďRudder ParametersĒ tab if I remember correctly; Rudder Locking Gain. It doesnít have anything to do with the gain settings in the TX. I donít ever remember paying any attention to it before until I read this post suggesting how to set it to a better value than the factory default of 70. For me, like I said, 50 works fine along with a Rudder Delay setting of zero.

Apparently this setting is as effective in v3.1 as it is in the new v4.0 as I havenít flashed to v4.0 yet. In fact, I may never flash to a newer firmware ever. As they say ďif it ainít broke.Ē I just got it working right Iím not anxious to tamper.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
The Mechanic is offline        Reply With Quote
Old 12-09-2013, 05:21 PM   #20
nameci
Registered Users
 

Join Date: Nov 2011
Location: Lake Zurich, IL
Default

Sorry, I read it as you have reduced your TX tail gain.

This information was posted by many different members, as an work around for those were having issues after they have upgraded to 3GX to V4.0 where same heli did not have issue on V3.1/V3.0. And this was to address the tail bounce issue. This set up on PC program was not needed to be changed for majority of the people prior to V4.0.

If this change fixed your problem, that's great. But if you had to change this setting to get rid tail wag on your 450 on V3.1 software, there is something else that may be causing the wag in first place. For V3.1, I would highly recommend getting all the software parameter to default and isolate the mechanical problem first before start messing around the PC software parameter.

BTW OP, HighVoltage450, is a clone acct of dwdw510 who has been banned for life from HF.
nameci is online now        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Align 3G FBL System > Align 3GX FBL System


Align 3GX FBL System Align 3GX FBL Flybarless System Software and Hardware Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com